Issue 127538

Summary: SV translation: "Basic" mistranslated as "grundläggande"
Product: Native-Lang Reporter: Kai-Mikael Jää-Aro <Kai-Mikael.Jaa-Aro>
Component: svAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: jim, knmc, mseidel, oooforum, pescetti
Version: 4.1.3Flags: jim: 4.1.4_release_blocker+
Target Milestone: 4.1.4   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: Easy
Attachments:
Description Flags
Screenshot of mistranslated menu none

Description Kai-Mikael Jää-Aro 2017-09-16 07:44:58 UTC
In the menu option Verktyg->Makron->Organisera Makron->OpenOffice grundläggande… someone has missed that “Basic” refers to the programming language Basic, not the concept of basic functions.  This threw me for a loop when I was looking for Basic programming.

Thus, the option should be Verktyg->Makron->Organisera Makron->OpenOffice Basic…
Comment 1 Marcus 2017-09-17 15:28:16 UTC
Thanks for your report.

I've marked it with target 4.2.0, then we hopefully don't miss this issue.
Comment 2 oooforum (fr) 2017-09-26 12:16:31 UTC
Could you precise what is the language impacted?

Please submit your suggestions directly on Pootle
https://translate.apache.org/projects/aoo40/
This string is localized at:
officecfg/registry/data/org/openoffice/Office/UI.po
Comment 3 oooforum (fr) 2017-09-26 12:28:46 UTC
I checked this string.
Seems to be fine:
https://translate.apache.org/sv/aoo40/translate/officecfg/registry/data/org/openoffice/Office/UI.po#unit=15565390

Could you provide a screenshot of this menu?
Comment 4 Kai-Mikael Jää-Aro 2017-09-26 20:12:30 UTC
Created attachment 86218 [details]
Screenshot of mistranslated menu
Comment 5 Kai-Mikael Jää-Aro 2017-09-26 20:13:35 UTC
The language concerned is Swedish (language code “sv”).  Attached screenshot of the mistranslated menu.
Comment 6 oooforum (fr) 2017-09-27 11:15:40 UTC
As said in my comment 3, this string is correctly translated since 4 years ago.
So, I don't understand why AOO 4.1.3 don't embedded this.
Comment 7 oooforum (fr) 2017-09-27 16:30:38 UTC
Could you try the following build?
https://dist.apache.org/repos/dist/dev/openoffice/4.1.4-RC4/binaries/sv/
And make a feedback.
Comment 8 Kai-Mikael Jää-Aro 2017-09-27 20:14:40 UTC
Installed it + associated language pack.  The menu is still mistranslated in the same way.
Comment 9 Marcus 2017-09-27 20:19:49 UTC
Issue confirmed, see comment #8
Comment 10 Andrea Pescetti 2017-09-28 19:45:40 UTC
The explanation is in our release workflow:

1. Version 4.1.x only contains specific localization changes that were explicitly requested (not this one). No Pootle synchronization was done; not because of laziness, but because Pootle is aligned with the trunk=4.2.x strings and a mass-import can't be done on 4.1.x due to moved/changed strings.

2. Importing localization work from Pootle is one of the many good reasons why we should focus on 4.2.0 as soon as 4.1.4 is out of the door. Updating translations from Pootle WILL be part of the release in that case.

So it's good to keep this one targeted to 4.2.0 as it is now.
Comment 11 SVN Robot 2017-10-03 14:20:39 UTC
"mseidel" committed SVN revision 1811013 into trunk:
#i127538# Corrected wrong translation for "Basic" (same as in Pootle)
Comment 12 Marcus 2017-10-03 15:13:41 UTC
Thanks fo the commit, I've set the status to FIXED for the moment
Comment 13 Jim Jagielski 2017-10-11 12:11:57 UTC
Thx. Folded into 4.1.4-RC5 (and 4.1.5)