Issue 127558

Summary: General Error while opening an existing .odt file in 4.1.4-RC5 on MacOS X
Product: Build Tools Reporter: Andrea Pescetti <pescetti>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Critical    
Priority: P2 CC: jim, mseidel, truckman
Version: 4.1.4-dev   
Target Milestone: 4.1.4   
Hardware: All   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Andrea Pescetti 2017-10-17 18:50:33 UTC
Opening an existing .odt file is broken in OpenOffice 4.1.4-RC5 as reported on the dev list.

The file opens, but a "General Error" dialog box appears.

This has been confirmed both on Mac OS X 10.12 and 10.13.

Some users, though, reported they can open files normally.

The issue has some similarity to https://bz.apache.org/ooo/show_bug.cgi?id=127315 but nobody could reproduce it on Linux.64 with 4.1.4-RC5.
Comment 1 Andrea Pescetti 2017-10-17 18:51:48 UTC
As reported on the dev list, this is now fixed with a full rebuild of convenience binaries for Mac without any code changes. Leaving open for documentation.
Comment 2 Jim Jagielski 2017-10-17 19:44:37 UTC
Ensure that the libxml2 library being used is the one provided by the macOS SDK and not 3rd party when building. This was triggered when the expat module was built and used/required a null LOADLIBOBJFILE. This can be forced via --with-system-libxml
Comment 3 Don Lewis 2017-10-17 20:44:12 UTC
I'm curious about why --with-system-expat is not used on macOS.