Issue 127699

Summary: Hyphenization does not work
Product: Writer Reporter: Gerhard Schmidt <info>
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Critical    
Priority: P5 (lowest) CC: oooforum, petko
Version: 4.1.5   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Test document that should do Zeilentrennung. none

Description Gerhard Schmidt 2018-02-11 16:38:36 UTC
Created attachment 86347 [details]
Test document that should do Zeilentrennung.

Hyphenization (Zeilentrennung) does not work, neither under Linux nor under Windows. Even if enabled in the general properties and on the style level and on the current text paragraph level. It says it is but it isn't.

At least 4.1.4 also had this strange behaviour, that worked fine in older OpenOffice versions.

This is a dramatic error as I work with 300 page documents and doing soft-hypenization is a real mass. 

brgs,
gerhard
Comment 1 oooforum (fr) 2018-02-11 17:23:53 UTC
Already reported

*** This issue has been marked as a duplicate of issue 121930 ***
Comment 2 Gerhard Schmidt 2018-02-14 17:51:50 UTC
How come that this issue was reported several times over at least four years long and was not fixed as it should? It would be simple to delete the user's profile when a new version is installed, thereby overwriting all this stuff. If you want to be generous you can add a question in the uninstall procedure.

brgs,
gerd
Comment 3 Peter 2018-02-15 06:32:37 UTC
Because reporting the issue is not enough. It needs a volunteer who does the job.

For a proper fix we need imho to overhaul the profile management and make it more sturdy.
This I not so easy as it seem.

You are of course welcomed to try to add the option to the installer if you like.
Or try to review the code so it becomes more sturdy. Just write a mail to recruitment@openoffice.apache.org with your skill and what you want to do. We try to guide you.

We have other topics too. There are like 3000 issues that need to be retested or fixed.
And we are still at preparing the release that contains the development of the last years.
So existing volunteers are busy.

I hope that clarifies the situation to you.