Issue 127783

Summary: Crash when opening any PPT file
Product: Impress Reporter: Pedro <pedlino>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Major    
Priority: P2 CC: jim, mechtilde, mseidel, petko
Version: 4.2.0-devKeywords: crash, regression
Target Milestone: 4.2.0Flags: jim: 4.2.0_release_blocker+
Hardware: PC   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Sample PPT file for testing but crash occurs with any PPT none

Description Pedro 2018-05-29 09:03:05 UTC
Created attachment 86428 [details]
Sample PPT file for testing but crash occurs with any PPT

All PPT files crash AOO 4.2.0 on opening on my Windows 7 x64 machine (tested with  Rev. 1831525 from mseidel and also with Rev. 1832057 from the Buildbot)

There is no problem with ODP or PPTX.


This is a confirmed (by mseidel) regression from 4.1.5
Comment 1 Matthias Seidel 2018-05-30 16:41:31 UTC
Confirmed with every PPT I tried.
Even if you save an ODP as PPT and then try to open it AOO crashes.

This seems to be Windows only.
Comment 2 Pedro 2018-06-04 11:05:55 UTC
Further details: if another file has already been open (e.g. an ODS file) even if it is closed before opening a PPT file then AOO will not crash.
The crash occurs if AOO is open without any file been previously opened or when AOO is closed (open by file association)
Comment 3 Pedro 2019-10-24 19:36:33 UTC
Crash still occurs every time under Windows 7 x64 with Matthias' build
AOO420m2(Build:9821)  -  Rev. d08390903b
2019-10-22 20:51 - CYGWIN_NT-10.0 x86_64 - Development Test Build
Comment 4 Peter 2020-01-18 17:00:01 UTC
I have tried today with my Linux build based on trunk and it did work. Is it a Windows only Issue or is it specific to 4.2.0 and Trunk it works?

I will check if I can do a windows build in the next days.

(Sidenote: When opening a ppt, I get tons of Assertion errors.)
Comment 5 Matthias Seidel 2020-01-18 17:30:51 UTC
I am pretty sure that this is Windows only,

And it is a regression, so trunk and 4.2.0 are broken.