Issue 127887

Summary: update bundled redland/raptor/rasqal
Product: General Reporter: Don Lewis <truckman>
Component: codeAssignee: AOO issues mailing list <issues>
Status: RESOLVED FIXED QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: mseidel, petko
Version: 4.1.6-dev   
Target Milestone: 4.1.8   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---

Description Don Lewis 2018-09-10 17:06:52 UTC
These trunk commits should be merged to AOO416 to upgrade the bundled versions of:
  redland 1.0.8 -> 1.0.17
  raptor 1.4.18 -> 2.0.15
  rasqal 0.9.16 -> 0.9.33

  https://svn.apache.org/viewvc?view=revision&revision=1701344
  https://svn.apache.org/viewvc?view=revision&revision=1757789
  https://svn.apache.org/viewvc?view=revision&revision=1805089
  https://svn.apache.org/viewvc?view=revision&revision=1818098

svn merge -c 1701344 '^/openoffice/trunk/main/redland' main/redland
svn merge -c 1757789 '^/openoffice/trunk' .
svn merge -c 1805089 '^/openoffice/trunk' .
 and apply configure.ac changes to configure.in
svn merge -c 1818098 '^/openoffice/trunk' .

Tested in 4.1.6 on 32-bit Windows 7 and CentOS 6 x86_64.
Comment 1 Peter 2018-09-16 09:26:27 UTC
Accepted for 4.1.6
Comment 2 Peter 2018-10-08 06:13:26 UTC
merged in: Issue 127887 - update bundled redland/raptor/rasqal with revision 1843108
Comment 3 Matthias Seidel 2018-10-09 13:27:37 UTC
(In reply to Don Lewis from comment #0)

...
> svn merge -c 1805089 '^/openoffice/trunk' .
>  and apply configure.ac changes to configure.in
...

These changes in configure.in seem to break the build process:
https://ci.apache.org/builders/openoffice-linux64-41x/builds/159/steps/configure/logs/stdio
Comment 4 Matthias Seidel 2018-10-13 16:26:29 UTC
Revoked with r1843571.

I am not sure about the changes in configure.in.
Do we really want to have macOS 10.9 as a minimum in 4.1.x?

I think this was only planned in trunk and Jim took back the changes shortly after...
Comment 5 Don Lewis 2018-10-15 22:14:10 UTC
Sounds like someone with MacOS access needs to create new patches for configure.in if they are really needed for this to build on the Mac.
Comment 6 Matthias Seidel 2018-10-15 22:22:01 UTC
That's the problem. I don't think the changes in configure.in are really needed (or useful) for 4.1.6.

We should ask Jim to have a look...
Comment 7 Matthias Seidel 2019-09-28 12:16:58 UTC
Maybe we should give this one another try for AOO 4.1.8?
Comment 8 Peter 2019-10-01 11:10:04 UTC
Yes we should
Comment 9 Matthias Seidel 2020-09-27 20:24:49 UTC
Committed to AOO418 as part of:

https://github.com/apache/openoffice/pull/94