Issue 127924

Summary: Inserting Sound or Video kills AOO
Product: General Reporter: jmpoo <jmpoo-bugz>
Component: uiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: mseidel, petko
Version: 4.1.6-dev   
Target Milestone: ---   
Hardware: PC   
OS: Linux 64-bit   
See Also: https://bz.apache.org/ooo/show_bug.cgi?id=127925
Issue Type: DEFECT Latest Confirmation in: 4.1.6
Developer Difficulty: ---

Description jmpoo 2018-10-23 17:34:53 UTC
Linux Mint 18.3 AOO 4.1.6_RC1_Rev. 1844227

Open i.e. Impress
Insert a second slide
Insert any sound or video file on this slide
The file is inserted and the media toolbar is shown
klick the first slide

AOO is closed immediately

Same in Writer, Calc and Draw
Comment 1 Matthias Seidel 2018-10-23 17:40:22 UTC
Again:

Rev. 1844227 is *not* RC1
Comment 2 jmpoo 2018-11-02 14:53:43 UTC
Sorry for confusion.

Tried it again with the now released RC1 AOO416m1(Build:9790)-Rev. 1844436
and got the same issue

Found out that it works last with AOO401m5(Build:9714)-Rev. 1524958
and broke down in AOO410m18(Build:9764)-Rev. 1589052
Comment 3 Peter 2018-11-02 14:57:52 UTC
4.1.x does not have gstreamer 1.0.0 support.
This will come with 4.2.0. Which we want to release soon (tm).
Comment 4 Peter 2018-11-02 14:59:41 UTC
I am not sure why it works with the old version thought.
Comment 5 jmpoo 2018-11-02 16:50:39 UTC
(In reply to Peter from comment #3)
> 4.1.x does not have gstreamer 1.0.0 support.
> This will come with 4.2.0. Which we want to release soon (tm).
See also: issue 127925

To make sure we do not misunderstand: When you press Play in the Media Bar, the video plays (I tried mp4).

But OpenOffice crashes when you click in the header to enter a title or click on the first slide.
Comment 6 jmpoo 2018-11-02 16:55:28 UTC
In AOO 3.4.1 and 4.0.1 the video is insertet, you can enter a title or click on the first slide without crash -and- the video is shown in presentation mode as expected.
Comment 7 jmpoo 2019-03-08 13:21:28 UTC
At issue 127925 I added a test file and a video which shows the behavior.

Open the test file, go to the second slide, select the embedded video and try to add a title (or click on the first slide) - AOO closes immediately