Issue 128242

Summary: OpenOffice dumping core in centos 8
Product: General Reporter: SVGK Raju <svgkraju>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED_WITHOUT_CODE QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: cmarcum, mseidel, oooforum, pescetti, petko
Version: 4.1.7Keywords: crash
Target Milestone: ---   
Hardware: PC   
OS: Linux 64-bit   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description SVGK Raju 2019-12-16 04:55:15 UTC
OpenOffice 4.1.7 dumping core in CentOS 8.

[root@rsa log]# uname -a
Linux rsa 4.18.0-80.11.2.el8_0.x86_64 #1 SMP Tue Sep 24 11:32:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[root@rsa log]# cat /etc/redhat-release 
CentOS Linux release 8.0.1905 (Core) 

Dec 16 10:15:01 rsa systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Dec 16 10:15:01 rsa systemd[1]: Started Process Core Dump (PID 16164/UID 0).
Dec 16 10:15:02 rsa systemd-coredump[16165]: Process 16158 (soffice.bin) of user 1000 dumped core.#012#012Stack trace of thread 16158:#012#0  0x00007f5d997a751d _dl_relocate_object (ld-linux-x86-64.so.2)#012#1  0x00007f5d997aecfd dl_open_worker (ld-linux-x86-64.so.2)#012#2  0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#3  0x00007f5d997ae6ae _dl_open (ld-linux-x86-64.so.2)#012#4  0x00007f5d980019f1 do_dlopen (libc.so.6)#012#5  0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#6  0x00007f5d98002593 _dl_catch_error (libc.so.6)#012#7  0x00007f5d98001af7 dlerror_run (libc.so.6)#012#8  0x00007f5d98001b8a __libc_dlopen_mode (libc.so.6)#012#9  0x00007f5d97fd3c39 init (libc.so.6)#012#10 0x00007f5d9788be67 __pthread_once_slow (libpthread.so.0)#012#11 0x00007f5d97fd3d84 __backtrace (libc.so.6)#012#12 0x00007f5d993d6080 n/a (libuno_sal.so.3)#012#13 0x00007f5d993d6dca n/a (libuno_sal.so.3)#012#14 0x00007f5d97f009c0 __restore_rt (libc.so.6)#012#15 0x00007f5d997a751d _dl_relocate_object (ld-linux-x86-64.so.2)#012#16 0x00007f5d997aecfd dl_open_worker (ld-linux-x86-64.so.2)#012#17 0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#18 0x00007f5d997ae6ae _dl_open (ld-linux-x86-64.so.2)#012#19 0x00007f5d97a9d1ba dlopen_doit (libdl.so.2)#012#20 0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#21 0x00007f5d98002593 _dl_catch_error (libc.so.6)#012#22 0x00007f5d97a9d929 _dlerror_run (libdl.so.2)#012#23 0x00007f5d97a9d25a dlopen@@GLIBC_2.2.5 (libdl.so.2)#012#24 0x00007f5d993d0a2b osl_loadModule (libuno_sal.so.3)#012#25 0x00007f5d972d9875 _ZN4cppu29loadSharedLibComponentFactoryERKN3rtl8OUStringES3_S3_RKN3com3sun4star3uno9ReferenceINS6_4lang20XMultiServiceFactoryEEERKNS8_INS6_8registry12XRegistryKeyEEE (libuno_cppuhelpergcc3.so.3)#012#26 0x00007f5d7c20833e n/a (bootstrap.uno.so)#012#27 0x00007f5d972c8223 n/a (libuno_cppuhelpergcc3.so.3)#012#28 0x00007f5d972c8d7a n/a (libuno_cppuhelpergcc3.so.3)#012#29 0x00007f5d972c579a n/a (libuno_cppuhelpergcc3.so.3)#012#30 0x00007f5d972c59bf n/a (libuno_cppuhelpergcc3.so.3)#012#31 0x00007f5d7c1d5a36 n/a (bootstrap.uno.so)#012#32 0x00007f5d7c1cbe2c n/a (bootstrap.uno.so)#012#33 0x00007f5d94be1838 n/a (libutl.so)#012#34 0x00007f5d94be68ec _ZN14SvtPathOptionsC1Ev (libutl.so)#012#35 0x00007f5d9914aaaa n/a (libsofficeapp.so)#012#36 0x00007f5d9914cc98 n/a (libsofficeapp.so)#012#37 0x00007f5d9913e440 n/a (libsofficeapp.so)#012#38 0x00007f5d9455f7ef n/a (libvcl.so)#012#39 0x00007f5d9455f8ba _Z6SVMainv (libvcl.so)#012#40 0x00007f5d99166ffc soffice_main (libsofficeapp.so)#012#41 0x0000000000400f7b main (soffice.bin)#012#42 0x00007f5d97eec813 __libc_start_main (libc.so.6)#012#43 0x0000000000400eb9 _start (soffice.bin)
Dec 16 10:15:02 rsa openoffice4-startcenter.desktop[16148]: /opt/openoffice4/program/soffice: line 121: 16158 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"
Comment 1 Marcus 2019-12-16 22:54:13 UTC
When there is no description what this is and how to reproduce this, we cannot do anything about it.
Comment 2 SVGK Raju 2019-12-17 01:56:15 UTC
Discription is there above. I am not sure why you are not able to see that. However copy pasted the same again. I was not able to upload the core due to size restrictions.

OpenOffice 4.1.7 dumping core in CentOS 8.

[root@rsa log]# uname -a
Linux rsa 4.18.0-80.11.2.el8_0.x86_64 #1 SMP Tue Sep 24 11:32:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[root@rsa log]# cat /etc/redhat-release 
CentOS Linux release 8.0.1905 (Core) 

Dec 16 10:15:01 rsa systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Dec 16 10:15:01 rsa systemd[1]: Started Process Core Dump (PID 16164/UID 0).
Dec 16 10:15:02 rsa systemd-coredump[16165]: Process 16158 (soffice.bin) of user 1000 dumped core.#012#012Stack trace of thread 16158:#012#0  0x00007f5d997a751d _dl_relocate_object (ld-linux-x86-64.so.2)#012#1  0x00007f5d997aecfd dl_open_worker (ld-linux-x86-64.so.2)#012#2  0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#3  0x00007f5d997ae6ae _dl_open (ld-linux-x86-64.so.2)#012#4  0x00007f5d980019f1 do_dlopen (libc.so.6)#012#5  0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#6  0x00007f5d98002593 _dl_catch_error (libc.so.6)#012#7  0x00007f5d98001af7 dlerror_run (libc.so.6)#012#8  0x00007f5d98001b8a __libc_dlopen_mode (libc.so.6)#012#9  0x00007f5d97fd3c39 init (libc.so.6)#012#10 0x00007f5d9788be67 __pthread_once_slow (libpthread.so.0)#012#11 0x00007f5d97fd3d84 __backtrace (libc.so.6)#012#12 0x00007f5d993d6080 n/a (libuno_sal.so.3)#012#13 0x00007f5d993d6dca n/a (libuno_sal.so.3)#012#14 0x00007f5d97f009c0 __restore_rt (libc.so.6)#012#15 0x00007f5d997a751d _dl_relocate_object (ld-linux-x86-64.so.2)#012#16 0x00007f5d997aecfd dl_open_worker (ld-linux-x86-64.so.2)#012#17 0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#18 0x00007f5d997ae6ae _dl_open (ld-linux-x86-64.so.2)#012#19 0x00007f5d97a9d1ba dlopen_doit (libdl.so.2)#012#20 0x00007f5d980024f7 _dl_catch_exception (libc.so.6)#012#21 0x00007f5d98002593 _dl_catch_error (libc.so.6)#012#22 0x00007f5d97a9d929 _dlerror_run (libdl.so.2)#012#23 0x00007f5d97a9d25a dlopen@@GLIBC_2.2.5 (libdl.so.2)#012#24 0x00007f5d993d0a2b osl_loadModule (libuno_sal.so.3)#012#25 0x00007f5d972d9875 _ZN4cppu29loadSharedLibComponentFactoryERKN3rtl8OUStringES3_S3_RKN3com3sun4star3uno9ReferenceINS6_4lang20XMultiServiceFactoryEEERKNS8_INS6_8registry12XRegistryKeyEEE (libuno_cppuhelpergcc3.so.3)#012#26 0x00007f5d7c20833e n/a (bootstrap.uno.so)#012#27 0x00007f5d972c8223 n/a (libuno_cppuhelpergcc3.so.3)#012#28 0x00007f5d972c8d7a n/a (libuno_cppuhelpergcc3.so.3)#012#29 0x00007f5d972c579a n/a (libuno_cppuhelpergcc3.so.3)#012#30 0x00007f5d972c59bf n/a (libuno_cppuhelpergcc3.so.3)#012#31 0x00007f5d7c1d5a36 n/a (bootstrap.uno.so)#012#32 0x00007f5d7c1cbe2c n/a (bootstrap.uno.so)#012#33 0x00007f5d94be1838 n/a (libutl.so)#012#34 0x00007f5d94be68ec _ZN14SvtPathOptionsC1Ev (libutl.so)#012#35 0x00007f5d9914aaaa n/a (libsofficeapp.so)#012#36 0x00007f5d9914cc98 n/a (libsofficeapp.so)#012#37 0x00007f5d9913e440 n/a (libsofficeapp.so)#012#38 0x00007f5d9455f7ef n/a (libvcl.so)#012#39 0x00007f5d9455f8ba _Z6SVMainv (libvcl.so)#012#40 0x00007f5d99166ffc soffice_main (libsofficeapp.so)#012#41 0x0000000000400f7b main (soffice.bin)#012#42 0x00007f5d97eec813 __libc_start_main (libc.so.6)#012#43 0x0000000000400eb9 _start (soffice.bin)
Dec 16 10:15:02 rsa openoffice4-startcenter.desktop[16148]: /opt/openoffice4/program/soffice: line 121: 16158 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"
Comment 3 Peter 2019-12-17 08:08:41 UTC
Please do not repeat your dumb if it is not different.
we believe you that this is an issue.

However it is hard to fix if we have not more information.
What did you do before the crash?
Is it at startup or did you work on a document?

Have you taken any support action like asking on forums?
Did you try to reset your Profile?
Did you try to reinstall OpenOffice?

It is to understand the surroundings of this crash.

I hope this helps to make a step forward.
Comment 4 Peter 2019-12-17 08:10:25 UTC
How did you install openoffice?
Where did you download openoffice from?

Did it work before or does it crash directly after installation?
Comment 5 SVGK Raju 2019-12-17 10:02:31 UTC
I installed CentOS 8 freshly followed by openjdk version 1.8.0_232

Later I followed the steps mentioned in https://computingforgeeks.com/install-apache-openoffice-on-rhel-centos-8/

No errors were shown while installing openoffice.

It created all the icons as mentioned in the above URL.

When I clicked OpenOffice 4.1.7, start up UI for OpenOffice with status bar showed up for sometime, and crashed.

When I looked at /var/log/messages at the sametime, I saw the above dump trace.

Let me know if you need any further information.
Comment 6 oooforum (fr) 2019-12-18 18:23:06 UTC
(In reply to SVGK Raju from comment #5)
> I installed CentOS 8 freshly followed by openjdk version 1.8.0_232
LibreOffice was installed before?
Comment 7 Andrea Pescetti 2020-01-05 20:18:59 UTC
Suggestion: check if this is a duplicate of

https://bz.apache.org/ooo/show_bug.cgi?id=124948

Namely, see whether

$ sudo dnf install gdk-pixbuf2-xlib

solves it (but please do run the debugging steps at the issue linked above in order to find out the precise names of what you are missing, as CentOS 8 and Fedora are quite similar but not identical).
Comment 8 Peter 2020-01-13 10:49:50 UTC
Hello all,

can this issue be closed?
I think there has been an email that states this.

Thanks
Peter
Comment 9 Andrea Pescetti 2020-01-13 11:45:16 UTC
The e-mail discussion was for Fedora 31, not CentOS 8. It is absolutely possible that the CentOS 8 issue is the same, but we don't have confirmation yet.

Reference from users list:

https://lists.apache.org/thread.html/8da3251c94f07f6f1f81b13d1eee5953ce12817725bcf2b895d40e89%40%3Cusers.openoffice.apache.org%3E
Comment 10 SVGK Raju 2020-01-20 22:28:53 UTC
Thank you. OpenOffice working after installing gdk-pixbuf2-xlib. However we need to download the rpm and exeucute dnf localinstall
Comment 11 Carl Marcum 2020-02-16 01:49:58 UTC
I had a very similar issue:
https://bz.apache.org/ooo/show_bug.cgi?id=128290.
The library needed is gdk-pixbuf2-xlib and I only found it available in the Centos PowerTools repo which was not enabled by default on my CentOS 8 system.
Enable it with:
$ sudo dnf config-manager --set-enabled PowerTools
installed with:
$ sudo dnf install gdk-pixbuf2-xlib
Then AOO 4.1.7 started.
Comment 12 Andrea Pescetti 2020-02-16 16:09:13 UTC
*** Issue 128290 has been marked as a duplicate of this issue. ***