Issue 128387

Summary: AOO 4.1.7 on OS/2 loses file association
Product: General Reporter: Shmuel (Seymour J.) Metz <smetz3>
Component: uiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: mseidel, oooforum
Version: 4.1.7   
Target Milestone: ---   
Hardware: PC   
OS: OS/2   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
screen capture none

Description Shmuel (Seymour J.) Metz 2020-06-10 17:32:50 UTC
Created attachment 86956 [details]
screen capture

Sometimes AOO 4.1.7 looses the WPS association for a file and double clicking on the file icon brings up the WPS dialog instead of opening OpenOffice for the file. Attached is a screen capture.

This has been happening on ArcaOS 5.0.4 and older versions.

In addition to tracking down why this is happening, it wold be helpful if OpenOffice had a repair EA facility to restore the proper association.
Comment 1 oooforum (fr) 2020-11-24 19:32:54 UTC
Now, 4.1.8 is available.
Could you try this last build if this issue is still reproduce?
Comment 2 Matthias Seidel 2020-11-24 19:39:49 UTC
(In reply to oooforum (fr) from comment #1)
> Now, 4.1.8 is available.
> Could you try this last build if this issue is still reproduce?

AOO 4.1.8 is not released for OS/2 yet...
Comment 3 Matthias Seidel 2020-12-09 19:24:12 UTC
(In reply to Matthias Seidel from comment #2)
> (In reply to oooforum (fr) from comment #1)
> > Now, 4.1.8 is available.
> > Could you try this last build if this issue is still reproduce?
> 
> AOO 4.1.8 is not released for OS/2 yet...

Now it is! ;-)
Comment 4 Shmuel (Seymour J.) Metz 2020-12-24 00:19:25 UTC
Do I need to first uninstall 4.1.7 and is AOO-4180-GA-base-en-US.wpi all that I need?

I've alread updated libicu.
Comment 5 Matthias Seidel 2020-12-24 00:48:07 UTC
(In reply to Shmuel (Seymour J.) Metz from comment #4)
> Do I need to first uninstall 4.1.7 and is AOO-4180-GA-base-en-US.wpi all
> that I need?
> 
> I've alread updated libicu.

I think this is stated in the readme, located at the same place you got the wpi from...
Comment 6 Shmuel (Seymour J.) Metz 2020-12-24 15:46:04 UTC
OK, I see that I will need to uninstall 4.1.7 first.

Do I need to open a new ticket to suggest that the web page and readme note that ArcaOS 5.0.6 dooes not include the required level of libicu?
Comment 7 Shmuel (Seymour J.) Metz 2020-12-26 19:31:15 UTC
The problem still occurs with 4.1.8.
Comment 8 oooforum (fr) 2021-01-03 08:42:24 UTC
Did you reset the user profile?
Comment 9 Shmuel (Seymour J.) Metz 2021-01-03 16:54:15 UTC
How do I reset the user profile?