Issue 13597

Summary: Add concurrent access/modify to spreadsheets shared on a LAN
Product: Calc Reporter: lucat <lucat>
Component: codeAssignee: bettina.haberer
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description lucat 2003-04-18 18:58:51 UTC
Hello,
i just wanted to suggest you to add concurrent access to a spreadsheet shared on
a LAN. This is possible in Microsoft Excel and it is VERY useful when you have
lots of data and you want to split the job among one or more other members of
the LAN.
Excel shows each modified cell with a different color/note (the color depends on
the user who modified it) so you always know who modified it... of course the
color/note disappears at the next "save". (Try it with Excel to know what i am
talking about if you have doubts).
I am not sure if someone has already suggested this, i tried searching in the
database but i couldn't find it.
Thank you,
  Luca
Comment 1 frank 2003-04-22 09:13:21 UTC
Hi Bettina,

1 4 u

It seems to be a good enhancement of the redlining feature.

Frank
Comment 2 frank 2004-06-01 14:38:12 UTC
*** Issue 29716 has been marked as a duplicate of this issue. ***
Comment 3 immanuelcrc 2004-06-02 14:56:04 UTC
Copied from 29716

Someone posted this from the users list about using the feature in Excel:

<paste>
Given that you most likely don't have access to Excel, I will state a couple
of the simple tests I did.

Created a new Excel spreadsheet.
Selected Shared Workbook and ticked the desired options including automatic
update every 5 minutes. (It really is this simple for end users to enable.)
Save the file on a shared hard disk.

Both users open file which currently contains nothing
First user enters "Fred" into cell A1 and saves

Nothing happens in second users spreadsheet. If the second user presses
Save, all changes appear. The changes appear with a Note providing full
description of who changed what (including before and after) and when.

>From a computer persons point of view having to press Save to see changes
reflected in data is cumbersome. If the data is updated automatically every
5 minutes (the minimum time interval) then that could be a lot of updates to
review.

Now both users change cell A1 to "User1" and "User2" respectively.
User two saves first first.
User one goes to save.

User one is prompted that a change has already occurred in the cell. What
the change is, and whether to accept "mine", or "other".

If the changes do not overlap, the changes simply appear and the user is
informed that others have made changes. Again with full notes colour coded.

This approach is a called optimistic locking I believe. This is the first
time I have seen a good use for optimistic locking.
I don't use optimistic locking in applications. I use record level locking.

But hey, for end users with shared files and low volume changes, this
approach is completely valid. At a guess this would appear to be very little
different from tracking changes in a word processing document.

What fusses me about all of this is I can't possibly see how OpenOffice.org
is useable in Government and Corporates where this type of requirement
exists everywhere. Even in the small business, medium business sector I work
in, multiple user updates is pretty fundamental. Even if it only occurs in
one in a hundred documents, if the functionality is not available in some
form, users will start to look at other packages.

Because of my database background I would prefer multi-user updates to be in
a more controlled environment.

</paste>
Comment 4 gnustavo 2005-09-30 13:29:51 UTC
I guess this is a duplicate of issue 8811
(http://qa.openoffice.org/issues/show_bug.cgi?id=8811), isn't it?

Gustavo.
Comment 5 frank 2005-09-30 16:15:53 UTC
Yeep, double to Issue 8811. 

All voters, transfer your votes please.

Frank

*** This issue has been marked as a duplicate of 8811 ***
Comment 6 frank 2005-09-30 16:16:30 UTC
closed double