Issue 13652

Summary: Legend in piecharts
Product: General Reporter: marcstuessel <marc>
Component: chartAssignee: IngridvdM
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description marcstuessel 2003-04-20 18:32:59 UTC
Apparently there is no way to assign the row content as a name to the 
coresponding section of a piechart; i.e. I don't want a separate legend but a 
means to assign the individual row contents to the piechart sections (the way 
MS Excel handles this)
Comment 1 frank 2003-04-22 09:31:27 UTC
wrong component, I've changed it.

Frank
Comment 2 kla 2003-04-23 14:56:47 UTC
Set to new.
Hi Bettina,
one for you.
Comment 3 bettina.haberer 2003-09-19 14:26:24 UTC
Summary: There is no way to get row content as a name to the
corresponding section of a piechart (like competition).
Comment 4 bjoern.milcke 2003-10-31 09:31:20 UTC
->marcstuessel: Can you be more specific? If you want to have the
category labels (which are usually in the legend) near the pie
segments, then try "Insert/Data Labels" and select "Data Label text".
Comment 5 marcstuessel 2003-11-23 15:58:32 UTC
christ, attaching a document is hard work. why is PDF not in thelist? 
why am I supposed to enter a mime type and why is "PDF" not 
sufficient?
Comment 6 marcstuessel 2003-11-23 16:27:11 UTC
Yes, your suggestion comes close, however, what I want is to move the 
label into the corresponding chart area, colour the text so as to 
improve legibility, and if need be, rotate the label.
Also, regardless of how the labels are put next to or into their 
correspinding segments, the legend should be suppressed automatically.

I appreciate that it is actually possible to place lables next to a 
graph, but why is this option not part of the Chart wizard?

I tried to create a pie-chart with lots of segments - putting the 
text labels close to the chart-segmetns looks pretty awful. The 
layouter does not deal with this - IMHO the labels should have a 
minimum spacing betweem them and use a line to connect themselves to 
their corresponding chart segment 
Comment 7 bettina.haberer 2004-04-08 12:59:46 UTC
Hello Ingrid, please give approval for this evaluated OO.o 2.0 flagged issue. 
If you confirm with the target OO.o 2.0, then please keep it on your owner (or
the owner of the concerning developer) for implementation. In case you want this
issue for 'OOo Later', then please reset the target milestone. If you decline
the issue finally, please set the resolution to 'Wontfix' (but do not close). In
case of 'OOo Later' or 'Wontfix' please reset it on Bettina's owner. Thank you.
Comment 8 bettina.haberer 2004-04-08 13:01:21 UTC
Sorry, took wrong reassign address, this time iha.
Comment 9 IngridvdM 2004-04-08 16:51:54 UTC
set target to OOo Later
Comment 10 bettina.haberer 2004-11-29 18:14:09 UTC
Reassigned to Ingrid.
Comment 11 IngridvdM 2005-04-26 10:48:56 UTC
-Better automatic positions for lables on pie segments are already targeted
within Issue 4039.
-Rotation of data labels is already targeted within Issue 24203.
-Applying different Font Effects to the data labels is already possible.
Select the pie segment and choose 'Object Properties...' in the context menu.
In the upcoming dialog select the tabpage 'Font Effects'.

As this issue does contain a lot of different requests and is therefor
complicated to read and to handle I created a new Issue 48170 that contains the
request for free positioning of data labels only.
For the same reason I close this Issue as duplicate. If you have additional
ideas or problems please do submit a separat Issue for each single idea. That
helps a lot when working on them. Thank you for your input.

*** This issue has been marked as a duplicate of 4039 ***
Comment 12 IngridvdM 2005-04-26 10:50:43 UTC
closed as duplicate