Issue 14050

Summary: "Word count" (statistics) counting headers and footers
Product: Writer Reporter: Unknown <non-migrated>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Trivial    
Priority: P3 CC: brat, issues, oooforum, robertjm
Version: OOo 1.0.3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 4568    

Description Unknown 2003-05-03 19:59:28 UTC
The "Number of words" statistic, found in File->Properties->Statistics, counts
all words included in both headers and footers inserted within the document.
Unfortunately, when it comes essays or documents for "school" (university) work
these should not be included and so I was hoping for an option to choose whether
to include the headers and/or footers within the word count statistic.
Comment 1 brat 2003-07-01 20:05:57 UTC
Thank you for your suggestion.  

I am going to confirm this issue.
Comment 2 h.ilter 2003-07-02 12:26:07 UTC
Reassigned to BH
Comment 3 sajer 2003-08-04 20:20:02 UTC
This issue should be solved with this issue in mind:

http://www.openoffice.org/project/www/issues/show_bug.cgi?id=1793
Comment 4 lohmaier 2003-10-02 01:20:07 UTC
cross-linking word-count issues (Platform: ALL, target: not determined)
Comment 5 guido.pinkernell 2004-02-14 19:58:38 UTC
*** Issue 16219 has been marked as a duplicate of this issue. ***
Comment 6 guido.pinkernell 2004-02-14 20:03:10 UTC
*** Issue 23974 has been marked as a duplicate of this issue. ***
Comment 7 hooloovoo 2005-05-24 02:57:21 UTC
This is a similar issue to 14410. I would personally like to see a little
checkbox which lets you include or not include footnotes as at the moment I keep
having to select all.
Comment 8 hooloovoo 2005-05-24 02:58:19 UTC
Using m100:
This issue seems a similar issue to 14410. I would personally like to see a
little checkbox which lets you include or not include footnotes as at the moment
I keep having to 'select all'ing.
Comment 9 aziem 2005-10-10 00:59:00 UTC
*** Issue 42601 has been marked as a duplicate of this issue. ***
Comment 10 hhielscher 2006-11-15 14:56:28 UTC
Please make this feature flexible: the count should depend on the paragraph
style selected.
This would give the power to the user to define what gets counted and what not.
Also this would allow to have multiple articles in one document together with
fields for the word/character count.
Comment 11 bettina.haberer 2010-05-21 14:44:39 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 12 Robert Marshall 2013-04-14 00:10:00 UTC
I ran across this issue when trying to create a LibreOffice Writer template today.

I wanted to have a Word Count total in my Header record. While I could get the information to print on every page in my document, it also counted every word that was in the Header and Footer as well.

It would be helpful to be able to create a statistic Field which counts words in only the main body of the document. Of course, to do that first, I imagine this Feature Request would need to be dealt with first. Unless I'm missing something where you can calculate the word count only based on the body text.

Yes, I've seen the comments on figuring it out by highlighting and looking at the Selected Text value. However, that's not a usable variable for inclusion in the document, right?
Comment 13 oooforum (fr) 2019-07-12 07:22:49 UTC
This enhancement include other informations like footers, endnotes, etc.
So jump to this...

*** This issue has been marked as a duplicate of issue 14410 ***