Issue 14832

Summary: Field "Page Count" is missing
Product: Impress Reporter: sohm <philippe>
Component: editingAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: cmoulin, diwann, issues, lohmaier, marc.galmard, radim.kubacki, samuel.kvasnica, sgautier.ooo, synanceia
Version: OOo 1.1 Beta2Keywords: oooqa, rfe_eval_ok, usability
Target Milestone: OOo 3.2   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description sohm 2003-05-24 12:27:27 UTC
The field "page count" is missing in OOo Impress although "Page count" is
available in OOo Writer and "Page number" in Impress.
Comment 1 wolframgarten 2003-05-26 07:15:12 UTC
Reassigned to Bettina.
Comment 2 lohmaier 2003-05-31 17:23:27 UTC
confirming issue, setting target-milestone, adjusting priority
Comment 3 lohmaier 2003-05-31 17:25:12 UTC
not specific to a platform or os...
Comment 4 bettina.haberer 2003-06-11 08:51:33 UTC
Page Count makes sense at least in presentation mode. 
Comment 5 bettina.haberer 2004-04-08 17:55:04 UTC
Hello Christian, is this enhancemet perhaps goig into the Q within the new
footer in Ipress?
Comment 6 zot 2004-04-27 19:43:20 UTC
Yes a page count field for Impress/Presentor would be very nice.

Actually more fields in general should be there!

This RFE seems stale.  May the issues@graphics address is the problem
Comment 7 lohmaier 2004-10-23 15:51:12 UTC
setting prio to default, keywords & subcomponent according to new RFE-porcess
Comment 8 lohmaier 2005-05-03 20:54:41 UTC
*** Issue 48613 has been marked as a duplicate of this issue. ***
Comment 9 plasmasam 2005-11-16 20:22:06 UTC
By all means, this issue sits here around since 2003 ! And it is an
easy-to-implement one. 

@cj: would you please write the specs for this ? It would be the same as for
page count in Write.

Just to give you a feeling why this is important: I admit, one can really enjoy
as a speaker the panic and desperateness in the faces and eyes of the audience
having swapped the slide 21 of 21 over to 22 of 21 while beeing just tigh on
time with the PhD thesis presentation. Indeed, one can really enjoy such
situation, nevertheless this should not happen during a conference talk and
hence it is _important_ that one can get these automatically updated fields.
Comment 10 clippka 2006-11-15 10:24:13 UTC
taking over this issue
Comment 11 christian.guenther 2007-05-22 11:40:36 UTC
*** Issue 77661 has been marked as a duplicate of this issue. ***
Comment 12 clippka 2007-09-12 16:58:41 UTC
retarget
Comment 13 clippka 2009-02-03 16:17:21 UTC
retarget
Comment 14 clippka 2009-02-04 10:54:38 UTC
works great so far, only that the page count field is not updated correctly when
placed on a slide (works on master pages). But that seems to be a bug since page
number fields also do not update correctly, so I filed issue 98870 for it.
Comment 15 clippka 2009-02-04 11:56:00 UTC
Implemented in cws impress168 for OOo 3.2
Comment 16 clippka 2009-04-03 14:01:24 UTC
verified in cws, back to qa. (pleae note the repaint issue above)
Comment 17 Regina Henschel 2009-04-06 12:10:29 UTC
*** Issue 100881 has been marked as a duplicate of this issue. ***
Comment 18 wolframgarten 2009-04-17 11:23:40 UTC
Verified in CWS.
Comment 19 marina_hitekschool 2009-05-03 00:02:31 UTC
Verified in OOO310m9. Can be closed.
Comment 20 sohm 2009-05-03 22:07:32 UTC
i would like to thank all the openoffice supporter to resolve that bug ;) (6
years old)
Comment 21 sgautier.ooo 2009-05-04 21:10:55 UTC
Hi all, 

I can't see a cloned cws for 3.1 though I assume it can't be verified in m9.
I'll take a look on m47 to close it. Kind regards - Sophie
Comment 22 wolframgarten 2009-05-20 08:45:09 UTC
Tested in m48. Closed.
Comment 23 Joe Smith 2009-07-16 17:21:41 UTC
Verifying: I see correct behavior in DEV300_m52 (Linux)

Insert > Fields > Page Count; copied slide; count updates as expected.
Comment 24 arghman 2009-09-03 20:03:13 UTC
is there a workaround in 3.1? This is really surprising to not have a page count.