Issue 14993

Summary: problems with import of .dxf files
Product: Draw Reporter: Unknown <non-migrated>
Component: uiAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1 Beta2   
Target Milestone: AOO Later   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
DXF file
none
Snapshot of monitor
none
columbia.dxf in AutoCAD 2007
none
columbia.dxf in OpenOffice 3.0.0 under WinXP none

Description Unknown 2003-05-28 05:24:12 UTC
I have found a problem with importing a .dxf file into DRAW(linux version) while
everything is ok with same version of draw in windows).
I have a .dxf file (AutoCAD2000, VariCAD8, QCAD open it correct)
and when I import it to DRAW it shows up ugly - half of objects
(lines,circles and so on) are loosed at all, others are incorrect.
I use RedHat 7.3. I have checked it in OpenOffice-1.0.2, OO1.1beta1,
OO1.1beta2,StarOffice.beta2. Same time when I import the same .dxf file
into OO1.1beta in WindowsXP Pro. everything is ok. All objects are correct.
Comment 1 wolframgarten 2003-05-28 07:25:07 UTC
Set to new.
Comment 2 wolframgarten 2003-05-28 07:29:08 UTC
Changed type to defect.
Comment 3 wolframgarten 2003-05-28 07:29:59 UTC
This is reproduceable in 1.1beta2 and in a current internal version.
Please have a look. Reassigned to Sven.
Comment 4 sven.jacobi 2003-06-05 15:07:23 UTC
SJ->WG: I was not able to reproduce this bug, so can you please
provide a bugdoc which definitely has this error.
Comment 5 wolframgarten 2003-06-05 15:31:08 UTC
Created attachment 6678 [details]
DXF file
Comment 6 wolframgarten 2003-06-05 15:34:14 UTC
Created attachment 6679 [details]
Snapshot of monitor
Comment 7 wolframgarten 2003-06-05 15:34:43 UTC
Snapshot and bugdoc attached, reassigend to Sven.
Comment 8 sven.jacobi 2003-06-05 17:12:34 UTC
SJ->THB: I can not reproduce this bug, but there must be a problem
somewhere. As I know you prefer such kind of miracles.
Comment 9 thb 2003-06-10 15:56:41 UTC
Hm. Cannot reproduce by myself (yet), but seen on Wolfram's screen.
Comment 10 thb 2003-07-04 14:26:09 UTC
Thanks to stunnix, I'm pretty confident that the atof's in dxfgrprd.cxx is the 
culprit there.
Comment 11 thb 2003-09-12 18:50:49 UTC
Sven, please check whether these atofs can be replaced by our
locale-independent rtl methods.
Comment 12 sven.jacobi 2003-09-16 09:55:04 UTC
accepted
Comment 13 marc.neumann 2003-10-15 14:13:31 UTC
"According to the OpenOffice.org roadmap
(http://tools.openoffice.org/releases) this issue was retargeted to
OOo Later." 
Comment 14 sergey_feo 2009-03-04 18:23:23 UTC
The new OpenOffice 3.0.0 imports "columbia.dxf" much better.
I attach screenshots of this dxf in AutoCAD 2007 and OpenOffice Writer 3.0.0. I
can't find any differences.
Comment 15 sergey_feo 2009-03-04 18:25:20 UTC
Created attachment 60711 [details]
columbia.dxf in AutoCAD 2007
Comment 16 sergey_feo 2009-03-04 18:26:37 UTC
Created attachment 60712 [details]
columbia.dxf in OpenOffice 3.0.0 under WinXP