Issue 15220

Summary: should register .rtf files as OpenOffice.org Writer files
Product: Installation Reporter: gemal <bugzilla>
Component: codeAssignee: Olaf Felka <olaf-openoffice>
Status: CLOSED FIXED QA Contact: issues@installation <issues>
Severity: Trivial    
Priority: P3 CC: ahz001, flibby05, issues, kami911, kpalagin, Mathias_Bauer, mfedyk, michael.ruess, ooo, stp, utomo.prawiro
Version: OOo 1.1 RC4Keywords: oooqa
Target Milestone: OOo 2.3   
Hardware: PC   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description gemal 2003-06-02 19:14:09 UTC
double clicking on a .rtf file should open Writer with the file.
You can open the .rtf file from with Writer but it should register .rtf files as a OpenOffice.org Writer document like Office does.
Comment 1 mci 2003-09-11 11:50:12 UTC
reassigned to mru
Comment 2 michael.ruess 2003-09-12 14:03:36 UTC
Registering .rtf like .doc/.ppt/.xls during installaton could be a
useful  addition.
Comment 3 utomo99 2003-09-18 07:48:53 UTC
I update the version 1.1 Rc4, and target for 1.1.1 

I think people will feel better by this file association
Comment 4 utomo99 2003-09-19 04:40:58 UTC
added oooqa
Comment 5 Olaf Felka 2003-09-25 13:08:58 UTC
*** Issue 15794 has been marked as a duplicate of this issue. ***
Comment 6 utomo99 2003-10-30 09:28:34 UTC
Reassign issue to owner of selected subcomponent

------- Additional Comments From Christian Lohmaier 2003-09-14 13:43
PDT -------

*** Issue 19572 has been marked as a duplicate of this issue. ***



Comment 7 Olaf Felka 2003-10-30 09:39:42 UTC
of - bh: Please have a look at this enhancement.
of - utomo99: OOo 1.1.1 will not be a feature enhanced version, just
bugfixes.
Comment 8 Olaf Felka 2003-10-30 09:42:01 UTC
BTW: 'Word processor' is the right component.
Comment 9 utomo99 2003-10-30 09:54:49 UTC
sometimes it is difficult to guess what component it is. as mru also
think it must be regitering in the installation. actually we also can
say it is a defect because Writer cannot open the rtf by double click :)

I also change the QA contact to SW

------- Additional Comments From mru@openoffice.org 2003-09-12 06:03
PDT -------

Registering .rtf like .doc/.ppt/.xls during installaton could be a
useful  addition.
Comment 10 lohmaier 2004-01-21 17:33:54 UTC
*** Issue 24616 has been marked as a duplicate of this issue. ***
Comment 11 ezh 2004-06-28 19:55:49 UTC
This drives me creazy... :(
Comment 12 ezh 2005-02-15 16:29:55 UTC
Any chance for 2.0?
Comment 13 lohmaier 2005-08-25 20:19:37 UTC
*** Issue 44951 has been marked as a duplicate of this issue. ***
Comment 14 lohmaier 2005-08-25 20:59:39 UTC
*** Issue 53724 has been marked as a duplicate of this issue. ***
Comment 15 kpalagin 2006-09-21 21:34:13 UTC
Changing component o installation, as it seems to me that installation should 
register .rtf to open with OpenOffice.
Comment 16 Mathias_Bauer 2007-04-12 07:38:04 UTC
Ingo, please take this over. I assume that it isn't a big deal to extend the
custom action for registering OOo as handler for Word document to also support rtf?

Do you think that this task and also the task about registering our
"applications" instead of soffice.exe is something that we should do in a minor
version or is it something that we should do in a major version only?

In case you are fine with doing it in a minor, what do you think about 2.3 (for
both tasks)?
Comment 17 kpalagin 2007-04-12 08:08:44 UTC
Mathias,
can we a bit extend original issue to include most common file-types that we 
can handle (for example .csv in addition to .rtf), make it user-selectable 
during installation and system-wide (so that all users on machine get the 
registration)?
Comment 18 Mathias_Bauer 2007-04-12 08:30:00 UTC
That depends. If you want a fast fix extending the RFE would be
counterproductive as it surely will create discussions. The request for
registering rtf is undoubtful reasonable and as we already have a UI for MS file
formats can be implemented fast and easily. Everything else will be time
consuming so I would prefer to create another issue for this.
Comment 19 ingo.schmidt-rosbiegal 2007-04-18 13:20:14 UTC
We will try to include rtf registration similar to doc,ppt,... in OOo 2.3 time
frame. So rtf will be registered, if in the "File type" dialog the check box for
"Microsoft Word Documents" is checked. In the same CustomAction it will be
possible to set the correct application for the MS file types
-> target 2.3
Comment 20 ingo.schmidt-rosbiegal 2007-04-18 13:22:34 UTC
Accepting issue
Comment 21 kpalagin 2007-04-18 13:41:32 UTC
is, mba,
I am not exactly sure that combining .doc and .rtf under the same checkbox is 
good idea. 
Any chance we can do separate checkbox for .rtf?
Comment 22 Mathias_Bauer 2007-04-18 13:48:42 UTC
Not in 2.3. But I don't think we should do it at all.

Besides that doc and rtf are basically the same format so I see no sense in
adding UI clutter just to differentiate between them. 

Moreover, as the original request more or less asks for doing the same as Word:

"it should register .rtf files as a OpenOffice.org Writer document like Office
does."

we are doing exactly this: either register for both of them or for none. That's
exactly what Word does.
Comment 23 ingo.schmidt-rosbiegal 2007-04-19 11:47:33 UTC
is -> dv: please take care of the customaction
Comment 24 dirk.voelzke 2007-04-23 13:14:18 UTC
Accepted
Comment 25 dirk.voelzke 2007-04-26 11:00:13 UTC
fixed in registrar.?xx, registrationcontextinformation.?xx
Comment 26 Olaf Felka 2007-05-03 14:03:08 UTC
OF: Reassigned to for QAing
Comment 27 Olaf Felka 2007-05-03 14:04:44 UTC
OF: The fix looks good in cws native82.
Comment 28 kami911 2007-05-12 11:07:29 UTC
Have we got same RFE for csv too? I did not find the solution in native82. Is
this enhancenment is available for other systems than Windows?
Comment 29 Olaf Felka 2007-07-10 13:31:04 UTC
OF: Is ok in src680 m220.
Comment 30 maybeway36 2007-09-26 01:14:34 UTC
So I understand that Writer registers RTF files if and only if you tell it to
register DOC files. Is this correct?
Comment 31 Mathias_Bauer 2007-09-26 07:09:25 UTC
Yes. As both formats basically are the same it makes sense to treat them equally.
Comment 32 intersol 2007-11-04 20:51:28 UTC
There is another issue 72627 that requests associations for CSV, DBF and other
formats. Take a look at it and vote in order to increase it's priority.
Comment 33 oooforum (fr) 2018-11-20 16:29:35 UTC
*** Issue 72627 has been marked as a duplicate of this issue. ***