Issue 15546

Summary: Enter-Key behaves not as expected
Product: Calc Reporter: nomike <nomike>
Component: uiAssignee: frank
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P4 CC: caiot1, issues, mr_smyle
Version: OOo 1.0.3Keywords: ms_interoperability, oooqa
Target Milestone: ---   
Hardware: Other   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
testcasespecification none

Description nomike 2003-06-12 11:15:26 UTC
Szenatio in Redmond Office:

I click on Cell A3 to make it active.
After enterin Values or not I press the Tab-Key on zthe KBD. The active Cell is 
now correctly A4.
A few tabs Later I'm in A8.
When I press Enter now the following happens:

Redmond Office:
The active Cell is now B3 (which is a very handy and usefull thing)

OOo:
The active Cell is now B8.


If there isn't allready an option for that (you never could know what crazy 
things you guys do ;-) it would be great to add this feature. But to make it 
better than Redmond-Office with an configuration setting to turn this behavor 
off (maybe some people don't like this).

But for what I'm doing right now this feature would be veeery usefull and I 
think tha same will be with a lot of other persons too.

thx in advance and even more thanx for building such a great and powerfull 
office application. Great Job Guys!

mfg
Nomike aka Michael Postmann
Comment 1 oc 2003-06-16 08:29:34 UTC
Hi Bettina,
one4you
Comment 2 frank 2003-08-11 12:05:40 UTC
*** Issue 18051 has been marked as a duplicate of this issue. ***
Comment 3 bettina.haberer 2003-12-04 17:20:33 UTC
Hello Niklas, this one is also a nice feature (a kind of row break
after the last filled cell is recognized in a row of filled cells
(Feature does not work, if empty cells are inbetween)).
Please give approval for this evaluated OO.o 2.0 flagged issue. 
If you confirm with the target OO.o 2.0, then please keep it on your
owner (or the owner of the concerning developer) for implementation.
In case you want this issue for 'OOo Later', then please reset the
target milestone. If you decline the issue finally, please set the
resolution to 'Wontfix' (but do not close). In case of 'OOo Later' or
'Wontfix' please reset it on Bettina's owner. Thank you.
Comment 4 niklas.nebel 2004-01-26 11:28:06 UTC
This is not on the list of features that we're going to do for 2.0. We need to
focus on the enhancements from the PCD document.
Comment 5 frank 2004-04-13 13:47:27 UTC
*** Issue 27635 has been marked as a duplicate of this issue. ***
Comment 6 frank 2004-06-28 08:49:46 UTC
*** Issue 30788 has been marked as a duplicate of this issue. ***
Comment 7 html 2004-07-03 18:43:41 UTC
<p>To approximate the desired behavior (clumsily): Select a rectangle of cells.
Go to Data --> Define Range. It wants a name; give it a name. Now, within that
range, you can hit Tab to move forward row-wise, Shift + Tab to move backward
row-wise, Enter to move down column-wise, and Shift + Enter to move up column-wise.
</p><p>
See <a href="http://www.oooforum.org/forum/viewtopic.php?t=10203">this
thread</a> at OOoForum.org.</p>
Comment 8 caiot1 2004-07-04 02:39:06 UTC
HTML:
You really is able to do this?
This workaround does not works for me.
OOo keep doing the same thing as without it.
I already am able to use Enter, shift-enter, tab, shift-tab and also the arrow
keys. But it does not return 'to the last filled cell'.
Comment 9 nomike 2004-07-05 08:06:05 UTC
> But it does not return 'to the last filled cell'.

No! It should not return to the last filled cell (or at least as a configureable 
option because this idea sounds good too!)
It should beheave somewhat like this:

global temp;

function cell_movement(keyUsed)
{
   switch (keyUsed)
   {
      case left_arrow:
         move_cursor: left;
      case right_arrow:
         move_cursor: right;
      case up_arrow:
         move_cursor: up;
      case down_arrow:
         move_cursor: down;
      case tab:
         move_cursor: left;
      case enter:
         move_cursor: column_of(temp):down;
   }

      
   if (keyUsed != tab)
   {
      temp = actual_cursor_position;
   }
}

Something like this...(with some special cases when multiple cells are selected 
etc.)

mfg
Nomike aka Michael Postmann
Comment 10 frank 2004-11-08 07:21:21 UTC
*** Issue 36811 has been marked as a duplicate of this issue. ***
Comment 11 frank 2005-09-15 11:26:46 UTC
*** Issue 53427 has been marked as a duplicate of this issue. ***
Comment 12 frank 2006-02-17 10:51:04 UTC
*** Issue 57615 has been marked as a duplicate of this issue. ***
Comment 13 herbalizer1 2006-02-17 11:36:57 UTC
I'm really sad, this feature wasn't implemented into Openoffice 2.0

I'm sure there's other important things, but this can't be too hard to code.
Comment 14 jbroth 2006-02-17 12:03:40 UTC
Now that 2.0 is out can this be added in at some point?

JB
Comment 15 frank 2006-02-21 13:54:16 UTC
*** Issue 62301 has been marked as a duplicate of this issue. ***
Comment 16 lars 2006-05-10 22:31:26 UTC
*** Issue 65263 has been marked as a duplicate of this issue. ***
Comment 17 frank.loehmann 2007-07-19 15:16:52 UTC
.
Comment 18 frank.loehmann 2007-07-20 12:45:27 UTC
Set target.
Comment 19 frank 2007-08-01 13:44:29 UTC
*** Issue 77011 has been marked as a duplicate of this issue. ***
Comment 20 frank.loehmann 2007-08-02 17:14:34 UTC
Please find the spec here:
http://specs.openoffice.org/calc/ease-of-use/Enhanced_Data_Input.odt
Comment 21 thomas.benisch 2007-08-22 14:55:07 UTC
reassigned to TBE
Comment 22 thomas.benisch 2007-08-22 14:55:44 UTC
accepted
Comment 23 thomas.benisch 2007-08-22 15:16:04 UTC
fixed on CWS calcdatainput

The following files are affected:

sc/source/ui/view/tabview3.cxx
Comment 24 thomas.benisch 2007-08-23 11:09:39 UTC
TBE->FST: Please verify in CWS calcdatainput.
Comment 25 frank 2007-10-09 10:48:44 UTC
Created attachment 48773 [details]
testcasespecification
Comment 26 frank 2007-10-09 10:49:25 UTC
found fixed on cws calcdatainput
Comment 27 frank 2007-12-11 14:47:40 UTC
found integrated on master m239 using Linux, Solaris and Windows build