Issue 15889

Summary: CellStyle Property "IsInUse" does not work after deleting Rows/Columns in a spreadsheet
Product: Calc Reporter: Oliver Brinzing <oliver.brinzing>
Component: codeAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
CellStyle "IsinUse" demo file ... none

Description Oliver Brinzing 2003-06-21 11:03:35 UTC
Hi,

There is a problem with the "IsInUse" Property of the CellStyles
After deleting some Rows/Columns, it does not work (always shows
false)

I will create an attachment ...

Ciao

Oliver

--

Sub StyleTest

	oStyleFamilies = ThisComponent.StyleFamilies
	oParagraphStyles = oStyleFamilies.getByName("CellStyles")

	for i = 0 To oParagraphStyles.getCount-1
		Print oParagraphStyles.getByIndex(i).displayName,_
			  oParagraphStyles.getByIndex(i).getName,_
			  oParagraphStyles.getByIndex(i).isInUse,_
			  oParagraphStyles.getByIndex(i).isuserdefined
	next

End Sub
Comment 1 Oliver Brinzing 2003-06-21 11:04:26 UTC
Created attachment 7027 [details]
CellStyle "IsinUse" demo file ...
Comment 2 oc 2003-06-24 13:36:21 UTC
Hi Stephan,
please have a look
Comment 3 oc 2003-06-24 14:03:05 UTC
Does also occur with the UI (stylist)
Comment 4 niklas.nebel 2003-06-24 18:14:36 UTC
accepting.
Comment 5 niklas.nebel 2003-09-11 15:27:22 UTC
This should have target "later".
Comment 6 oc 2003-09-22 11:20:50 UTC
According to the OpenOffice.org roadmap
(http://tools.openoffice.org/releases) this issue was retargeted to
OOo Later.
Comment 7 Oliver Brinzing 2006-02-17 13:25:03 UTC
Hi,

this issue is still valid for oo 2.0.2 rc1 ...

Oliver
Comment 8 Oliver Brinzing 2009-05-19 07:34:54 UTC
verified in oo 3.1 - are there any plans to fix it ?
Comment 9 Marcus 2017-05-20 11:13:27 UTC
Reset assigne to the default "issues@openoffice.apache.org".