Issue 15900

Summary: Ability to remote control presentations
Product: App Dev Reporter: josua <josua>
Component: apiAssignee: clippka
Status: CLOSED FIXED QA Contact: issues <>
Severity: Trivial    
Priority: P3 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description josua 2003-06-21 21:45:46 UTC
It would be nice to be able to remote control presentations. To advance to next
slide and go back to previous slide, from an other application using UNO. If it
could be possible to get thumbnails of the slides as well, it would be very nice.
Comment 1 ooo 2003-06-23 08:45:55 UTC
highly application specific API
Comment 2 clippka 2003-06-27 10:37:16 UTC
this would be nice but its not on our list yet. Maybe later
Comment 3 groucho266 2007-09-18 16:22:51 UTC
Changed target to OOo2.4
Comment 4 clippka 2007-11-12 12:41:53 UTC
this will not make it in time for 2.4, changing target
Comment 5 clippka 2008-01-10 10:37:25 UTC
fixid, interface announce will follow
Comment 6 clippka 2008-01-11 14:58:48 UTC
*** Issue 71351 has been marked as a duplicate of this issue. ***
Comment 7 clippka 2008-01-13 20:20:54 UTC
*** Issue 40844 has been marked as a duplicate of this issue. ***
Comment 8 groucho266 2008-03-06 12:05:32 UTC
Regarding the above request for thumbnails:
With the presenterview CWS there are two ways of creating thumbnails:

1. For single slides you can use the service
that implements the interface.

2. For implementing something like a slide sorter you can use the service that implements the interface.

Please see the IDL files in offapi for documentation of the two interfaces.

Comment 9 groucho266 2008-03-06 12:07:14 UTC
Used by the presenter screen extension in the sdext module to control a slide show.
Comment 10 groucho266 2008-03-12 13:37:46 UTC
Setting target to OOo 3.0.
Comment 11 thorsten.ziehm 2009-07-20 15:55:40 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
If you want to know more about the handling of fixed/verified issues =>