Issue 1641

Summary: Chart Translation from Excel - Various layout errors
Product: General Reporter: Unknown <non-migrated>
Component: chartAssignee: oc
Status: CLOSED IRREPRODUCIBLE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P4 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Windows 98   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
file after translation from excel none

Description Unknown 2001-09-07 23:18:54 UTC
Chart created using Excel 97, Win98
When opened in OpenOffice spreadsheet, following layout changes occurred:

y axis changed from 0 to -45000, to +10000 to -45000.  I believe this is 
because one data set extends to about +10000, but the graph was deliberately 
set to finish at 0.

In Excel X axis labels were at 90 deg. along the top; in OpenOffice they have 
moved to the bottom, are still at 90 deg.  but unreadable (there doesn't appear 
to be room for them)

Legend now shows "Column H, Column R, Colum T" instead of the descriptive 
labels in the original.

Line colour has changed for one plot, and has become a series of marker 
diamonds on the other plot (there are only two plots on the graph, both were 
lines)

Graphics line overlaid on the graph has disappeared.

Happy to send both graphs if it would help
Comment 1 Unknown 2001-09-07 23:29:42 UTC
Created attachment 500 [details]
file after translation from excel
Comment 2 oc 2001-10-17 13:23:20 UTC
Hi David,

please attach the original XLS-file as well to verify the problems. 
Comment 3 oc 2001-10-31 13:26:57 UTC
Hi David.
Here are some comments to your problems (please for future issues, 
please write only one problem per issue):
1. y axis changed from 0 to -45000, to +10000 to -45000
Not reproducible without the original xls-file.

2. In Excel X axis labels were at 90 deg. along the top; in 
OpenOffice they have moved to the bottom, are still at 90 deg.  but 
unreadable (there doesn't appear to be room for them)
Excel could put the labels at the top of the chart This feature is 
not implemented in OpenOffice.

3. Legend now shows "Column H, Column R, Colum T" instead of the 
descriptive 
labels in the original.
You could give each series an own name in Excel, in OO it is only 
possible to take the first cell of the series as header.

4. Line colour has changed for one plot, and has become a series of 
marker diamonds on the other plot (there are only two plots on the 
graph, both were lines)
Not reproducible without the original XLS-file.

5. Graphics line overlaid on the graph has disappeared.
Not reproducible without the original XLS-file.

For further evaluation, please attach the original XLS-file.

Greetings, Oliver
Comment 4 oc 2002-01-10 09:50:30 UTC
Closed because of missing feetback from user