Issue 1761

Summary: Zoom should align to center, not left
Product: Writer Reporter: elonen <elonen>
Component: editingAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: andreas.martens, christian.jansen, contact_marcos, informatique.internet, issues, jeongkyu.kim, kami911, khirano, kpalagin, kumiai, Mathias_Bauer, matthias.mueller-prove, mr_smyle, os_ooo, pagalmes.lists, peter, pgawrysiak, stp, utomo.prawiro, vion, www.openoffice.org
Version: 638Keywords: oooqa, rfe_eval_ok, usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Current OOo Writer display at 20% zoom
none
Proposed writer display at 20% zoom. Editing 3rd page.
none
Screen shot showing problems at full screen and non full screen
none
Screenshot of portrait and lanscape handling in MS Word
none
New OpenOffice "Centering" Functionnality... none

Description elonen 2001-10-02 23:34:35 UTC
The WYSIWYG page view should be centered, not left-aligned. This apparently 
can't be changed from the Options menu..?

To demonstrate, try 50% zoom on 1600 x 1200 resolution.
Comment 1 stefan.baltzer 2001-10-08 14:37:59 UTC
Reassigned to Falko.
Comment 2 falko.tesch 2001-10-11 08:10:59 UTC
Yes. I complete agree!
Comment 3 elonen 2002-01-07 21:00:45 UTC
Just a small update: this is not limited to Win2000, changed the OS and Platform to All.
Comment 4 lohmaier 2003-05-05 17:11:34 UTC
How is the status of this issue?

PS: please make this optional...
Comment 5 lohmaier 2003-05-05 17:11:58 UTC
*** Issue 13650 has been marked as a duplicate of this issue. ***
Comment 6 falko.tesch 2003-10-15 14:27:20 UTC
The WYSIWYG page view should be centered, not left-aligned. 
Comment 7 falko.tesch 2003-10-15 14:27:41 UTC
Please give approval for this evaluated OO.o 2.0 flagged issue. 
If you confirm with the target OO.o 2.0, then please keep it on your
owner (or the owner of the concerning developer) for implementation.
In case you want this issue for 'OOo Later', then please reset the
target milestone. If you decline the issue finally, please set the
resolution to 'Wontfix' (but do not close). In case of 'OOo Later' or
'Wontfix' please reset it on Bettina's owner. Thank you.
Comment 8 andreas.martens 2003-10-21 16:06:28 UTC
See issue 20203
Comment 9 andreas.martens 2004-01-21 16:50:58 UTC
Duplicate?
Comment 10 gawron 2004-01-21 21:51:35 UTC
Agree, duplicate. But this problem is not only about centering, also about 
arrangement of pages at low zoom - pages should not be presented as 
one "stripe" from top to bottom of the screen, but "tiled" instead to 
efficiently use all screen space. 
Comment 11 gawron 2004-01-21 22:08:55 UTC
Created attachment 12627 [details]
Current OOo Writer display at 20% zoom
Comment 12 gawron 2004-01-21 22:09:59 UTC
Created attachment 12628 [details]
Proposed writer display at 20% zoom. Editing 3rd page.
Comment 13 gawron 2004-01-21 22:13:38 UTC
Extending this idea further one might think of capability to set zoom levels 
separately for each page (or group of pages) and dividing window into 
sections - for example to have one page with table of contents at very small 
zoom, but always visible; or setting bigger zoom for text only pages, and 
lower zoom level for pages with digrams etc.
Comment 14 Oliver-Rainer Wittmann 2004-01-22 08:55:19 UTC
This issue will address the centering of the pages, if the zoom is low enough.
Thus, undo the summary text change done by gawron.

OD->gawron:
Thanks for your contribution and your idea for tiled pages in low zoom. But,
please setup a new issue for your idea. For OOo 2.0 it is only planned to
address the centering of pages.
Comment 15 gawron 2004-01-23 21:53:13 UTC
OK. See issue <A HREF=http://www.openoffice.org/issues/show_bug.cgi?id=24772> 
24772 </A>
Comment 16 Oliver-Rainer Wittmann 2004-02-16 15:42:06 UTC
OD->HB:
As discussed with AMA, You take over this issue.
Comment 17 pb 2004-02-18 06:45:19 UTC
At first we need a specification.
Comment 18 lohmaier 2004-06-10 18:23:21 UTC
*** Issue 29905 has been marked as a duplicate of this issue. ***
Comment 19 andreas.martens 2004-06-17 11:41:23 UTC
Because of a shortage of resources we have to retarget this issue to OOo later.
Comment 20 sgautier.ooo 2004-09-06 17:28:13 UTC
reassigning & adding keywords according to new RFE process - sophie
Comment 21 lohmaier 2004-11-17 00:23:30 UTC
*** Issue 20921 has been marked as a duplicate of this issue. ***
Comment 22 lohmaier 2004-12-30 12:03:57 UTC
*** Issue 39679 has been marked as a duplicate of this issue. ***
Comment 23 michael.ruess 2005-01-18 07:49:55 UTC
*** Issue 40840 has been marked as a duplicate of this issue. ***
Comment 24 lohmaier 2005-02-05 16:37:51 UTC
*** Issue 42099 has been marked as a duplicate of this issue. ***
Comment 25 gawron 2005-02-05 21:42:45 UTC
What is the status of this issue? There are many duplicates - it seems to me
that the problem is more important to users than it might seem at the first
glance (still - 13 votes is also significant). Is it still being targeted at OOo
later (means -> "god knows when")? OOo 2.0 will be compared with MSOffice - and
lack of multipage zoom (available in MSOffice since - I think - version 2) or at
least centering (available always :-) is, well...
Comment 26 martin_z 2005-02-06 20:56:17 UTC
Yes I'm also currious what is happenening with this issue. I would be so happy,
if  it got made.
Comment 27 rafaelda 2005-02-10 04:54:51 UTC
This issue is still present in 1.9.77.
Comment 28 aparan 2005-02-11 06:43:33 UTC
The general alignment of pages in OO.o should be 'centred' rather than left. If
any of the docked toolbars is placed to the left of the screen and the context
switches on the toolbar [bullet, numbering, picture, etc.] all of a sudden the
page jumps the right, which is unpleasant. 
Comment 29 wiltony 2005-03-28 04:36:26 UTC
This is the first thing I noticed upon install.  Very annoying to have a
zoomed-out document forced to the left side of my screen.  At least make it
optional, so that those who like it can keep it, no?
Comment 30 michael.ruess 2005-04-19 12:19:24 UTC
*** Issue 47726 has been marked as a duplicate of this issue. ***
Comment 31 lohmaier 2005-09-16 19:30:52 UTC
*** Issue 54372 has been marked as a duplicate of this issue. ***
Comment 32 cosmotron 2005-09-30 15:56:20 UTC
I would like this to be fixed, or at least made into an option.
Comment 33 michael.ruess 2005-10-31 10:38:09 UTC
*** Issue 57015 has been marked as a duplicate of this issue. ***
Comment 34 gnuyen 2005-11-03 07:52:49 UTC
Created attachment 31138 [details]
Screen shot showing problems at full screen and non full screen
Comment 35 gnuyen 2005-11-03 07:55:23 UTC
As widescreen displays become more popular, e.g. all macs, and an estimated 80%
of all laptops by 2009, this issue will become more and more important.  I
created an attachment using my dual head display to show the problem on
widescreen monitors.  The lack of ability to center results in a very jarring
display.  On the left is in fullscreen mode, and on the right maximized.
Comment 36 doo 2006-02-12 15:14:43 UTC
Come on, it's being continuously requested already 5 years.. is it impossible?
Comment 37 ycaps123 2006-03-08 20:08:20 UTC
I just used 2 of my 5 votes on this issue.  It is very important to me (and other people) to be able to 
view an entire page in a centered fashion.  As a teacher, I would use this feature for newsletter 
layouts, assignments, etc.  For me, it is very disconcerting to have the page on the left side instead 
of the center (I'm one of those people who have to have symmetry).  Maybe this can be addressed 
in 2.0.3?
Comment 38 lars 2006-03-12 15:10:56 UTC
*** Issue 63078 has been marked as a duplicate of this issue. ***
Comment 39 washburn1 2006-06-06 17:00:35 UTC
Well, I've signed up for an account just to comment on this issue, which seems
to be ignored despite repeated comments and new users starting new topics to let
you know this is a problem.  It looks bad, especially on wide screens zoomed
out--the way most people work nowadays.

The fact that this obvious usability issue is so persistently ignored speaks
poorly of OO, and indicative of an organization that has trouble addressing
basic usability issues.  This issue is symbolic of why I don't use Openoffice.  
Comment 40 ledomira 2006-06-12 11:01:04 UTC
Me too.  I would have used all my votes, since this is the only issue I care
about, but I could only use two.

Since I've lost my Microsoft Word cd, I've had no choice but to use OpenOffice.
 I've had to adjust the size of the application window and center it on screen
to adjust for this problem.  But I can't change the zoom or I have to resize and
reposition the window again.

Here's hoping the next version finally includes it.
Comment 41 alienhand 2006-08-22 00:19:38 UTC
Now fix it !!
Comment 42 betovarg 2006-08-29 18:17:50 UTC
I was looking for this particular matter on the neooffice.org forums. Good to
hear im not alone. We need this! its anoying having thah on the left with all
that space on a widescreen. 
Comment 43 hartvig 2006-09-25 21:09:25 UTC
Opened: Tue Oct 2 15:34:00 -0700 2001

The bug report for this is nearing its 5th birthday. There is no way this thing
can be THAT hard to fix (if I had any idea about coding I would do it myself and
then recompile OOo).

Someone tell me why something as essential for ease of your eyes have been
buried for FIVE years :/.

Let's get some more votes for this! :-)
Comment 44 sajer 2006-10-06 01:46:42 UTC
The 5 year wait for this issue and several other small bugs or annoyances, and
especially the feautures that OOo lacks but Microsoft Office had since 1997
makes me loose faith in OOo. Waiting for years and years and years for small
features is not worth it. Soon I will gladly pay for MSO; I don't even know if I
will ever see any of those features even if I pay for StarOffice.
Comment 45 gawron 2006-10-13 07:37:26 UTC
To celebrate the FIFTH anniversary of this bug I wrote a little piece here (also
about some other favorite bugs of mine) – http://gawrysiak.org/corvus/?p=6
Enjoy… /sarcasm/ and maybe post it to Slashdot, Digg it or whatever, perhaps
OO.o developers read these more often than bug descriptions /sarcasm/.
Comment 46 lore1 2006-10-16 22:40:40 UTC
Well nothing new concerning this issue in OOo 2.0.4. Big disappointment.
Could someone from development explain why? Is that issue meant to remain forever?
So many people requesting to fix that. So long. Nobody cares?
Comment 47 utomo99 2006-10-31 11:22:28 UTC
This issue already have some duplicate, oooqa, rfe_eval_ok, usability
and already 5 years old.

I hope it will assigned to somebody. and consider a target, maybe OOo 2.2? 

Thanks
 

Comment 48 kpalagin 2006-11-05 08:29:13 UTC
May I suggest that somebody sends pollite message to the lead of Wordprocessor 
project (http://projects.openoffice.org/accepted.html), asking to clarify the 
status of this issue?
Comment 49 lore1 2006-11-05 13:57:26 UTC
Well I addressed kpalagin´s request and sent the following email to Mr. Martens:

> Dear Mr. Martens,
> 
> I would like to ask you about the issue 1761 (Zoom should align to center, not
> left).
> 
> There are many users, that consider this issue to be greatly annoying. Further
> I rather don´t recommend OOo to my friends, in order not to discourage them at
> all, before this issue is solved. Because I believe, it´s simply the greatest
> and terrible hassle in OOo Writer. There are many concrete reasons and 
> complaints in concerning query.

> I decided to write you an email, because this issue is reported for more than
> 5 (!) years, without any progress. With each and every new release of OOo many
> of us waiting for a good news, having this problem solved. But still nothing.

> Therefore I would like to kindly ask you for change in this situation and let
> us know about the status of this issue.

> Thank you for all brilliant work,
> sincerely,
> Zbynek Petrik (lore1)
> Prague, Czech Republic
Comment 50 andreas.martens 2006-11-07 08:31:01 UTC
I've been asked to clarify what happens with this bug. Here is my reply (I hope,
all interested people are on the CC list):
I noticed the high number of votes and of duplicates to this issue and I'm cc'ed
on this issue, so I've read your comments as well.
Our plan was to have a centered view for OOo2.0. During the implementation we
realized that the effort would be quiet high. So we decided to spent our
resources to more important issues.
Our first goal was only to center the pages on screen, not to have more than one
page parallel like the idea supposed by gawron. This would be an effort of more
than 2 weeks of implementation. The problem is that we could have different page
widths in a document, so it's not only a shift of the whole doocument, we have
to do some more work. To implement a "cool" view with more than one page
parallel we would need even more weeks. Unfortunately it looks like the
implementation of a centered view does not help to get the "cool" view :-(
Currently nobody is working on this task. Of course we would like to solve every
problem but unfortunately our resources are limited. There are a lot of other
requests/bugs we have to take care of. For OOo3.0 our idea is to support a more
sophisticated view with parallel pages.

->aparan: You mentioned the problem of docking toolbars (at the left) which
causes the content to jump. I don't see an improvement by implementing a
centered view. Ok, the jump will be a little bit smaller (halfway of left
adjusted view), but OTOH toolbars docked at the right border will causes jumps
for centered view as well. For a left adjusted document toolbars at the right
border don't cause trouble. So the problem of jumping content becomes worse with
a centered view, doesn't it?

->gnuyen: Does it really helps, if documents are centered on widescreen
monitors? From my point of view we need the parallel page view as gawron
described. To have (big) grey areas on both sides of the document instead of a
very big one on the right side doesn't makes me happy for widescreen monitors.
Comment 51 lore1 2006-11-07 20:10:51 UTC
Thank you very much for letting us know. 
I believe, each task needs certain time, but on the other hand, this (1761) is
quite big trouble, especially for users with widescreen high-resolution monitor.

> Our first goal was only to center the pages on screen, not to have more than one
page parallel like the idea supposed by gawron.

That "primary" goal would be very satisfactory..!!

Maybe OOo team could introduce "specific-donation-system" - PayPal donations for
particular issues. I think you would become rich on this issue;-)
Comment 52 Mathias_Bauer 2006-11-13 09:10:31 UTC
.
Comment 53 Mathias_Bauer 2006-11-13 09:11:23 UTC
*** Issue 71474 has been marked as a duplicate of this issue. ***
Comment 54 matthias.mueller-prove 2006-11-13 12:22:22 UTC
I add my votes to this issue. Makes 81 now.
Comment 55 ik666 2006-11-22 14:32:07 UTC
This is currently keeping me from using OOo. It may "only" be a matter of 
aesthetics, but this is precisely the point. It is the small details that get 
to be annoying when workin at the screen for several hours.

So yes. Two large grey areas en each side of the page would be a lot better 
than one on the right.
Comment 56 dave54 2006-11-22 17:06:24 UTC
Please add an option to align the page center. Currently, to center the page,
you can zoom page width, but you can't see down the page because it's so big.
You can fix that by making the window skinnier, but now you can't see all your
buttons at the top. There is no replacement for aligning the page center. Please
add it as an option.
Comment 57 deadend 2006-12-14 20:29:56 UTC
Left alignment is reason #1 I'm not using OOWriter as my default editor but only
use it when I have to.
Comment 58 hake 2006-12-18 22:36:23 UTC
It's really a pain to work hours looking on the left.
Comment 59 anachreon_ 2007-01-03 03:31:20 UTC
I would simply like to agree with those who have said this is quite possibly the
most annoying bug in OO.o.  When running a display at 1920x1200, it simply feels
wrong to have to look that far to the left side of the screen.  I think many of
us would gladly paypal some money in to get this fixed. 

It's a shame to use MS Word (or something else) just to avoid this issue, but a
lot of us do.
Comment 60 hrp8264 2007-01-03 08:40:41 UTC
I would like to have things centered too, but on the other hand, now the canvas
is close to the ruler, both horizontally and vertically.
Comment 61 Mathias_Bauer 2007-02-02 17:50:07 UTC
I wonder if we could implement the feature in two steps. The most problematic
part is that every page might have a different width so that the additional
shift we had to apply to the displayed text may change with every page. This can
be solved only by a complete rewrite of the text and object positioning.

By only taking the first page and calculating an additional left offset to every
screen display (currently we have a fixed one) we could make the change quite
easy. This will help to solve the problem completely for most users and even for
users using more than one page style per document it would surely make it much
better.

Opinions, anyone?
The "real" fix (using object and text positioning relativ to the page borders)
could be done later, the single approach as outlined above could be done in a
2.3 time frame.
Comment 62 Mathias_Bauer 2007-02-02 17:52:19 UTC
grrrr...

Error in last sentence:

s/single/simple
Comment 63 lohmaier 2007-02-03 01:16:49 UTC
*** Issue 50137 has been marked as a duplicate of this issue. ***
Comment 64 alienhand 2007-02-03 10:03:38 UTC
Since it is impossible to unsubscribe this issue - I have changed my mail to a
fake one !! Fraged up system where you can't unsubscribe !!

No centering in Oo = dead system
Gonna install M$ office now

bye
Comment 65 Oliver Specht 2007-02-08 09:09:35 UTC
Reassigned to implement the first step - centering documents.
Comment 66 Mathias_Bauer 2007-02-08 10:28:12 UTC
Oliver, the next release for enhancements is 2.3
Comment 67 hartvig 2007-02-08 12:19:54 UTC
mba, I believe most of the people here consider this a bug fix, not an
enhancement. Please reconsider as a *bug fix* for 2.2.1 e.g. for the first
release possible!

God knows OOo writer is utterly useless for me until this is fixed as there is
no way in hell I will put that kind of strain on my neck (having to look
slightly to the left all the time is just not good for your pose while sitting
in front of a computer).
Comment 68 Mathias_Bauer 2007-02-08 12:27:11 UTC
This is not my decision, it's up to the release committee to decide this.
We have the rule to add only small bug fixes and urgent fixes to 2.2.1. So at
least currently we aim for 2.3 and that's the reason why I changed the target.

If the code changes made by Oliver turn out to be simple and safe(!) I will ask
the release committee to accept the fix for 2.2.1.

The idea behind our new release model is that the amount of work (and especially
the QA work) to be done on the micro release will be very small. Especially
nothing should be integrated that has a significant regression risk. Without
seeing the code changes for this issue it's impossible to judge the regression
risk so we have to wait and decide later on.
Comment 69 Mathias_Bauer 2007-02-08 12:34:25 UTC
BTW: You don't need to stress your neck. As long as Writer can't display more
than one page(*) on a wide screen monitor I don't see a reason to use maximized
Writer windows. Until we deliver the fix you can center your complete window and
Writer will remember this position.

Please don't misunderstand me: I don't recommend this as a replacement for the
missing enhancement, but as a workaround for it that should allow you to
"survive" until the fix will be available.

(*) See issue 1598.
Comment 70 gawron 2007-02-08 12:35:36 UTC
And what is the timeframe (ie. estimated release dates) for 2.2.1 and 2.3
respectively?
Comment 72 hartvig 2007-02-08 12:44:00 UTC
mba, ok - I fully understand there will be other things to take into account.
I'm just happy that it seems like there is finally something being done about
this issue and well, I would just like to see it done as soon as possible :-).

I would like to say thanks to both you and "os" for taking an interest in the
matter. Hopefully it will be resolved soon :-)
Comment 73 hartvig 2007-02-08 12:50:41 UTC
mba, of note, I do know I can just make the window smaller and center it
manually, however sometimes I want to use a fullscreen window, which makes this
solution an annoyance, as I then have to do window management everytime I want
to zoom out / zoom in on a document besides just zooming. 

I've tried this, unfortunately it was still a showstopper as to how I work with
documents and I had to go back to MS word, which annoyed me as well heh. Anyway,
worthwhile suggestion for people that might not be as annoyed about this. I do
however think most people work with writer / word as I do: with a fully
maximized window :-).
Comment 74 xca1019 2007-02-08 18:37:50 UTC
@os / mba: So just to confirm - you are planning to address this issue in 2.3
(or 2.2.1 if it turns out to be a minor change and one can convince the QA guys)? 

I was bothered enough to spend some time over the last days to setup a build
environment for the sources from [1] and got the first build (of the unchanged
sources) running yesterday. So I was going to give this issue a try, but of
course it would be much better if an experienced OO developer is going for
implementing this patch.


[1] http://download.openoffice.org/2.1.0/source.html
Comment 75 Mathias_Bauer 2007-02-12 13:45:01 UTC
@xca1019: yes, this will be fixed in 2.3 - in the way that I described. We don't
center each and every page but the whole document. So if you have a landscape
and a portrait page in the same document the landscape page will be centered,
the portrait page will be positioned *slightly* moved to the left.

This way we fix the problem perfectly for 90+x% of the users (I doubt that x is
smaller than 5) and make it (IMHO) acceptable for the rest (those who have more
than one page width per document). And we get this with only a few days effort! 

The complete fix (centering each and every page exactly) would take several
weeks development time, mostly because we assume that we get a lot of side
effects we have to fix. We don't see this worth the effort. Now we more time to
work on some other highly demanded RFEs. :-)

So we would like to get the complete fix for free when we will have fixed issue
1598. 
Comment 76 Peter Lairo 2007-02-12 14:13:40 UTC
"So if you have a landscape and a portrait page in the same document the
landscape page will be centered, the portrait page will be positioned *slightly*
moved to the left."

Why would it be shifted? 

If the whole document is centered, presumably on the widest (landscape) page(s),
and the portrait pages are centered relative to the landscape page(s), then
shouldn't the portrait pages also be centered relatively to the view area?

Professionals that write (longish) reports will frequently have mostly portrait
pages, but also a few landscape pages (e.g., data tables). Therefore, I hope
your "slightly" means "barely noticeable", because looking at *mostly*
noticeably left-shifted portrait pages is highly annoying.

OT: Having used mozilla's bugzilla, reveals that this IssueZilla has some
annoying deficiencies: (1) the forced left menu makes the usable horizontal
"bug"-space too narrow, (2) can't link to comments, (3) comments aren't numbered
for reference, (4) can't reply to (quote) a comment, (5) the date format is hard
to read (the time is between month and year - WTF), (6) bug's title is not in
window header or bookmark, (7) no proper names for commentors, (8) e-mail is
munged to name@openoffice.org.
Comment 77 Mathias_Bauer 2007-02-12 14:22:56 UTC
Slightly means: it depends on the width of your screen. In the worst case it is
the same as now, the "portrait" page is left aligned with the "landscape" one,
the latter being centered. If you screen is big enough to leave space on the
left side of the landscape page the portrait page does look a bit better than now.

So there are cases where the situation isn't much better than now. We think that
this is a problem only for a few percent of the users and doesn't judge to
invest a lot of work we could better use for RFEs where a much larger percentage
of users will benefit. 

So we will leave the fix for this remainder for a later version where we
implement the ability of having more than one page per window and get the
centering for free as in this version we must be able to put any page anywhere
on the screen. But this is a much bigger effort.

Comment 78 Peter Lairo 2007-02-12 15:46:01 UTC
Most people have a resolution of 1024x768, and only 26% have a resolution higher
than that(1)! I'm guessing the most common monitor size is 17" (with very few
larger than that).

In Microsoft Word a very comfortable (and likely the most used) zoom-factor for
portrait documents is 100%, which (at 1024x768 and 17") leaves only *very
little* extra space on the left and right. If a landscape page exists, in OOo,
this would almost always cause the portrait pages to be very noticeably
non-centered (likely even along the left edge). Therefore, I think the most
common case will *not* be what you claim will affect "a few percent of the
users", but will be quite the opposite: it will affect the vast majority of
users. It is indeed what you  call the "worst case".

Microsoft Word's handling is very effective: The portrait pages remain
centered(!!!) and the landscape pages, if there is not enough space to be
centered, are left-aligned and extend to the right as far as needed (farther
than to the left). 

The advantages of this method are:
1. (the most common) portrait pages are centered.
2. The landscape pages are not cut off on the left (where the most relevant
portion usually is)

Bonus points: If the user selects zoom-level="page width", then OOo should
rescale the page *as* the user scrolls from a portrait to a landscape page (and
vice-versa). Microsoft Word doesn't do this (yet). ;-)

(1) http://www.w3schools.com/browsers/browsers_stats.asp
Comment 79 Peter Lairo 2007-02-12 15:49:02 UTC
Created attachment 42956 [details]
Screenshot of portrait and lanscape handling in MS Word
Comment 80 Mathias_Bauer 2007-02-12 17:12:40 UTC
@peter:

> If the whole document is centered, presumably on the widest (landscape) 
> page(s),and the portrait pages are centered relative to the landscape page(s),
> then shouldn't the portrait pages also be centered relatively to the view area?

The problem is that we can't handle different left page borders without
rewriting large parts of the layout code view code. In our current code all
pages must start at the same x position of the screen. The current fix for this
issue where we just add a constant additional left border to all pages
(calculated from centering the widest page of the document) is very easy and
helps in all cases where you don't have alternating page widths. My assumption
is that this is true for the vast majority of documents. 

> Most people have a resolution of 1024x768, and only 26% have a resolution 
> higher than that(1)! I'm guessing the most common monitor size is 17" (with
> very few larger than that).

Fine, so if these numbers are correct (where did you get them from?) only 26% of
the users have any real problem with the current behavior at all. On my 1024x768
notebook screen and 100% zoom factor the difference between a centered and a
non-centered page in format "portrait" is ca. 2 cm on the screen. For larger
zoom factors there's no difference between centered and non-centered view at
all. That's definitely not a big issue. 

> Microsoft Word's handling is very effective: The portrait pages remain
> centered(!!!) and the landscape pages, if there is not enough space to be
> centered, are left-aligned and extend to the right as far as needed (farther
> than to the left)

Word seems to behave differently here, depending on the zoom factor. On my
1280x1024 monitor and 100% both pages (portrait and landscape) are centered
while at 150% only the portrait page is centered and the landscape page is left
aligned to the portrait one. I assume that on your monitor you will get both
pages centered if you use a zoom factor smaller than 100%.

We can't do the same as we currently lack the ability to place pages on
arbitrary places on the screen (something that due to the effort is planned for
a later version covered by issue 1598).

But you are right, there could arise a new problem for users with smaller
screens. Thanks for pointing that out before we had to fix that later on. So
perhaps we could center the document not in all cases (only in case the empty
space exceeds a certain value and the document has alternating page widths) or
we should allow to switch centering off manually (I prefer the first option). 

That means in the example in your screen shot where a portrait and a landscape
page are shown above each other we wouldn't change anything to the current
behavior (the portrait page will stay a little bit off-center) but in case the
user has a 1280 or 1600 pixels width the document will be centered as planned.

Comment 81 cosmotron 2007-02-12 17:56:20 UTC
I think that as long as the portrait view is centered, that will please the most
amount of people at once.  At the same time, still work on the cases where
people are mixing protrait with landscape, but I don't think that it has to be
perfect all at once.
Comment 82 cppm 2007-02-13 00:06:08 UTC
I would -really- like this in OpenOffice, I don't think the development guys 
understand just how badly this has reflected upon OpenOffice look

When you open writer for the first time the first thing that strikes you is how 
odd it looks, and then you realise you are staring at one hell of massive, 
super visible bug that stands out like a elephant with diarrhoea in a china 
shop... in norway

It has been enough to make Word users go white in the face, well I exaggerate, 
but they have such an odd look on their face, like they've smelt something 
rotten, and it's coming from my computer... :(

Please please fix sooner rather than later this so my freinds who have become 
addicted to the 'Ribbon' of Office 2007 (which by the way OOo needs to develop 
a competing GUI revolution to answer to that piece of heresy) stop sniggering 
and pointing behind my back... it really is that shameful

note: perhaps make it optional though, I can imagine that some people would 
like it like that...
Comment 83 cppm 2007-02-13 00:18:00 UTC
PS: when you talk about this issue affecting only "26%" of users, it at least 
has a significantly noticable effect on the look and feel of OOo on my laptop, 
which doesn't have an uncommon screen resolution for laptops these days. I'm 
telling this to you after I realised just how much of a relief it was to return 
to MS word for a bit.
Comment 84 ori_l 2007-02-16 20:34:58 UTC
Like other users, I've fired up Word today at work and wow, what a relief -- a
centered page! I can't begin to tell you how annoying it is to not have this
feature. This is a deal-breaker for me. I'm through with OO.org until this is fixed.
Comment 85 Mathias_Bauer 2007-02-16 22:01:41 UTC
Please read at the least the last comments before you add comments that don't
add anything to the work to be done. You should be able to read that we are
already working on it. So keep your energy for other issues. :-)
Comment 86 sajer 2007-02-20 22:54:23 UTC
"Fine, so if these numbers are correct (where did you get them from?) only 26% of
the users have any real problem with the current behavior at all."

Only 26 % of your users affected ... that doesn't worry you guys. Its obvious
that you don't have paying costumers.

Don't expect screen resolutions to go down, and don't expect your attitude to do
you any good.
Comment 87 Mathias_Bauer 2007-02-21 07:28:34 UTC
First: we *have* also paying customers that use StarOffice. BTW: interestingly
none of them ever asked us for a centered view. They usually are more interested
in other things. Despite of this we already have implemented a centered view for
OOo2.3 (QA approval provided).

You really should have read all comments here before expressing such unbalanced
view. The 26% came from a user, not from a developer. I just took it as a sign
that the number of users that will not be satisfied by our not perfect solution
we have developed now for OOo2.3 will be even less than the ~5% I expected as a
rough guess. Try to read and understand what was written here. 

In OOo 2.3 we will always have a centered view for all cases where documents
don't have alternating landscape and portrait formats. This will be the vast
majority of documents written by our users. And from the small number of
documents that have both portrait and landscape pages where only the latter will
be centered only a fourth of the user base will be able to feel the problem if
the 26% are correct as on small monitors the non-centered view is even less
important.

If you consider that also not everybody sees the absence of a centered view as a
problem at all (like me or obviously our paying StarOffice customers) it's a
good estimation that only a few percent of all users will not be satisfied by
what we will have in OOo 2.3. 

I don't understand why so many people don't read the whole comments written here
(especially those of the developers) but instead pick a single remark of their
choice without even understanding the context it was put into and then write
just what comes into their mind. This is not very helpful and mainly nonsense as
in case of the last comment.

Folks, please read and understand what was written so far if you want to be
taken seriously. 
Comment 88 Oliver Specht 2007-02-21 08:56:03 UTC
Fixed in cws os92 in
sw/source/ui/uiview/viewport.cxx
sw/source/core/view/viewsh.cxx
Comment 89 cppm 2007-02-21 16:07:20 UTC
Yay fixed

can't wait till 2.3 then :D

Sorry if my comments annoyed you mba, just the perfectionist in me has found 
this annoying for quite some time. And I've found this to be a barrier to 
getting people on the OO bandwagon. With this fixed people will have to look 
closer to find something 'wrong' with the look 'n' feel.
Comment 90 michaelvd 2007-02-21 16:18:08 UTC
> With this fixed people will have to look closer
> to find something 'wrong' with the look 'n' feel.

I'm sure they'll find something ;-)

Good thing I bought a 20" screen just in time to see this new feature in 
action once it's released!
Comment 91 merschmann 2007-02-21 17:21:42 UTC
Please use dev@sw.openoffice.org for any discussion.
Issuezilla should be reserved for the technical part of this issue.
Comment 92 Oliver Specht 2007-03-02 09:36:40 UTC
Reassigned for verification
Comment 93 michael.ruess 2007-03-09 12:26:22 UTC
Reopening issue, a problem when switching the zoom factor remains to be fixed.
Comment 94 michael.ruess 2007-03-09 12:40:46 UTC
MRU->OS: when changing the zoom e.g. from 50% to 200% the view will be shown
wrong. When then grabbing the horizontal scroll bar, the view will jump into the
correct position.
Comment 95 Oliver Specht 2007-03-13 15:13:36 UTC
Fixed in viewport.cxx
Comment 96 Oliver Specht 2007-03-13 15:14:39 UTC
Reassigned for verification
Comment 97 pagalmes.lists 2007-03-13 15:27:33 UTC
Is there a snapshot planned to test the new behaviour?
Comment 98 michael.ruess 2007-03-14 16:10:28 UTC
Verified fix in CWS os92.
Comment 99 washburn1 2007-03-24 04:01:58 UTC
I see some people have worked on this.  Many thanks!  One question though: If
it's already a verified fix, might it be possible to include it in the 2.2
release?  I just looked at the main page, and they're still on the 2.1 release,
so 2.3 is presumably a long time away.

Alternately, are there somewhere "beta" versions can be downloaded ahead of
time, or a way to patch the fix on a 2.1 install?  I'd like to try using OO
again soon, but I will wait 'til 2.3 if necessary... 
Comment 100 Mathias_Bauer 2007-03-25 19:07:53 UTC
No, this is impossible. 2.2 is already overdue.
Comment 101 hubertf 2007-04-04 07:41:16 UTC
I've downloaded the new dev snapshot at
http://download.openoffice.org/680/index.html and the issue is still there,
where can i download a linux build with this fix...

We are  really impatient to see how this problem was finally fixed... 
Comment 102 Mathias_Bauer 2007-04-04 08:25:44 UTC
The Child Workspace os92 containing the changes is still not integrated. Once it
is done the QA engineer will add a comment to this issue that it is "verified in
master". This will show you the milestone build where you can take a look.
Comment 103 matthias.mueller-prove 2007-04-04 12:57:17 UTC
for the record (and instead of a specification): If the horizontal scrollbar has nothing to do then the page 
will be centered in the window. Otherwise we keep the behavior from previous OOo versions (ZoomIn 
bahaviour will not be changed.)

See Oliver, what I mean -- specifications can really be short, clarify the issue and drive issues home.
Matthias /user experience team
Comment 104 matthias.mueller-prove 2007-04-05 11:59:08 UTC
Version 2 of the spec text:
If the horizontal scrollbar has nothing to do then the pages 
will be centered in the window. Otherwise we keep the behavior from previous OOo
versions (ZoomIn bahaviour will not be changed.)

The center of the pages is defined by the half width of the widest page of the
document (pages can also be in landscape orientation, right?).

Then all pages are aligned to the left border of the widest page.
Comment 105 michael.ruess 2007-04-11 06:45:35 UTC
*** Issue 76234 has been marked as a duplicate of this issue. ***
Comment 106 norbert2 2007-04-14 19:29:12 UTC
mmp wrote: "Then all pages are aligned to the left border of the widest page."

If I remember correctly, MS Word centers all pages. So a "Portrait" pages are
centered to the middle of a "Landscape" pages.

Why not adopt this?
Comment 107 Mathias_Bauer 2007-04-15 12:39:11 UTC
This has been answered here several times. Please read.
Comment 108 michael.ruess 2007-04-19 10:49:24 UTC
Checked in SRC680m209 for OOo 2.3.
Comment 109 hubertf 2007-04-23 10:18:18 UTC
you said : "Then all pages are aligned to the left border of the widest page."

Why all pages aren't simply centered in the viewport instead? Can you explain
(and argue) your choice

Thanks

Ok, i read comments and found this one :
"If you consider that also not everybody sees the absence of a centered view as a
problem at all (like me or obviously our paying StarOffice customers) it's a
good estimation that only a few percent of all users will not be satisfied by
what we will have in OOo 2.3.
"
So, i undertand that in fact you dont care having a weird (if not ugly) behavior
for those who will have mixed portraits/landscape mixed documents.

Do you always do things like that?
I mean, implement half of the functionnality, considering that there will be few
people that will complain about lacks?
Every functionnality in this software are thought like this? Well done guys!
Great! Good Job! Award for this!
=> Think about it twice please.
Comment 110 hubertf 2007-04-23 10:20:47 UTC
Created attachment 44604 [details]
New OpenOffice "Centering" Functionnality...
Comment 111 gawron 2007-04-23 10:29:22 UTC
True... looks abysmal. What about reopening this bug then (or should someone
create new bug issue for this)?
Comment 112 hubertf 2007-04-23 10:38:29 UTC
it would be better to reopen this bug, because the functionnality as been "half
implemented"
Comment 113 Oliver Specht 2007-04-23 10:45:24 UTC
->hubertf: Please read again the comment from mba from Fri Feb 2 17:50:07 +0000
2007 
Comment 114 hubertf 2007-04-23 11:16:42 UTC
Ok i understand mba's point of vue...
but I think this bug must remain open until this functionnality is fully
implemented. 
Comment 115 Oliver Specht 2007-04-23 11:36:08 UTC
->hubertf: No, there's no use in reopening this issue. It would then be closed
as wontfix. The next step is the already mentioned issue 1598
Comment 116 Mathias_Bauer 2007-04-23 16:57:24 UTC
I hope you don't misunderstand Oliver's comment: "WONTFIX" doesn't mean that we
don't want to implement the feature. It just means that we don't want to fix it
as a separate issue. This would take us several weeks extra development time.

As Oliver said: the "completely centered view" implementation will be a nice
"side effect" of implementing issue 1598. The problem we have to solve for both
is the same: all objects in the text document are painted relative to the window
boundaries but we must position them relative to the boundaries of the page they
are lying on.

So everybody who really thinks that the solution we will provide in 2.3 is not
enough for them should vote for issue 1598.
Comment 117 norbert2 2007-05-06 10:09:57 UTC
The implementation is buggy:  Issue 76699
Comment 118 Mathias_Bauer 2007-05-06 12:30:39 UTC
Well, let's call it a collision between two features. :-)
Thanks for finding it!
Comment 119 lore1 2007-09-20 00:02:30 UTC
Thanks guys, I´ve waited for this for more than year. It´s cool now.
Comment 120 mr_smyle 2008-02-02 23:54:37 UTC
2.3.1 There is option to align page to left!? I WANT to left!!

or is it "hard to implement"?
Comment 121 Mathias_Bauer 2008-02-03 12:01:19 UTC
This option won't get implemented.

The overwhelming majority of our users seemed to want what we got now - a
centered view. Adding more options always makes code more complicated and more
error prone and it adds UI clutter. You can't make everything configurable, this
should be reserved for situations where the demand seems to be high enough.