Issue 17874

Summary: Select All failure when text body begins with a table
Product: Writer Reporter: schwarzenberg <schwarzb>
Component: codeAssignee: h.ilter
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1 RC2Keywords: oooqa
Target Milestone: ---   
Hardware: Sun   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description schwarzenberg 2003-08-05 08:01:45 UTC
When a table is the very first element of the text body of a document then
"Edit->Select All" always selects ONLY that initial table. It doesn't matter
where the cursor is, even when the cursor is in the following plain text part
only the table gets selected.

As soon as there is a single (empty or nonempty) line or more text before the
table "Select All" works as expected (selects the whole text body including the
table).

Bug found in Linux and Solaris.
Comment 1 rblackeagle 2003-08-05 21:18:41 UTC
Same thing here (linux, RC2).  I guess I should have filed an issue
for it, but I'm glad you did.
Comment 2 lohmaier 2003-08-05 22:32:46 UTC
duplicate.

*** This issue has been marked as a duplicate of 7747 ***
Comment 3 lohmaier 2003-08-05 22:33:17 UTC
closing duplicate.