Issue 18247

Summary: MSInteroperability-18: background page colours
Product: Writer Reporter: caolanm
Component: codeAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 1.1 RC3   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 18771    

Description caolanm 2003-08-15 09:46:27 UTC
Support im and ex of page background colors from/to .doc
Comment 1 caolanm 2003-08-15 17:44:43 UTC
Accepting this issue.
Comment 2 caolanm 2003-08-28 09:47:23 UTC
Set Target
Comment 3 caolanm 2003-08-28 12:26:39 UTC
Hmm, only word 2003 can truly have background colours, otherwise its
only background colours for htmlview. There is a new compatability
flag in 2003 which says to use this colour for pagepreview mode.
Interesting.
Comment 4 caolanm 2003-08-28 13:14:33 UTC
So: 
A: Only 2003 can truly have background page colours
B: And only one colour for all pages (we'll export the standard page
style's bg)
C: Word's bg is drawn as filling the entire page, not just the
printable area

With these provisios in mind, this is implemented in
killarneyfilterteam13 for 2.0
Comment 5 caolanm 2003-09-16 13:08:37 UTC
reopen to reassign.
Comment 6 caolanm 2003-09-16 13:11:54 UTC
cmc->mru: If you don't have 2003 only import and reimporting into
writer will work naturally. 97 doesn't have the feature at all I
think, in other versions of word you will have to go to view->web
layout to see the bg colour.
Comment 7 michael.ruess 2003-09-19 14:08:15 UTC
checked new feature in CWS filter13.
Comment 8 michael.ruess 2003-09-19 14:08:25 UTC
Verified.
Comment 9 Rainer Bielefeld 2003-10-17 07:09:25 UTC
Hi mru, 

can you please have a look on issue 19630 and issue 17501 ?

May be they are duplicates of this one (I am not sure) and so they
might be fixed.

Rainer
Comment 10 michael.ruess 2004-02-27 14:01:01 UTC
*** Issue 25715 has been marked as a duplicate of this issue. ***
Comment 11 michael.ruess 2004-04-27 13:51:04 UTC
Closed, fixed in current OO 2.0 snapshot.

Issue 17501 is ma duplicate of this, though it is not marked as this.
Issue 19630 refers to graphic filters and is not related to this problem here.