Issue 18325

Summary: Click on link to anchor/bookmark in HTML docs fails
Product: Writer Reporter: Unknown <non-migrated>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, tamblyne
Version: OOo 1.1 RC3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Unknown 2003-08-17 22:36:10 UTC
When HTML files are set up to open in Start OpenOffice.org, clicking a hyperlink in one HTML file 
will bring up the HTML file that it links to (all inside OO). The only problem is when the hyperlink is 
to an anchor (bookmark) in the other HTML file. In that case, clicking the hyperlink should bring up 
the other file in OO with the cursor at the location of the anchor (bookmark), like with MS Word, 
but it instead does nothing. The following example has HTML from two files, one of which links to 
an anchor in the other:

In "OO1.html":
<A HREF="OO2.html#here">Go there</A>

In "OO2.html":
<A NAME="here"></A>here</P>

Fixing this error would make OO as powerful as Word in linking HTML files to each other, 
surpassing the WYSIWYG HTML editors Dreamweaver and GoLive in this respect.
Comment 1 tamblyne 2003-08-19 16:15:16 UTC
Confirmed WinXPPro/1.1rc3 per reporter's instructions.  

Clicking on link in 0001.html produces "not found" error in OOo.  

Defect or RFE?  
See slightly different RFE filed by reporter Issue 16547

Tam  

Comment 2 h.ilter 2003-08-20 11:26:11 UTC
Reassigned to ES
Comment 3 stefan.baltzer 2003-09-12 15:22:23 UTC
SBA: Adjusted Version from 1.0.3 to OOo 1.1 RC, PLatform and OS to
"All" according to recent findings. Adjusted Summary to summarize the
findings. Target set to OOo 2.0
Comment 4 eric.savary 2004-04-21 11:31:21 UTC
ES: as described. the click on a hyperlink does not follow the URL until the anchor.
Comment 5 andreas.martens 2004-04-26 16:55:48 UTC
I don't see a volunteer to solve this problem for OOo2.0?!