Issue 18927

Summary: Macro recorder dont recognize bookmarks.
Product: General Reporter: nilsolov <no>
Component: scriptingAssignee: AOO issues mailing list <issues>
Status: CLOSED NOT_AN_OOO_ISSUE QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, flibby05, issues, pagalmes.lists
Version: OOo 1.1 RC3   
Target Milestone: AOO Later   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 81517    

Description nilsolov 2003-09-01 22:58:15 UTC
I was trying the macrorecorder to record filling out a text document at certain 
bookmarks. I used the navigator and doubleclicked on the bookmark I wanted to go to 
and then I entered the text. When I looked at the macro I saw that the text entries was 
recorded but not the interviening moves to new bookmarks.
Comment 1 noel.power 2003-09-02 09:01:51 UTC
Mathias,
Wild guess that this is a framework issue ;-)
Comment 2 Mathias_Bauer 2003-09-05 10:06:32 UTC
Currently the recorder does not record any movements that are not
caused by keyboard commands. This is a well known restriction and was
communicated several times.

So this issue is more an enhancement request. I hope that we can add
this enhancement for OOo2.0, but it needs a concept for recording
position or selection changes, fixing every single occurence doesn't
really help.
Comment 3 Mathias_Bauer 2003-10-01 11:07:04 UTC
Targetting Macrorecorder bugs is postponed until we have broader feedback.
Comment 4 thorsten.martens 2003-10-22 09:14:42 UTC
Set target to OOo Later.
Comment 5 andreas.schluens 2004-01-30 14:22:42 UTC
.
Comment 6 Rob Weir 2013-07-30 02:37:21 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.
Comment 7 Edwin Sharp 2014-02-25 19:05:30 UTC
See help for Limitations of the macro recorder