Issue 18930

Summary: selecting multiple graphics with SHIFT key in writer not working reliably
Product: Writer Reporter: firmail <firmail>
Component: uiAssignee: Oliver Specht <os_ooo>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, rb.henschel
Version: OOo 1.1 RC4   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description firmail 2003-09-01 23:21:31 UTC
When muliple graphics (i.e. 2 sqares made in draw and copied into a writer
document) are to be selected then the SHIFT key does not always work.

If the graphics are copied into a writer document and imediately selected, then
everything works fine. If however text is selected (i.e. a word double clicked)
in  between then after clicking one graphic and then holding the SHIFT key and
clickint the other graphic to select them both, does not work.

Only if a character is entered again in writer, then the two graphics can again
be selected with the SHIFT key.
Comment 1 jack.warchold 2003-09-09 16:19:32 UTC
jw: reassigned to jw
changed target to 1.1.1
changed os to all
changed platform to all
changed version to OOo1.1RC4
changed status to new

could reproduce with OOo1.1RC4
works in OOo1.0.3
Comment 2 jack.warchold 2003-09-10 13:04:30 UTC
reassigned to hbrinkm
Comment 3 andreas.martens 2003-09-15 14:43:14 UTC
It should be yours, not Henning's.
Comment 4 Oliver Specht 2003-10-17 15:09:29 UTC
Target OOo 2.0 seems more appropriate
Comment 5 knackaerts 2003-11-06 10:45:30 UTC
Related problem?

Put two images in an empty writer document
Select the selection tool in the draw toolbar
Try to use a select box to select both images
I see the box, can change size, but no images are selected.

Kris
Comment 6 andreas.martens 2004-06-17 14:57:42 UTC
Because of a shortage of resources we have to retarget this issue to OOo later. 
Comment 7 michael.ruess 2005-01-03 08:31:53 UTC
*** Issue 39729 has been marked as a duplicate of this issue. ***
Comment 8 jsveiga 2009-08-13 20:11:36 UTC
This is still there in 3.1, specially so for pictures inserted from file
(Insert, Picture, From File), and the typing text workaround does not work for
this case (it does, sometimes, for drawing object).

Interestingly, the Help says this should work:
"To group objects
1.Select the objects together that you want to group. Hold down Shift while you
click the individual objects.
2.Right-click any of the selected objects to open the context menu.
3.In Impress or Draw, choose Group. In Calc or Writer, choose Group – Group. "

Additionally, there's a weird behavior if you bring images from Draw:
1 - Insert two pictures from files in Draw, select them both, Copy
2 - Paste them in Write (they come grouped)
3 - Right-click, ungroup them 
NOW you can click on one, then shift-click on other to select them both and then
right-click, group them back. If you insert both pictures from file directly in
Write, you can't multiple-select them.

Also, if you create two drawing object in Write (say, two rectangles, or two
textboxes), it is possible to shift-click and multiple-select them UNTIL you
insert a picture from file, then no longer.

In other words, inserting an image from file in the Write document seems to
break the multiple selection (shift+click), not only for the image, but for
other objects.
Comment 9 stephan66 2009-11-16 21:40:33 UTC
I just put in a vote for this issue on behalf of several colleagues at my office. 

They noticed that copying a picture and the drawing objects to draw (2 separate
actions of course, as you can't SHIFT-click to select them together) and copying
them back to writer makes the problem disappear.
Comment 10 Regina Henschel 2012-06-26 13:51:59 UTC
(In reply to comment #8)
> This is still there in 3.1, specially so for pictures inserted from file
> (Insert, Picture, From File), and the typing text workaround does not work
> for this case (it does, sometimes, for drawing object).

That is a missing feature and the feature request is already in issue 17860.

> 
> Additionally, there's a weird behavior if you bring images from Draw:
> 1 - Insert two pictures from files in Draw, select them both, Copy
> 2 - Paste them in Write (they come grouped)
> 3 - Right-click, ungroup them 
> NOW you can click on one, then shift-click on other to select them both and
> then right-click, group them back. If you insert both pictures from file directly
> in Write, you can't multiple-select them.

The reason for this is, that a picture inserted from Draw is a drawing object and a picture inserted directly is not a drawing object.

> 
> Also, if you create two drawing object in Write (say, two rectangles, or two
> textboxes), it is possible to shift-click and multiple-select them UNTIL you
> insert a picture from file, then no longer.

That is a bug which is tracked in issue 118137.

*** This issue has been marked as a duplicate of issue 17860 ***
Comment 11 Regina Henschel 2012-06-26 13:52:45 UTC
Closing in favor of issue 17860. Please move your votes.