Issue 19285

Summary: Right to left (vertical) handling behaviour is unpredictable
Product: Writer Reporter: acli <acli>
Component: codeAssignee: ulf.stroehler
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1 RC4   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Expected display
none
Unexpected ("wrong") display none

Description acli 2003-09-08 21:49:19 UTC
I start by typing some Chinese text and then proceeded to change the writing
direction via Format | Page => Writing direction => Right to left (vertical).

Now I select the text I typed and try to change the font. It turns out that for
a lot of fonts, OpenOffice does not correctly rotate the CJK characters.
However, for *some* fonts, OpenOffice does correctly rotate the CJK characters.

I don't see any pattern as yet, as to which fonts give the expected "correct"
behaviour. In particular, commonly-found fonts (Chinese fonts from Arphic,
Japanese Kochi fonts, Korean Baekmuk fonts, etc.) do not seem to give the
correct results.

Screen shots attached. The expected "correct" output should contain CJK
characters that look like horizontal lines.
Comment 1 acli 2003-09-08 21:50:08 UTC
Created attachment 9105 [details]
Expected display
Comment 2 acli 2003-09-08 21:50:41 UTC
Created attachment 9106 [details]
Unexpected ("wrong") display
Comment 3 jack.warchold 2003-09-09 10:52:00 UTC
jw:reassigend to us
can you please take a look on this issue
Comment 4 acli 2004-01-14 18:11:54 UTC
Sorry to have forgot to check for duplicates in my own reports. But this one is
still "unconfirmed," so I am closing this (older) one instead.

*** This issue has been marked as a duplicate of 24362 ***
Comment 5 acli 2004-01-18 07:03:07 UTC
Reopening to change reason for closing.
Comment 6 acli 2004-01-18 07:04:06 UTC
Problem as described no longer reproducible in OOo 1.1.
Comment 7 ulf.stroehler 2004-07-20 14:45:56 UTC
Closing issue.