Issue 2022

Summary: MRU file list should be user-configurable to more than 4 entries
Product: General Reporter: mitsu <mitsu>
Component: uiAssignee: requirements <requirements>
Status: CLOSED FIXED QA Contact: issues@ui <issues>
Severity: Trivial    
Priority: P3 CC: issues, marius.andreiana, royalozma
Version: 638Keywords: oooqa, rfe_eval_ok, usability
Target Milestone: OOo 2.0   
Hardware: All   
OS: All   
URL: http://specs.openoffice.org/appwide/menus/FileMenu.sxw
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description mitsu 2001-10-25 00:58:50 UTC
At present the MRU list is only 4 files long --- it should be possible to make
this larger, up to, say, 10 files.  This is particularly the case since the list
contains files of mixed type (word processing, spreadsheet, etc.)  Many users,
like myself, who edit a lot of documents, often find it helpful to have a longer
MRU list.
Comment 1 stefan.baltzer 2001-10-25 17:33:25 UTC
Reassigned to Falko.

Remark: In the old 5.2 days, an entry like "pick=8" in the soffice.ini's [soffice-Picklist] 
section did this job (to be "hacked manually" = without UI, but at least it worked)
Comment 2 carsten.driesner 2001-12-05 14:34:48 UTC
Please open the file <office
installation>/share/config/registry/instance/org/openoffice/Office/Common.xml
and search for the following subtree:
<History>
 <Size cfg:type="int">100</Size>
 <PickListSize cfg:type="int">4</PickListSize>
 <List cfg:type="set" cfg:element-type="HistoryType"/>
 <PickList cfg:type="set" cfg:element-type="HistoryType"/>
</History>
The number of entries is defined by
<PickListSize...>number</PickListSize. Set from 1 to 99 if you want.
Currently there is no GUI to change this value.
Comment 3 falko.tesch 2002-01-02 10:44:21 UTC
This issue is re-assigned to Christian Jansen for further evaluation.
Comment 4 christian.jansen 2002-01-03 11:06:10 UTC
Normaly 4 entries are enough. Due to Carstens hint it is in my opionen
not so important to add an item to the UI to allow more than 4 entieres.
Comment 5 mitsu 2002-01-03 15:52:09 UTC
In Microsoft Office the MRU list is user-configurable to up to 10 
entries.  Most users in our small company reconfigure this entry to 
list 10 entries in each application, and Microsoft Office has 
separate MRU lists for each application.  It is easy to do this in 
Office: just open a single settings dialog box.

Requiring users to open up an XML subtree is the same thing as saying 
that 99.9% of users will not have access to this feature.  Average 
users simply cannot deal with this sort of thing, at all.  I can 
imagine someone like my father trying to do this --- impossible.

There are a large number of settings in Microsoft Office, and 
changing the size of the MRU list is one of the maybe 10 or so things 
that I find useful to change.


Comment 6 christian.jansen 2002-01-21 09:13:11 UTC
*** Issue 1360 has been marked as a duplicate of this issue. ***
Comment 7 Unknown 2002-05-07 09:10:56 UTC
For security reasons I need to be able to turn OFF the MRU in total. 
Will changing the PickListSize to 0 have that effect?
Comment 8 Frank Schönheit 2002-05-07 18:14:55 UTC
Mitsuharo,

would a Basic macro to run inside OOo which does the same as modifying
the XML file manually (and which would do this in a "more official"
way, as it will not touch files which are an internal implementation
detail of the configuration backend) change the chances of users
accessing this? If so, we (okay, I assume it would be me :) could
provide this.

Chris,

I do not know if changing the config entry to 0 would have the desired
effect. However, I do not think that this would solve your security
problem, as there still is the history list (available in the URL bar
in the drop down list). At least this list would need to be adjusted,
too. However, I strongly encourage you to open a new bug for this
instead of misusing this one here - this definately is a very
different problem. Thanks.

Ciao
Frank
Comment 9 derb 2002-06-23 23:11:08 UTC
I would like to add my voice as one of those who would like to see 
the ability to more easily lengthen the MRU file list. For one thing, 
even when I did as suggested and changed the PickListSize entry to 9 
it did not change in the application - at least not under Windows 
2000.

Also, to be most useful, it should be application sensitive so that 
when in Writer you are only presented with Writer documents on the 
pick list.

A macro to do this would not be as effective as being built into the 
application unless a reference to it was included in the help file.
Comment 10 horkana 2002-09-04 22:09:02 UTC
Related issue
http://www.openoffice.org/issues/show_bug.cgi?id=3077
Comment 11 Frank Schönheit 2002-09-05 15:47:14 UTC
*** Issue 3077 has been marked as a duplicate of this issue. ***
Comment 12 royalozma 2002-09-06 06:59:53 UTC
What about a submenu at the bottom of the "FILE" menu which says "Less
recent files..."?
Comment 13 christian.jansen 2003-01-28 13:42:56 UTC
We should move the MRU list from its current location to a sub menu of
in the file menu. This entry could be called "Open Recent" the sub
menu should store 10 items.

Reassigned to Bettina
Comment 14 tomf 2003-06-21 23:26:13 UTC
This issue is listed as a duplicate of a similar issue against Linux.
 It needs to be fixed generally, not just for Windows.

I modified Common.xml to set a limit of 20 files, but had to open
Common.xml as root to do it.  This limit should be settable from
within oowriter, and should set a separate MRU list for each application.
Comment 15 kronning 2003-08-23 07:45:30 UTC
This is terrible, this issue is almost two years old now, and nothing 
has happened! Some users want to extend the MRU list, others want it 
removed.

I tried removing the menu item from Tools>Configure>Menu but I could 
not remove it from there, any reasons for this? Also, why can't there 
be a single input for the number of files in the list in 
Tools>Options>Load/Save>General ?

If the list would be a menu item just as all other menu items, then 
users could remove it or move it to a submenu (ie. File>Recent 
Documents)

In MacOSX applications the MRU list is a submenu with one menu item 
to clear the list.
Comment 16 mitsu 2003-12-11 21:30:55 UTC
Is anyone ever going to do something about this issue?
Comment 17 alex.thurgood 2004-01-06 17:11:58 UTC
Here we are in 2004, and still nothing seems to have been done. There is a
duplicate in issue 5114, which is nearly as old as this one, if not older (I
haven't checked). 

Well as a voluntary qa member, I'm going to set the oooqa keyword too.
Comment 18 norvic 2004-01-16 21:26:31 UTC
As a new user, currently operating in Win2000 but moving to Xandros when I can,
I would like to add my support to those calling for a longer MRU list.  It
doesn't matter TOO much if it is a mix of applications, though separating thwm
would be useful.  But restricting it to 4 is just too small, esp if I am in WP
mode and all 4 are spreadsheets!  I agree wholeheartedly with the small business
user - you cannot expect SMEs to use the product if it does not have at least
the useful functions which are in the product they are giving up (MSOffice).

Ian 
Comment 19 lohmaier 2004-05-09 19:53:04 UTC
*** Issue 28971 has been marked as a duplicate of this issue. ***
Comment 20 rkollien 2004-05-10 16:31:32 UTC
We run into the problem, that the history in Common.xcu grows up huge. We
generate temporary documents and load them into writer via CLI. After viewing
and printing, the file is deleted because not needed any more. So we have a
history grown up with files that do not longer exist. Will try to use the 
<Size cfg:type="int">100</Size> pragma mentioned in a similar issue. But it
would be better to limit the history size by gui. And: it shouldn't only limit
the visible MRU but also the stored entries in Common.xcu.
Comment 21 rkollien 2004-05-10 16:41:04 UTC
No go! On 1.1.0 the "<size>"-pragma has no effect. It is ignored and deleted by
OOo. So the history grows indefinetely?!
Comment 22 loucrazy 2004-05-17 15:59:08 UTC
I tried to look for this file:

<office
installation>/share/config/registry/instance/org/openoffice/Office/Common.xml

which a comment from 2001 suggested would contain this setting.

However, in my installation there is no Common.xml file at all (OOo 1.1.1 on 
Win XP)

Is there a way to change it in the current version of OOo?
Comment 23 andreschnabel 2004-05-18 21:31:56 UTC
as a workaround you can use this macro:
http://sourceforge.net/project/showfiles.php?group_id=87718&package_id=100070
Comment 24 n7dr 2004-08-30 23:28:37 UTC
When I run the suggested macro from sourceforge, it happily tells me that my
list has been updated to contain 12 entries, but there's no discernible
difference in the way that Writer actually behaves :-(

I have to agree with the earlier posters: OOo should work much more like Word in
this regard. Perhaps having a list that has only four entries would (maybe,
possibly, although admittedly unlikely) be OK if the list was maintained
separately for each application, but it's almost useless the way that it is
currently implemented. After editing four documents in Writer, it is very
frustrating to open Calc and see that none of the four entries on the MRU list
has anything to do with the Calc application.


Comment 25 rkollien 2004-08-30 23:56:43 UTC
We now run in the problem, when the history is to big (don't know how mutch
entries) the COMPLETE Common.xcu is set to the default values!!!! All user
settings are thrown away. Not very good :-( This only happens to users who use
many different documents. 
Comment 26 gieschke 2004-10-16 10:54:46 UTC
*** Issue 19145 has been marked as a duplicate of this issue. ***
Comment 27 gieschke 2004-10-16 11:00:15 UTC
*** Issue 16308 has been marked as a duplicate of this issue. ***
Comment 28 lohmaier 2004-10-16 12:46:59 UTC
setting keywords, reassigning, OS/Platform: ALL, fixed typo in summary
Comment 29 flibby05 2004-12-14 23:38:50 UTC
*** Issue 39000 has been marked as a duplicate of this issue. ***
Comment 30 matthias.mueller-prove 2005-02-11 13:35:50 UTC
For OOo2.0 the MRU list moved to File>Recent Documents. It is also extended to
10 items.
See spec for details.
Comment 31 matthias.mueller-prove 2005-02-11 13:36:42 UTC
// task closed