Issue 20661

Summary: Wanted: Insert cross reference to paragraph number
Product: Writer Reporter: toralf <toralf>
Component: uiAssignee: bettina.haberer
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: bulbul, guido.pinkernell, issues
Version: OOo 1.1 RC4Keywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: Other OS   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description toralf 2003-10-03 13:28:06 UTC
Some way to insert the number of a numbered paragraph as a cross reference might
be nice. Not possible today, as far as I can tell, as:

1. There is no format "Paragraph No" or similar in Fields->Reference
2. The number itself can't be used as reference value (target), as there is no
way to select auto-inserted text.
Comment 1 sajer 2003-10-10 23:59:12 UTC
http://www.oooforum.org/forum/viewtopic.php?p=11845#11845

Take a look at this thread; as one users says:

"Even if it does change automatically, Writers solution sucks. 

I use automatic numbering of headings 1 - 3 and in a huge document 
with many headings, making cross-references in Microsoft Word is 
easy. I can make cross-references to each and every headline without 
defining it first. It is so easy that it is difficult if not 
impossible for a normal human being not to figure out how to use it. 
Everything is where you expect it to be. 

In Writer you would have to define every heading as a cross-reference 
if you make cross-references to alle chapters. Image a document with 
300 headings (heading 1, 2 and 3). Why all this manual work, a word 
processor is supposed to make all this easy."
Comment 2 bulbul 2003-11-12 23:39:24 UTC
Might this be made a duplicate of issue 2593?

Until the cross-referencing of paragraphs is made possible and
intuitive i still can't recommend OOo for writing academic papers in
my field, linguistics. In linguistics, we use many numbered examples
to which we refer throughout a paper. I myself am forced to continue
using Latex on all documents of this nature.
Comment 3 Unknown 2003-11-17 05:15:33 UTC
Just stumbled on something here.

Using the navigator you can drag sections out of the headings field
(or any other) and creat static hyperlinks to them.  I would would
like to suggest that refrasing this to a request to make those static
links bothe dynamic and formatable (like bookmarks are) would resolve
this issue without having to add a major piece to the interface.

Also there needs to be documentation on how and what the feature does
now sence the only way I discoveded that this was possible whe when I
tried to drag the window and missed the edge. 
Comment 4 bulbul 2003-12-10 17:34:53 UTC
If by "numbered paragraph" the reporter means a paragraph with a style linked to
an outline level number, then it actually is possible to target the paragraph
number, by choosing the "chapter" format of the "set reference" function in the
Fields dialog (used by cross reference).

I think that it's unintuitive and misleading to use the word "chapter" to
describe this format, since it actually references any number associated with an
outline numbered style. I've filed a separate bug to suggest a change: issue 23284.

As such, i'm rescinding my earlier comment. The functionality is there, but it's
rather hard to figure it out.

Reporter, could you please try the "chapter" format for inserting a reference
(instead of the "paragraph no" you were looking for) and confirm that this
answers your issue. If it does, then please close this bug as invalid.
Comment 5 toralf 2003-12-11 08:39:21 UTC
I was talking about normal paragraph numbering as in the one you get when
hitting the numbering icon in the toolbar - not outline numbering.

I've actually used outline numbering as a workaround now, but this method is
generally too cumbersome to use for simple numbered lists, and of course, there
is also the limitation that you are restricted to a fixed number of outline
levels (as far as I understand.)

Another limitation of the "chapter" format is that you get just the number,
without any formatting; I sometimes want to include separators etc. in the cross
reference text.

I think the best way to fix this problem would be simply to allow the
auto-inserted number to be selected for cross reference source.
Comment 6 mci 2003-12-15 11:08:09 UTC
reassigned to bh
Comment 7 geofffarrell 2004-01-11 10:38:04 UTC
*** Issue 20661 has been confirmed by votes. ***
Comment 8 guido.pinkernell 2004-01-31 18:52:50 UTC
This is obviously a duplicate of Issue 2204.
All those which have voted here: Please transfer your votes to Issue 2204.

*** This issue has been marked as a duplicate of 2204 ***
Comment 9 guido.pinkernell 2004-01-31 18:53:16 UTC
.
Comment 10 troy_rollo 2005-12-29 03:30:15 UTC
Also a duplicate of issue 25072 
Comment 11 stgries 2008-08-29 02:06:31 UTC
As much as i want to move away from word, not being able to insert
cross-references to numbered lists is just insane. In linguistics, we need to be
able to refer to numbered examples all the time; in statistics, we need to refer
to numbered equations (and that is also clumsy enough). How am I supposed to
write anything longer than 20 pages (or even the occasional book) without this
feature? PLEASE make this a priority!!!