Issue 21062

Summary: inserting reference to chapter with navigator needs improvement
Product: Writer Reporter: lakewa <lakewa>
Component: uiAssignee: bettina.haberer
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P4 CC: guido.pinkernell, issues
Version: OOo 1.1Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description lakewa 2003-10-11 20:02:52 UTC
OpenOffice 1.1 German version on Win2k.
Planning dissertation. Tried to insert a link to a chapter with a numbered heading.
1. When drag and dropping from the "navigator" (F5) it will link, but with the
chapter number.
---> needs to work w/o chapter number.
---> prints as underlined, which I do not want
---> does NOT change, when I change the chapter!
2. Tried insert link ("Querverweis in German"). Window opens corretly, but does
not let me link a chapter at all.

Thanks & regards,
Kevin Walsh

mail: lakewa(at)gmx.de
Comment 1 lohmaier 2003-10-17 19:50:10 UTC
First the solution for the users problem:
> 2. Tried insert link ("Querverweis in German"). Window opens corretly,
> but does not let me link a chapter at all.

Su mußt zuerst eine Referenz setzten: Dazu die Überschrift markieren
und Einfügen->Querverweis auswählen und im tab "Referenzen" den
Feldtyp "Referenz setzen" auswählen und einen Namen vergeben. Im Feld
"Wert" sollte der Wortlaut der Ãœberschrift eingetragen sein.
Jetzt kannst Du im weiteren Text Querverweis -> Referenz einfügen
wählen. (Um den Wortlaut zu bekommen ganz rechts "Refereztext" auswählen).
Dieses Feld wird aktualisiert wenn Du den Orignaltext änderst (der ist
auch grau hinterlegt)

Now to the issue:
When dragging a chapter from the navigator into the text (with mode
hyperlink), the Navigator inserts simple text with a hard-formatting.
The text includes the outline-numbering (if set) and doesn't update
when the referenced Text gets updated. It's also bothersome to remove
the hyperlink-formatting afterwards.

One improvement would be to use a character style for the text, but
much better would be if this action would be a (maybe additional) mode
like the following:
1) Set a reference to the text (like one would do manually: Select the
heading's text, run Insert|Cross-Reference-> set reference, choose a
name (navigator could ask for it), klick OK)
2) Insert the reference-Text as reference (like manually go to the
place you want to have the reference inserted, choose
Insert|Cross-Reference->Insert Reference, pick the right one and
select "Reference" from the Format field)
3) trigger HelpAgent (the bulb) to explain what is it about the
references and how one can get the chapter-number or the page-number,
above/below, etc)
Comment 2 h.ilter 2003-10-21 11:12:20 UTC
Reassigned to BH
Comment 3 guido.pinkernell 2004-01-31 18:50:37 UTC
Obviously a dup of Issue 2204.

*** This issue has been marked as a duplicate of 2204 ***
Comment 4 guido.pinkernell 2004-01-31 18:51:10 UTC
.