Issue 21729

Summary: Please implement an editable 2-page zoom view
Product: Writer Reporter: magrawal <magrawal>
Component: uiAssignee: bettina.haberer
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1 RC5Keywords: oooqa
Target Milestone: ---   
Hardware: Other   
OS: Other OS   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Shows blank space on the right side of window to fit another page
none
OpenOffice 1.1.0 showing 2 pages in page preview none

Description magrawal 2003-10-26 14:52:58 UTC
The attached screenshot is from SO7. I miss a 2-page view where I can see 2 
pages side-by-side. I tried zooming down to see if OO would try to fit 2 or more 
pages side-by-side but without success. If you notice in the attached image, 
there is so much blank space on the right side that could have been used to show 
2 pages side-by-side. I would suggest that zoom should have an option to show 2 
complete pages side-by-side. It is useful on many modern desktops with large 
screens.
Comment 1 magrawal 2003-10-26 14:53:30 UTC
Created attachment 10656 [details]
Shows blank space on the right side of window to fit another page
Comment 2 mci 2003-11-06 10:21:00 UTC
Hi magrawal,

thanks for using and supporting OpenOffice...

Well, this works for me, I'll attach a screenshot...

reassigned to mci
Comment 3 mci 2003-11-06 10:23:08 UTC
Created attachment 10997 [details]
OpenOffice 1.1.0 showing 2 pages in page preview
Comment 4 mci 2003-11-12 12:32:30 UTC
.
Comment 5 mci 2003-11-12 12:35:09 UTC
Hi magrawal,

did this help you?

I'll wait until 12/03/2003 to get a comment from you that this wasn't 
what you wanted to get...
If there's no new comment from you I'll assume that this was what you
wanted...

set to worksforme...
Comment 6 magrawal 2003-11-12 18:03:35 UTC
Well, after some thinking, I relaized that we are talking about 2 
different things. The screenshot you posted is from File -> Page 
preview. I am talking about View -> Zoom. I do think that a zoom 
setting of 2 pages is very useful. The reason is simple, many users 
now have 17' screens, and we like to be able to edit a document while 
seeing 2 pages at a time, particularly in the closing stages of a 
document. This way, we get a preview of the document, while we still 
have editing privileges. 
Essentially, all I am suggesting is that when documents are zoomed out 
using View -> zoom (not File -> Page preview), they should be laid out 
horizontally instead of vertically, this will make very good use of 
screen real-estate.
Comment 7 mci 2003-11-12 18:25:57 UTC
Hi magrawal,

am I right: You want to have an editable 2-page-view?
Comment 8 magrawal 2003-11-12 18:37:33 UTC
Yes, I think it would be useful if one of the options in View -> Zoom 
were 2 pages. 
In general, I also think that displaying pages horizontally instead of 
vertically when the zoom view is small would be a useful improvement. 
Would you like me to file a separate issue for this second suggestion?
Comment 9 mci 2003-11-12 18:39:59 UTC
@magrawal: ok, I'll reassign this Issue...

reassigned to bh
Comment 10 lohmaier 2004-08-12 21:23:51 UTC
duplicate.

*** This issue has been marked as a duplicate of 1598 ***
Comment 11 lohmaier 2004-08-12 21:24:20 UTC
closing duplicate.