Issue 22050

Summary: Relative hyperlinks in spreadsheets become absolute when "Save As .xls"
Product: Calc Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: uiAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows 98   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Testkit to reproduce the problem none

Description Rainer Bielefeld 2003-11-03 11:06:20 UTC
I checked with 1.1.0 German version WIN98SE: 645m19(Build8693) 

I added a testkit, steps to reproduce:

1. Unzip attached testkit to C:\
   so that you have a folder "C:\test\
2. open 'testfile.sxc'
3. check link to 'opened.sxw'
   expected: writer- document will be opened
   actual: as expected
4. open 'testfile.xls' (which has been created from by "File - Save As") 
   and test hyperlink again
   expected: as above
   actual: as expected
5. so far, so good, now go to 'testfile.sxc' and create a new EXCEL document in
   the same folder by Menu: "File - Save As - EXCEL-Document" with name  
   'testfile2.xls', 
   and then close all OOo files
6. cut and paste folder 'test' from 'C:\' to an other drive 
   and folder, for example D:\TEMP\
   it is important that the folder 'test' does not remain at the old
   location with it's old name
7. start from 2. in 'test' at the new location, and you will see, 
   that again everything works as expected with 'testfile.sxc'
   but not with the ".XLS" - documents, their hyperlinks still lead to "C:\test\
   what shows, that the hyperlinks in the created EXCEL documents changed from 
   "relative" to "absolute"

I can not answer the question, whether EXCEL supports relative links (only if
"yes", this can be a real DEFECT). Could someone please check this? Becuase of
this auestion I did not set keyword "ms_interoperability"

Rainer
Comment 1 Rainer Bielefeld 2003-11-03 11:07:55 UTC
Created attachment 10904 [details]
Testkit to reproduce the problem
Comment 2 Rainer Bielefeld 2003-11-03 11:08:47 UTC
Corrected Summary
Comment 3 frank 2003-11-03 11:48:09 UTC
Hi Daniel,

it seems to be yours as the save relative to filesystem checkbox seems
to be checked, the Calc document opens the link just fine.

Frank
Comment 4 frank 2003-11-03 11:48:54 UTC
Target 1.1.2 ?
Comment 5 daniel.rentz 2003-11-06 10:10:11 UTC
This issue is equal to issue 22107, which is already fixed for OOo 2.
0. Therefore this issue remains for OOo 1.1.2 only.

Fixed in SRX645/sab006.
Comment 6 niklas.nebel 2003-11-06 14:58:25 UTC
review done.
Comment 7 daniel.rentz 2003-11-12 14:28:44 UTC
back to QA
Comment 8 frank 2003-11-20 09:33:14 UTC
reset to fixed
Comment 9 frank 2003-11-20 09:33:53 UTC
verified on cws sab006
Comment 10 frank 2003-12-10 11:28:07 UTC
reset target to OOo 1.1.1 approved by AK

Frank
Comment 11 oc 2004-01-30 11:04:59 UTC
Fix will be availabe in the forthcoming OOo1.1.1