Issue 23126

Summary: Changes in text alignment does not show on record changes
Product: Writer Reporter: rarias <rarias>
Component: uiAssignee: h.ilter
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, utomo.prawiro
Version: OOo 1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Containing text with justification at both sides. none

Description rarias 2003-12-02 23:22:54 UTC
In OpenOffice.org Writer 1.1.0, every change you make to a text, whatever its
nature, is recorded as changed, provided of course you have activated the
record-change feature, through Edit > Changes > Record.

The bug is that the change is not recorded (the left vertical margin does not
appear) if you chnage the text alignment. I included a document where you can
test my claim. The document has already the record-change feature activated. The
text in the document is now justified (at both sides). If you change to, let's
say, left justified, nothing happens.
Comment 1 rarias 2003-12-02 23:24:28 UTC
Created attachment 11705 [details]
Containing text with justification at both sides.
Comment 2 utomo99 2003-12-10 10:26:10 UTC
please explain step by step how to reproduce the problem,
Thanks

Comment 3 rarias 2003-12-10 22:50:29 UTC
STEPS TO REPRODUCE THE PROBLEM
1. Open the document RecordChangesError.sxw listed in the Attachments section of
this web page.
2. Verify that Record in Edit > Changes > Record is activated, as it should be
since I saved the document with this feature activated. 
3. Select the text beginning with "Este es un campo heredado..." (third line)
until the end of the paragraph "... así lo ameritan" (eleventh line).
4. Notice the selected text is signaled in the tool bar as "justified".
5. In the tool bar select the Align Left button.
6. The selected text is now left aligned. However, the change has not been
signaled, with the vertical bar at the left and putting the text in underlined
red (or whatever color corresponds in the order).
7. Undo the Align Left operation. Now the text is justified again.
8. In the tool bar select the Italic button.
9. The selected text is now in italic. And the change has been signaled with the
 vertical bar at the left and putting the text in color, as we expect it happens
due to the change.
10. Undo the Italic operation. Now the text is at its original state.
11. In the tool bar select the Centered button. Repeat for the Align Rigt
button. None of these operations are detected as a change in the text.
12. In conclusion, alignment operationa are not detected as a change, which is a
bug if my intention is to show a change. 

Regards
Ramiro Arias
Comment 4 guido.pinkernell 2004-01-27 16:56:09 UTC
Duplicate of an Issue which lists several other changes not being recorded

*** This issue has been marked as a duplicate of 17922 ***
Comment 5 h.ilter 2004-03-18 15:47:19 UTC
.