Issue 23402

Summary: OpenOffice should indicate when it is using font/glyph substitution/fallback
Product: Internationalization Reporter: sforbes <xslf>
Component: BiDiAssignee: Joost Andrae <Joost.Andrae>
Status: CLOSED DUPLICATE QA Contact: issues@l10n <issues>
Severity: Trivial    
Priority: P3 CC: alan, caolanm, dtardon, falko.tesch, issues, jbf.faure, Joost.Andrae, kaplanlior, mey.wer, tintys, yba
Version: OOo 1.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description sforbes 2003-12-10 13:16:16 UTC
this is more a usability problem then a code defect: 
Right now, if the user selects a font which does not have the appropiate glyphs
for the language typed (for example, selecting bitstream vera and then typing in
Hebrew), OO slintly uses font substitution without notifing the user.

This is one (if not the) most common causes for users in Israel to complain
about "strange" behavier with Hebrew in OO, is that they are using a font with
no Hebrew glyphs without relising it (OO automaticly kicks in with font
substitution, without any indication).

In most cases, changing the font to a true Hebrew font fixes the problems they see.

If OO would have indicated to the user somehow that the font they selected is
not the one used in practice, and that there is font substitution going on, many
user problems would be prevented.
Comment 1 wliad 2004-01-18 19:52:49 UTC
Font fallback without a notification is not a defect, but it sure should be 
addressed as UI feature that should at least appear once, with a checkbox for 
silancing it in the future.

Should change from defect to feature... sforbes, it's your choice. I voted for 
this one.

wliad.
Comment 2 sforbes 2004-01-18 21:47:57 UTC
>but it sure should be addressed as UI feature that should at least appear once,
>with a checkbox for silancing it in the future

I am not sure I understand you. I was not talking about a warning or pop-up,
just some visual clue that the font chosen is not the one used (perhaps an icon
next to the font name in the toolbar, or something along those lines).

That way, we won't need to offer a "checkbox for silancing it in the future"

>Should change from defect to feature

As as see many questions on the message boards that would have been prevented
had the user known that the font cohsen is not the font used (for example, PDF
comming out with uqestion marks due to attempting to use a non-Hebrew font for
Hebrw text), I see this bug as a usability defect.
Comment 3 Dieter.Loeschky 2004-01-29 17:00:51 UTC
DL->FT: Could you please handle this?
Comment 4 sforbes 2004-06-21 14:47:39 UTC
adding dina as cc
Comment 5 falko.tesch 2005-02-16 09:52:47 UTC
FT: Targeted to OfficeLater and set to FEATURE.
Comment 6 falko.tesch 2005-10-20 20:51:43 UTC
FT: I'm leaving so I will re-assign this issue to requirement default user
Comment 7 jallan3 2005-12-14 16:14:36 UTC
This is very important for professional use.

If we receive letter text or form text from a client in MS-Word format, which is
very common, it is necessary to know whether the fonts displayed on screen and
sent to printer are the same fonts the client expects (or fonts sufficiently
similar that substitution is acceptable, eg. Swiss instead of Helvetica). 
Currently in OpenOffice the only way to do this is to run a cursor through the
entire document sent, looking at the names of fonts in the font window, and
checking if each font name that appears there is the name of a font actually
installed on the computer being used.

In MS Word, one can go into Tools/Options, click on the Compatiblity tab, and
then on the "Font Substitution ..." button which either brings up a message that
all fonts in current document have been found and no substitution has been made,
or brings up a window indicating which fonts are not found and what substitution
has been made, allowing the user to edit this table (and to actually replace the
font with a substitute font within the document if desired.)

In Quark Express, if one or more fonts are not found, a similar Window allowing
the user to control substitution appears as the document loads, allowing the
user to specify which fonts are to be substituted at that time. This I think the
preferable way of dealing with the issue, as the user is immediately given the
information about missing fonts without having to take the initiative of
searching into the bowels of a menu, but can if desired simply click to bypass
the screen and let the application then substitute as it wishes.

My suggestion would be to bring up such a window of font substitutions in
OpenOffice when a document loads and also allow access again to this window
through Tools/Options in emulation of MS-Word. If we carelessly miss the fact
that font substitution has occurred, production work and production time may be
wasted, both on our end and on the client's end, when the client quite rightly
complains that the fonts appearing in the signoff samples of the finished
product are not correct.

Currently under OpenOffice though Tools/Options/Tools/Fonts the user can set up
a permanent font substitution table. Probably an option should appear here
asking whether the user wishes not to be warned of any substitutions indicated
by this table.
Comment 8 lohmaier 2006-08-04 22:31:20 UTC
*** Issue 67384 has been marked as a duplicate of this issue. ***
Comment 9 alan 2007-06-05 12:48:45 UTC
For the next Hebrew version of OOo, I've addressed sforbes' problem in a
different way - by letting the user know in the font drop-down list box which
fonts support Hebrew. Those fonts which have Hebrew glyphs have a sample of the
first three letters of the Hebrew alphabet appended to the font name. If the
font name doesn't have the Hebrew sample, the user knows that it doesn't support
Hebrew. This does not fulfill the requirement described here, but it goes a long
way toward solving the problem, and it's pretty easy to implement.
Comment 10 meywer 2007-08-21 12:07:59 UTC
see issue 45128 also
Comment 11 kaplanlior 2008-05-08 20:34:49 UTC
Any news about this ?
Comment 12 meywer 2008-08-09 12:32:18 UTC
cc
Comment 13 dtardon 2008-09-10 07:09:02 UTC
cc
Comment 14 rafaella.braconi 2008-09-10 08:04:44 UTC
setting target and cc:ing ja
Comment 15 Martin Hollmichel 2009-04-24 09:16:34 UTC
reassigned
Comment 16 Joost Andrae 2009-04-24 09:41:38 UTC
Resetting target because no developer is actively working on this. On the other
hand I close this issue as duplicate to issue 45128. Mentioned issue contains a
dependency to another issue that contains a solution how to address this feature.

ja->coni: What makes you think that this feature is to be implemented for 3.1 ?

*** This issue has been marked as a duplicate of 45128 ***
Comment 17 Joost Andrae 2009-04-24 09:42:11 UTC
.
Comment 18 meywer 2009-04-25 21:38:36 UTC
Me as user I need to know, when a font-substitution is done and I want to know
also, which font is used instead of the font selected by the user (which is not
abĀ“vailable on the system or which doesn't contain glyphs used in the document).

For now it is impossible to recognise this, which is a bug for me.