Issue 23481

Summary: misleading error message
Product: General Reporter: yharms <yharms>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P5 (lowest) CC: issues
Version: OOo 1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description yharms 2003-12-11 18:14:52 UTC
If you open with an oo-installation without installed Math-Component a
oo-document with an embedded formula inside  the embedded object will be
displayed with a placeholder. Clicking at the placeholder brings up a generic
OLE-error message.
Most people will simply think the application is buggy and has 'eaten' the
formula like MS-word used to do it with embedded gafics.

Replace the message with a more specific one :
OLE-application for this object could not be found (<identifier>). Hint: Maybe
this application or Open Office feature ist simply not yet installed on this
machine. Try installing all Components to solve this problem.
Comment 1 thorsten.martens 2003-12-12 14:23:59 UTC
TM->MRU: As talked about, please have a look.
Comment 2 michael.ruess 2004-01-05 15:22:48 UTC
More detailed descriptions of the "General OLE error" message is desired here.
It does not only affect Math objects; also when a document contains other
objects (even from 3rd party applications) where the server application is not
installed on a certain system, this is the case.
Comment 3 michael.ruess 2007-02-21 15:40:27 UTC
*** Issue 74703 has been marked as a duplicate of this issue. ***
Comment 4 Regina Henschel 2009-11-18 23:12:22 UTC
*** Issue 107007 has been marked as a duplicate of this issue. ***
Comment 5 bettina.haberer 2010-05-21 15:17:22 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements".