Issue 23982

Summary: template crashes Windows completely
Product: Writer Reporter: ingenstans
Component: codeAssignee: h.ilter
Status: CLOSED FIXED QA Contact: issues <>
Severity: Trivial    
Priority: P2 CC: issues
Version: 680m17   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
the killer template none

Description ingenstans 2003-12-30 13:58:06 UTC
This was found on the users list by Tom Cloyd <>. He 
built a simple template with 10 numbered indented levels and six comment styles. 
Loaded into Windows 2000 SP4 (testeed by me) or Windows XP, (tested by him), it 
hangs OOo completely, with steadily increasig consumption of CPU cycles and 
virtual memory. This is true both with OOo 1.1 and 680_m17. He reports that at 
one stage a hrad reset was necessary to get XP to respond.

It will load on Linux under 680_m17; but attempting to make a new document from 
the template hangs OOo there just as on Windows. I've put it as priority 1 
becasue nothing that OOo does should ever bring down the operating system, and 
certainly not the mere addition of a style to a template.
Comment 1 ingenstans 2003-12-30 13:58:58 UTC
Created attachment 12192 [details]
the killer template
Comment 2 ingenstans 2003-12-30 14:00:37 UTC
I append his original report to the user list, since it is a pretty clear 

---- Start original report -----

I've just spent 6 hours watching my ver. 1.1.0 OOo lock up my Win-XP OS, 
over and over. Here's how I get it to happen:

I have a simple template which I've been using for some days. Earlier 
today, I made some minor changes to it, saved it, then tried to load it 
into an existing file (main menu: Format > Styles > Load). OOo grabbed 
most of the CPU cycles, and everything else ground virtually to a halt. 
There we sat for some minutes. I finally invoked Task Manager and bombed 
OOo off. Even that effort was breathtakingly slow.

After some futzing around, I attempted to rebuild the template from 
scratch. What's in it is merely 10 levels of numbered headers and a few 
other things, with a total length of less than one page.

At first this new template worked - at that point it was half build. 
When I got more or less back to where I was before, the lockups began 
all over again. I tried every trick I could think of. Six hours of 
trying. I've never seen anything achieve this degree of lock up on 
WinXP. At one point I couldn't even get to Task Manager, and had to do a 
hard reset - a pretty rare thing with WinXP.

So...this template, which is integral to a lot of my word processing, 
appears to be a real OOo killer. I have not the slightest clue why OOo 
can't handle it. It's just not that much. Seems like someone in the know 
ought to look at this.

Comment 3 ingenstans 2003-12-30 14:03:09 UTC
changed OS to "all" until it's shown to work anywhere, since if it's bust on 
Windows 2000, XP, and Linux, it's probably bust everywhere.
Comment 4 grsingleton 2003-12-30 17:27:38 UTC
May I suggest that the version be changed to 1.1 rather than the build number. I
can confirm that it definitely hangs OOo1.1.0 up under RH9
Comment 5 h.ilter 2004-01-06 08:42:57 UTC
HI->FME: Please analyse whether this issue is an pp candidate.
Comment 6 frank.meies 2004-01-06 09:57:16 UTC
FME: Fixed in sw/source/core/text/porfld.cxx rev. (cws swq02)

FME: Could also be fixed for pp.
Comment 7 frank.meies 2004-01-07 15:51:35 UTC
Reassigned to QA.
Comment 8 h.ilter 2004-01-07 16:30:09 UTC
We have a regression to 1.0 => PP candidate
Set to 1.1.2
Comment 9 h.ilter 2004-01-07 16:37:20 UTC
In discuss with TZ retarget to OOo 1.1.1
Comment 10 frank.meies 2004-01-08 07:07:27 UTC
FME: !!!No regression!!!

Comment 11 frank.meies 2004-01-08 10:27:22 UTC
FME: Fixed in sw/source/core/text/porfld.cxx rev. (cws ooo111fix2)
Comment 12 frank.meies 2004-01-14 09:40:01 UTC
FME: Please verify in ooo111fix2 and swq02.
Comment 13 h.ilter 2004-01-22 10:37:22 UTC
Verified with cws: swq02 = ok
Comment 14 h.ilter 2004-01-22 10:38:29 UTC
Waiting for cws: ooo111fix2
Comment 15 h.ilter 2004-01-27 14:08:48 UTC
Verified with cws ooo111fix2 = ok
Comment 16 h.ilter 2004-01-27 14:10:17 UTC
Waiting for integrated swq02
Target changed to OOo 2.0
Comment 17 h.ilter 2004-01-30 13:32:39 UTC
Meanwhile verified with integrated srx645_m27s2-1_01.8739 = ok
Comment 18 h.ilter 2004-02-02 08:55:25 UTC
Retarget again to OOo 1.1.1 for the statistic.
Comment 19 h.ilter 2004-02-17 10:17:41 UTC
Verified with integrated 680m25 = ok