Issue 24439

Summary: Spellchecker "missing dictionary" behaviour misleading
Product: Writer Reporter: hmlf <helen_ml_faulkner>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, steve.m.frank
Version: OOo 1.1Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 81913    

Description hmlf 2004-01-15 13:01:47 UTC
I was mislead by the spell checker's behaviour when you have a language setting
for which a dictionary is not installed.  I had English(Australian) set at the
language, but only English(GB) installed.  When I ran the spellchecker, it raun
and did nothing, and didn't tell me that it did nothing because it didn't have
the dictionary.  So I assumed that the spellchecker had actually checked my
spelling, which it hadn't.  I think that's a real problem in a situation where
it's important to get the spelling right.

I have since been told that the reason the spell checker doesn't tell you it
doesn't have a dictionary is that some users will have multiple languages in
their document and may not have dictionaries for everything installed and may
not want a warning every time they spellcheck.  I personally don't think that's
as likely to come up at the situation I had.  

Maybe a solution would be to have the default behaviour be that the spellchecker
tells you when its missing the dictionary for the language you set, but also to
allow the user to choose to switch those warnings off.  This would allow the
newbie user to realise that their document isn't being checked, and the more
advanced user to turn off those annoying warnings.  

I did read the spellchecking and language documentation from the help system,
but didn't understand what was going on until a human explained it to me.  Maybe
the documentation could describe the behaviour more clearly as well.


Helen Faulkner
Comment 1 khendricks 2004-01-15 13:10:37 UTC
Unfortunately, lingucomponent is not the place for this issue.  The dialogs and settings and 
control of the dictionaries is in the WordProcessor project.  Linugcomponent code is effectively 
passive in this regard. 
I am moving this issue to that project. 
Comment 2 h.ilter 2004-01-15 16:29:35 UTC
HI->TL: Please keep in mind with your project.
Comment 3 thomas.lange 2004-02-06 10:04:16 UTC
There is a message if the dictionary is missing but only once per office run
when the spellcheck dialog is invoked and only if the missing language was not
encountered previously by the automatic spellchecking.

TL->BH: You provably still do not want the automatic spelchecking to raise
windows of any kind. But one could memory the missing languages and bring the
message the next time when the interacticve spellchecking is used.
To you for decision.
Comment 4 i327 2005-11-21 20:43:46 UTC
Spellchecker states 'The Speckcheck is Complete' when actually it is not activated.

At issue here is that once the "Tool" > "Option" > "Language Settings" >
"Writing Aids" > check box "Available Language Modules" “ Myspell
SpellChecker”  when de-checked does not gray out the tool bar option but allows
a carry through of Spellcheck and will state 'The Speckcheck is Complete'

Solution if de-checked item is not active in any writing aid, that function gets
grayed out at the tool bar. To further help user when that gray tool bar button
gets pressed (activated) it jumps the user right to the writing aids option
dialog box which allows the user to change that option without going the long
rought of activating this tool. A dialoge box just does not cut it any firther
when it is possible to take you right to the right option box to get the tool
activated. This would be the best user friendly option saving the first time
user 15 – 20 minutes to find out how to get the spellcheck to work.

This issue is a clarification of 58219 initial problem that was closed,
underlying problem needed to be addressed.
Comment 5 atdsm 2006-06-14 21:22:02 UTC
There are two issues here. One is a feature request: to have the spellcheck
option grayed out if spellchecking is not available (among other things). (Do I
have that right?) The other is, in my opinion, a bug: the user is told that the
spellcheck is "complete" when in fact no spell checking occured at all.

For the bug, there is another issue filed. Rather than change this issue from
feature request to defect, I will point to the other issue: issue 66332.

In my opinion, if i66332 is to be closed as duplicate then this issue should be
changed to defect. The lack of error message when no dictionary is available is
a defect which causes useability problems, especially as such an error message
used (?) to work correctly (confer issue 18370).

Comment 6 lohmaier 2006-06-16 12:30:31 UTC
*** Issue 66332 has been marked as a duplicate of this issue. ***
Comment 7 atdsm 2006-06-16 13:25:47 UTC
As issue 66332 has been closed as a duplicate, it is my opinion that this issue
therefore be relabelled as a defect or at least given a target. I have read
through the spellcheck specification as posted at There is no specific
specification written for what happens when a user chooses a language with no
dictionary. The closest thing I can find is a line which says: "Language
attribute [None] in the character attributes dialog suppresses hyphenation,
thesaurus and spelling." The corresponding illustration displays setting the
language to "None" rather than to a language without a dictionary.

The implication is that setting to an actual language should not suppress
spellchecking, or if there is no dictionary, a warning should occur. (Probably
this should be explicitely added to the specification.)

Given that OOo used to display an error or warning in the situation in question
(at least according to the other issues referenced) and that this bug can cause
severe confusion and user annoyance, in my opinion this should be classified as
a defect.

Also, this should in my opinion be a P3, because it is a situation where "the
user interface for a common functionality is confusing."
Comment 8 dridgway 2007-01-02 00:05:33 UTC
Note that this can happen even if the user never sets a language themself. If
user's environment has a language without a dictionary (eg one of the many
Englishes), then spellchecking (auto or manual) falsely claims no mispellings:
to me this is clearly a defect. There's lots of English users in Australia and
Canada, to name just a fraction of those affected, therefore P3. 

Also see issue 38996.

I haven't confirmed regression behavior, so I haven't set regression keyword.
Comment 9 jelofson 2008-08-26 15:26:58 UTC
I absolutely agree that this is a defect. My computer is set up as English
Canada and Openoffice won't check the spelling because it assumes the document's
language is en_CA. When I run a spell check, it says "Complete" and I am to
believe all is well, which is not the case. I also am not able to install new
dictionaries because the dialog box that opens from the wizard is too small and
basically useless. I wonder, would I be able to install the dictionary as a
normal user anyway? Would I be prompted for a sudo password? I can't get that
for so I don't know. This will keep ordinary users very annoyed. I am using 2.4.
How on earth can a word processor be installed with no functional spell checker?
Installing the spell checker should not be done using the wizards either. It
should be under Tools, Options, Language Settings. I should be prompted if I am
trying to check spelling and there is not dictionary for the selected locale.
Comment 10 bettina.haberer 2010-05-21 16:13:48 UTC
Changed the owner to 'requirements'.
Comment 11 Rob Weir 2013-07-30 02:37:37 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.
Comment 12 Robert Smith 2014-09-02 20:13:05 UTC
I don't know.... click on spell check and it underlines every thing; even the, a, I, etc.
Comment 13 Ariel Constenla-Haile 2014-09-02 21:36:42 UTC
(In reply to Robert Smith from comment #12)
> I don't know.... click on spell check and it underlines every thing; even
> the, a, I, etc.

Your bug is likely Bug 121930
Locate the User Profile, and delete the folder named "uno_packages" and "extensions"