Issue 24451

Summary: Row delete, within an autofilter selection, deletes nonselected rows too.
Product: Calc Reporter: dhogan <dhogan>
Component: uiAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1   
Target Milestone: ---   
Hardware: Sun   
OS: Solaris   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Autofilter test file none

Description dhogan 2004-01-15 21:19:30 UTC
System is Sun solaris with OOo 1.1 Spreadsheet. 

Setup the following in a column:

Fruit
grapes
pears
apples
bannana
apples
pears

Turn on autofilter; select apples from pull list; now select the two apples 
rows (select-drag within row numbers) and delete them; pick the autofilter pull 
list and select all.

The issue is the bananna row got deleted too.  Excel does not do this.

Undo to return the three deleted rows.  

select apples from the autofilter pick list; select-drag to select only the two 
cells with apples; hit delete to clear the cells;  select all from autofilter.

The bananna cell is also emptied, which excel does not do.

I could not find any help to indicate this was design intent and feel it is a 
defect.
Comment 1 dhogan 2004-01-15 21:23:19 UTC
Created attachment 12507 [details]
Autofilter test file
Comment 2 frank 2004-01-16 08:54:54 UTC
Hi,

this is a double to Issue 2977:

Frank

*** This issue has been marked as a duplicate of 2977 ***
Comment 3 frank 2004-01-16 08:55:55 UTC
closed double