Issue 24472

Summary: autofilter - the easiest way to loose all your data!
Product: Calc Reporter: peopleandplanet <rich>
Component: uiAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description peopleandplanet 2004-01-16 12:52:56 UTC
Ok, this maybe because I'm used to Excel, but I'm sure you'll agree it's
counter-intuitive...

Set this up in column A:
  Some Letters
  AAA
  BBB
  DDD
  EEE
  FFF
  BBB
  GGG

Now apply Autofilter,

Now filter for BBB
Looks like this:
  Some Letters
  BBB
  BBB

Ok, all well. Now highlight the two cells by dragging a range. Press Copy.

Move somewhere else and press paste. Two cells are filled as you might expect.
All well. Aha! you think, so when I select like this, it has selected just the
cells shown. Not so...

Now type "killer" in place of the top BBB.
Now either:
  A) select the cell and drag the little filler blob down to cover the next
     cell down (the other BBB one shown). OR
  B) select the cell, hit Copy, select both cells (as before), hit Paste.

Now you THINK you've replaced all the cells in front of you with "killer". But
remove autofilter (and you may have to highlight the lot and press unhide -
what's that all about too?), and you'll have this:

  Some Letters
  AAA
  killer
  killer
  killer
  killer
  killer
  GGG

and that's all your data lost!

As I often do a lot of work like this, it's a real bind. I've had to set up a
macro (external to OOo) which types repeated sequences of Ctrl+V, Down, so that
I can fill a bunch of cells properly, without overwriting "filtered" ones.

The only safe way (as I recommend to new users) is to Sort the table, not use
autofilter.

I lost a whole days work this way when a new user was using an accounts Calc
spreadsheet.

Please help!
Comment 1 frank 2004-01-16 13:18:49 UTC
Hi,

what's about using the Link Bugs & Issues and than following the Ling Search ...

using autofilter as the keyword for the summary field and spreadsheet as
component will lead you to some Issues regarding the autofilter and the most
important one Issue 2977 .

This is a double.

Frank

*** This issue has been marked as a duplicate of 2977 ***
Comment 2 frank 2004-01-16 13:19:13 UTC
closed double