Issue 24654

Summary: Send document does not work with Pegasus Mail MAPI
Product: General Reporter: gjackson1 <gjackson>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: brendel, issues
Version: OOo 1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description gjackson1 2004-01-21 22:27:13 UTC
I have reproduced this with OOo 1.1.0 and 1.1.1a, in both the Text and Calc 
applications.  With an open document, I do File, Send, Document as Attachment 
(or PDF).  If Pegasus Mail (4.12a) is not running, it is launched, as normal, 
but then I am presented with this dialog box in OOo: 

"An error occurred in sending this message.  Possible Errors could be a
missing user account or a defective setup.  Please check the
OpenOffice.org settings or your email program settings."

This error is displayed whether Pegasus is initially running or not.  I have 
Pegasus set up to use MAPI and this has been verified to work in other 
applications.  Normally Pegasus displays a dialog box saying that information 
is being transferred to it through MAPI, but it is not displayed with OOo.  I 
have tried uninstalling and reinstalling OOo and the error persists.

If a MAPI solution cannot be made, I think OOo should have the option of 
specifying a generic commandline to launch the email application of the users 
choice with some commandline parameters.
Comment 1 atr 2004-01-22 07:39:41 UTC
ATR -> gjackson1: Sorry, OO does not support pegasus mail. So this isn't a
defect. I change this issue to 'enhancement.

ATR -> BH: Hi bettina, please have a look, thanks.
Comment 2 gjackson1 2004-01-22 11:27:53 UTC
It is currently set for "Default email program", which I understood to be all 
MAPI-compliant mailers.  Reading the users mailing list, there are several 
people using OOo with Pegasus Mail through MAPI, but under Win98.  I an using 
Windows 2000 Professional.  In any event, a solution is a solution.  :)
Comment 3 ace_dent 2008-05-16 02:57:35 UTC
OpenOffice.org Issue Tracker - Feedback Request.

The Issue you raised has the status 'New' pending further action, but has not
been updated within the last 4 years. Please consider re-testing with one of the
latest versions of OOo, as the problem(s) may have already been addressed.
Either use the recent stable version: http://download.openoffice.org/index.html
or consider trying the new OOo 3 BETA (still in testing):
http://download.openoffice.org/3.0beta/
 
Please report back the outcome so this Issue may be Closed or Progressed as
necessary - otherwise it may be Resolved as Invalid in the future. You may also
wish to search for (and note) any duplicates of this Issue that may have
advanced further by checking the Issue Tracker:
http://www.openoffice.org/issues/query.cgi
 
Many thanks,
Andrew
 
Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~
http://marketing.openoffice.org/3.0/announcementbeta.html
Comment 4 brendel 2009-01-07 14:01:43 UTC
I just tested using OO 3.0.0 and Pegasus mail 4.41, with Pmail being the
standard system mailer (e.g. works with right click and send to in the file
manager with out problems) and it still doesn't work, OO complains sitll that it
"was
unable to find a working e-mail configuration ..."

see also bugs 27467 and 80220

Oliver
Comment 5 bettina.haberer 2010-05-21 15:10:14 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements".