Issue 24969

Summary: [RFE] Presentation should play a sound file over more than one slide
Product: Impress Reporter: linux_karen <jared>
Component: codeAssignee: christian.guenther
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: afrayer, bettina.haberer, caiot1, christian.guenther, clippka, dmaizer, ht990332, hub, issues, ooo, pagalmes.lists, palemon, rainerbielefeld_ooo_qa, renatoyamane, utomo.prawiro, zrnk
Version: OOo 2.0Keywords: ms_interoperability, oooqa
Target Milestone: OOo 2.3   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 78386    
Issue Blocks:    
Attachments:
Description Flags
Sample (may require some fidgeting to work correctly)
none
Sample.zip (in case you can't open a rar file) none

Description linux_karen 2004-02-01 10:24:47 UTC
In PowerPoint it is possible to attach a sound file to a slide in a 
presentation, and enable that sound to continue playing over the next x slides 
(user-definable number).  I use it to play an MP3 song while displaying the 
lyrics onscreen.  OOo Impress suffers two problems in this area:

1. It can't play MP3s (unless I'm particularly braindead in my efforts to do so)

2. It can't play a sound file over more than one slide.

This is a powerpoint compatibility bug and a real problem for me.
Comment 1 wolframgarten 2004-02-02 08:07:36 UTC
Reassigned to Christian.
Comment 2 christian.guenther 2004-02-04 16:00:47 UTC
This is not a bug but a feature.
Please have a look.
Comment 3 christian.guenther 2004-03-08 16:02:30 UTC
reassign to bh
Comment 4 bettina.haberer 2005-05-20 13:58:27 UTC
Please only one enhancement per issue. For case 1. please refer to issue ID
45698. I adjust the summary for case 2.
Comment 5 christian.guenther 2005-11-02 14:38:30 UTC
*** Issue 56458 has been marked as a duplicate of this issue. ***
Comment 6 wolframgarten 2005-12-06 07:52:47 UTC
*** Issue 58921 has been marked as a duplicate of this issue. ***
Comment 7 lars 2005-12-18 12:34:46 UTC
*** Issue 34517 has been marked as a duplicate of this issue. ***
Comment 8 lars 2005-12-18 12:35:22 UTC
*** Issue 46990 has been marked as a duplicate of this issue. ***
Comment 9 lars 2005-12-18 12:36:34 UTC
*** Issue 59490 has been marked as a duplicate of this issue. ***
Comment 10 ace_dent 2006-01-27 08:59:34 UTC
*** Issue 59725 has been marked as a duplicate of this issue. ***
Comment 11 ace_dent 2006-01-27 09:05:35 UTC
Additional comment from closed duplicate Issue 59725 (transferred by 'ace_dent',
comment by 'crosstrax'):
QUOTE/
"Music does not play from one slide to another". This is a very common and 
much used feature in PP97 and must be fixed. People want to hear the music play 
(regardless of what type) until they assign a "stop music" (which is in your 
drop down menu) to one of the transitions of the slide show. At this time the 
music only goes for the length of time that the transition takes, not even the 
length of time that the slide is displayed!
/QUOTE

Regards,
Andrew
Comment 12 nevetslee 2006-02-02 20:02:45 UTC
This would be an awesome addition to the Open Office Suite. Does anyone know
when it might be looked at?
Comment 13 nevetslee 2006-02-02 21:50:05 UTC
This would be an awesome addition to the Open Office Suite. Does anyone know
when it might be looked at?
Comment 14 baaann 2006-02-20 23:01:15 UTC
I haven't tried to do this, but having seen the recent thread on the users list,
I  stumbled on a couple of possible solutions.

1. RaccoonShow - http://www.jonobacon.org/projects/raccoonshow/

This takes a pdf presentation and blends it with an audio file, using a text
file to specify the timings, into a flash file. It appears to be Linux specific

2. W3C SMIL spec - http://www.w3.org/TR/REC-smil/

I would have thought that this would be relatively simple to implement as an
export filter.

Barrie
Comment 15 ajmc 2006-02-21 13:59:54 UTC
The capability to play a sound file through a presentation has been in Excel
since at least 1997. That some are willing to stand on their heads to make it
happen should indicate that it's an important feature.
Comment 16 nevetslee 2006-03-23 21:50:52 UTC
It'd be great to see this issue marked as a P3 or a P2. I think it does affect 
a lot of users. Ignoring the fact that this would make Powerpoint easier to 
leave behind, it would make a presentation software that offers more 
functionality and would be much more attractive.

Steven
Comment 17 guyjohnston 2006-05-17 16:39:13 UTC
This seems like a very important issue stopping MS being left behind, from the
number of comments and duplicate issues.
Comment 18 nevetslee 2006-05-18 16:16:40 UTC
I'll keep this alive by posting again, and I'll check out RacoonShow.

Comment 19 baaann 2006-05-18 17:40:50 UTC
There is another app which may be useful, Limsee2. It is a Java app, which
outputs SMIL format and can import Impress slides. 

http://wam.inrialpes.fr/software/limsee2/

http://www.ercim.org/publication/Ercim_News/enw62/deltour.html
Comment 20 renatoyamane 2006-09-07 21:26:46 UTC
In 02/01/2006, the user linux_karen say:
"This is a powerpoint compatibility bug and a real problem for me"

2,5 years later I re-write:
This is a powerpoint compatibility bug and a real problem for me.

Don't forget this bug :-)
Comment 21 utomo99 2006-10-31 11:15:26 UTC
I think better if the reporter attch a sample bugs file, so developer can see 
if something missing when opened in OOo. 

I believe that will help make it faster for considering the bugs.

Thanks
Comment 22 jondoe 2006-10-31 18:09:10 UTC
The difficulty in demonstrating this bug with a sample is that the sound file
isn't embedded directly into the presentation file.  At least, with my meager
PowerPoint/Impress skills I haven't gotten the same functionality with an
embedded object as a linked sound.  And, to complicate things PowerPoint (once
again with my limited knowledge) doesn't seem to allow you to set the file path
as relative.  I don't even know if Impress will allow you to do that.  (Relative
file paths would be far superior for various obvious reasons.)

That said, I'll attach a rar archive that works correctly in PowerPoint.  If you
don't get the intended results at first, you should be able to get the same
results by inserting the sound file (or any sound file) from scratch and
matching all of the custom animation settings for the sound in this file.
Comment 23 jondoe 2006-10-31 18:16:29 UTC
Created attachment 40198 [details]
Sample (may require some fidgeting to work correctly)
Comment 24 jondoe 2006-10-31 18:21:42 UTC
Created attachment 40199 [details]
Sample.zip (in case you can't open a rar file)
Comment 25 utomo99 2006-11-01 04:12:15 UTC
to BH:
Please consider this RFE, because many duplicates and also have many votes. 
and the data I think is enough.

Thanks
Comment 26 christian.guenther 2006-11-15 11:09:54 UTC
*** Issue 71546 has been marked as a duplicate of this issue. ***
Comment 27 Rainer Bielefeld 2006-11-23 13:59:43 UTC
*** Issue 71870 has been marked as a duplicate of this issue. ***
Comment 28 Rainer Bielefeld 2006-11-23 14:01:38 UTC
*** Issue 29698 has been marked as a duplicate of this issue. ***
Comment 29 Rainer Bielefeld 2006-12-15 08:10:42 UTC
*** Issue 72600 has been marked as a duplicate of this issue. ***
Comment 30 jasonmac 2006-12-28 22:51:05 UTC
this is a major compatibity issue for us with PowerPoint in our education
environment K-12
Comment 31 mmibobwood 2007-01-05 17:27:54 UTC
It is hard to understand why this is listed as a P4.  When it come to the
functionality of "Presentation" this is a much needed feature.  The truth is
failure to include this feature is limited the adoption of OpenOffice on the
office, school, and church computer.  This needs to be moved to P3 or P2 level
and resolved before the next release or MS PowerPoint will continue to be the
Presentation software of choice. 
Comment 32 nadavkav 2007-01-05 21:09:20 UTC
i agree (move it to p3 or p2)

we have students complain about this LITTLE issue on many schools in which we
installed OpenOffice
Comment 33 radams 2007-01-05 21:41:42 UTC
I worked for a company, Micrografx, that made a competitive product to 
PowerPoint called Charisma. This is one of the things that users clamored for, 
and that we delivered in Charisma 4.0.

In 1992.

So I agree that OOo needs to get with the 21st century and make this 
functionality a priority.
Comment 34 cosmo81 2007-01-08 16:36:48 UTC
I can't believe that there is no activity on this issue. Every second question
in the impress-forum is: How can I play music over all slides?

The priority should be P3 or P2 not P4 and the target milestone should be 2.2,
2.2.1 or 2.3!

It could not be So difficult to ad this simple feature.
Comment 35 kpalagin 2007-01-08 17:10:28 UTC
cosmo81,
suggest people register at http://www.openoffice.org/servlets/Join and vote 
for this issue (leaving additional comments would be redundant and 
counterproductive as it will just annoy developers).
Hopefully when counter reaches 200 Sun will consider this enhancement for 
implementation.
Comment 36 caiot1 2007-01-13 00:46:05 UTC
A few changes to make it more visible to developers looking for something to do.

We can't set the target without a developer.

It's not needed to add comments here since most developers won't read them.

To vote is a good thing to acquire visibility, so you can ask the people you
meet who wants this enhancement added to the product to vote for it.
Comment 37 Rainer Bielefeld 2007-01-13 08:46:21 UTC
Restore 'Version' due to
<http://www.openoffice.org/bugs/bug_writing_guidelines.html> ("Version: In which
product version did you first find the issue?") 
Comment 38 caiot1 2007-01-13 16:19:19 UTC
"If applicable".

It's a request for enhancement Rainer.

The version where you find an issue is useful for new bugs or regressions, since
it makes a lot easier for the developers to track it.

"The version someone first request for an enhancement" doesn't matter at all.

Comment 39 caiot1 2007-01-13 23:42:33 UTC
Rainer: discuss it in the QA mailing list if you dislike it for any reason,
changing it to 2.0. I've started a thread about this topic.

Comment 40 shaunmcdonald131 2007-02-16 10:43:42 UTC
*** Issue 74588 has been marked as a duplicate of this issue. ***
Comment 41 shaunmcdonald131 2007-02-16 10:46:41 UTC
Adding cc of duplicate issue.
Comment 42 gvanspeybroek 2007-03-21 15:50:34 UTC
IS THERE STILL NO SOLUTION FOR THIS PROBLEM. I DOWNLOADED JONDOE'S SAMPLE BUT 
IS DOES NOT WORK.
Comment 43 bettina.haberer 2007-03-21 16:14:32 UTC
Hi Christian, this is a strongly asked enhancement request.  Is this issue still
on your list? 
Comment 44 clippka 2007-03-21 16:30:30 UTC
When this issue is so easy to fix why is there not yet a patch attached to this
issue?

cl->bh: yes it is on my very long list of very important issues but if no one
gives us more developer resources it will stay on that list. it is not that easy
to fix, it will take time that we currently don't have.

the beauty of open source, you get blamed but not paid *sigh*
Comment 45 revnomad 2007-03-21 19:16:32 UTC
Hmph I'm a pastor I completely understand your frustration.  I consider this
very important but not letting it get in the way of using OpenOffice.  

Keep up the good work.
Comment 46 renatoyamane 2007-03-22 13:21:15 UTC
revnomad, if you need a music in your presentation, you understand why this
issue have more than 200 votes and a lot of request since 2004!
And pls, read comment of radams in Jan/05/2007.
Best regards,
Renato S. Yamane
Comment 47 marshfeldman 2007-03-22 14:31:26 UTC
Revnomad,

It's not just about music. I teach an online urban geography course totally on
the Internet. I want to post lectures on the course web site using Impress. In
many instances, the natural flow of the verbal narrative spans multiple slides.
In other instances, noises like car horns, jack hammers, and so on ought to span
slides. In still other instances, the sounds should make a transition, say from
jack hammer to bird chirping, as the lecture moves from the street to the park.
I look forward to the day when I can not only completely customize the
synchronization between different media but also convert the entire presentation
to flash without losing any effects.
Comment 48 cedric_vdd 2007-03-25 15:07:37 UTC
J'anime des stages en milieu associatif et cette option me fait cruellement
défaut et m'empêche d'utiliser complétement Linux lors de ces stages.
Comment 49 maximusx 2007-03-29 14:46:26 UTC
I think it's about time that the higher-ups in OpenOffice's Development
Department give this some serious thought. The fact that Impress is unable to
play an mp3 file over multiple slides is one of the things that makes is less,
well, impressive than PowerPoint. This issue has been up for over 3 years, and I
think it's time that the OOo programmers actually LOOKED at this issue and did
SOMETHING to resolve it.
Comment 50 zrnk 2007-04-03 22:56:31 UTC
Yes, I completely agree with Maximusx that it is time to "put out or shut up"
about OOo being a complete replacement for other office suite programs. The run
around that users have had to put up with is embarassing to say the least. How
can any user promote a faulty product ? I have very little good to say to anyone
about OOo !! (No)thanks for the program...Zrnk..
Comment 51 cno 2007-04-04 07:49:59 UTC
@znrk: IssueTracker is for serious comments, not for flames.
Comment 52 rosman 2007-04-14 15:11:17 UTC
I just installed OOo 2.2. I would say that in OOo 1.1.4 that problem didn't exist.
In fact it was easy, in a first step, to set 'nosound" and "a transition" for
all slides and then , in a second step, set the desired music only for the first
slide.
After (or before) choose a slow transition for the first slide. Then click
"read" to start one transition who starts also the music. A second click on the
slide (or on read) DURING the sound holds the music up to the end. Then go to
diaporama. 
This for Windows 98.
May be I will go back to 1.1.4 
Comment 53 Martin Hollmichel 2007-05-15 08:02:34 UTC
@ka, I'm adding you as the project lead to this issue.

@cgu: can you confirm as regression to 1.1.x ?
Comment 54 christian.guenther 2007-06-11 11:28:04 UTC
*** Issue 78281 has been marked as a duplicate of this issue. ***
Comment 55 bruce61 2007-06-11 12:03:55 UTC
I am curious as to why Issue 34517, which has been made a duplicate of this
issue had a priority setting of 'P2'. 
I'd admit this is an enhancement (though it is one that Powerpoint has a basic
feature) and that maybe(?) a P2 rating is pushing it. However, for those looking
for an alternative to Microsoft Powerpoint, and who make use of features, this
lack of being able to play a sound file over more than one side makes IMPRESS
less of a choice in replacing Powerpoint. It also makes it harder to boast about
the product when comparing it to Mircosoft. So while not a program 'bug', it is
sure starting to bug me.
Comment 56 solonor 2007-06-11 12:37:56 UTC
Open Office has been my choice for word processor and spreadsheet for a long
time. Sadly, when I finally found the need to use its presentation tool, it
totally failed. Impress got tossed for IrfanView because of this lack of
functionality.
Comment 57 k_zoldik 2007-06-11 13:40:59 UTC
This is a big issue, expecially when importing a powerpoint document. I may lose
a  big part of the content of the document and be forced to search alternative
software!
Comment 58 grillon 2007-06-11 15:19:13 UTC
Hi all,
IMHO, the feature is already present - Impress does indeed play sounds in
presentations - but it doesn't work as expected - halts after 1st slide - so I
see it as a bug. And a serious one, since it prevents one from migrating to OOo
if presentations with sounds are a critical need.
Happily for me, I don't need it, but I won't advocate Impress to other people
because of this issue (though all the rest of the suite is great).
I apologize for not being a programmer and indeed help instead of only complain.
But I'd like to join the choir intending to show how important this fix is.
Many thanks,
Grillo
Comment 59 clippka 2007-06-11 16:48:01 UTC
Indeed this is a bug.

Sounds from slide transitions should play until the next slide that also has a
sound set or has <stop previous sound> selected. Also the sound should loop if
"Loop until next sound" is enabled.
 
I fixed the user interface to actually do something with the "Loop until next
sound". I added the property to the core, the api and fixed the slideshow module
to support loop and not stop the sound if current slide has no sound. Still open
is that loop does not work with the XPlayer, have to debug this. Also file
format has to be added for the loop property.  
Comment 60 marshfeldman 2007-06-11 20:57:28 UTC
Ideally, sounds should synchronize with slides in several different ways: (1)
one sound per slide (as current), (2) sound continues until next slide with a
sound or <stop previous sound>, (3) for a set time, (4) until an event (e.g.,
mouse click, specific transition type, etc.). The ability to add tracks and
synchronize them with slides, ala Microsoft's Producer for PowerPoint, is what
we really need. For example, on track could have music and another, narration.
Export to Flash, and you have a real killer app.
Comment 61 zrnk 2007-06-12 02:26:06 UTC
Wonderful news that the bug is fixed. Now, how do us humble users get the fix ??
When I had my program check for new updates, none were available.
Comment 62 hub 2007-06-12 02:29:48 UTC
zrnk: it is not fixed. It is marked as STARTED. That means that someone is
working on it. The target is currently set to 2.3. That means it is scheduled to
appear in OpenOffice.org 2.3. Note that this is not a committment it is just
planning.
Comment 63 clippka 2007-06-13 12:14:41 UTC
changed the xml format that we redundantly export the slide transition and the
sound inside the smil animations. This enabled me to use the repeatCount
attribute of the audio element to store if the sound should loop. This will also
be helpfull for future developments, f.e. synchronized audio.

Currently playing a song over more than one slide works. The <stop previous
sound> options seems not to be implemented, will look into this now.

Looping of sounds does not work, maybe I need to write a follow up issue on this
one as it is a problem inside the avmedia component.

All interested, please stay tuned for 2.3 beta
Comment 64 clippka 2007-06-13 12:27:08 UTC
reassign issue to me
Comment 65 pagalmes.lists 2007-06-13 12:31:00 UTC
cl: Why did you moved the issue from started to new ?
Comment 66 clippka 2007-06-13 13:51:02 UTC
cl->pagalmes: I didn't, issuezilla did it after I reassigned this issue to myself

Update: I submitted issue 78386  for the problem that looped sounds do not work.
Comment 67 pagalmes.lists 2007-06-13 15:33:49 UTC
cl: tricky software ;-)
Comment 68 clippka 2007-06-14 11:16:04 UTC
now works as expected even with stop sound except the looping. Now SJ has to
update the ppt im/export.
Comment 69 sven.jacobi 2007-06-14 16:22:25 UTC
sj: now the ppt import/export is also supporting sound loop/stop for slide
transitions..
Comment 70 hub 2007-06-14 16:22:33 UTC
what is the API for that?
Comment 71 srilyk 2007-06-15 20:11:20 UTC
I should think you could make at least a quick hack for this - the OO media 
player will play a music file throughout the whole show - it even has the 
option to repeat. Is it not possible to just work with the controls that are 
already there?
Comment 72 renatoyamane 2007-06-16 22:19:12 UTC
Pls, can someone edit "Issue 24969 depends on", inserting #78386?
I don´t have permission to do that.

Best regards,
Renato
Comment 73 clippka 2007-06-18 11:32:10 UTC
cl->hub: XDrawPage has the new boolean property "LoopSound" for looping sound.
The old property "Sound" which stores the url for a slide transition sound can
now also hold a boolean=true which indicates a stop sound.

cl->renato: imho this issue does not depend on issue 78386. Playing sound over
more than one slide works now, issue 78386 can be fixed at a later time, but
should also be fixed for 2.3
Comment 74 clippka 2007-06-18 12:24:53 UTC
cl->cgu: please verify
Comment 75 christian.guenther 2007-06-19 19:01:59 UTC
CGU: Verified in cws impress122
Comment 76 flechette 2007-08-09 17:50:50 UTC
ne pas pouvoir intégrer un fichier son tout au long d'un diaporama manque
cruellement depuis si longtemps.
J 'aimerais vraiment que cet oubli soit corriger et je remercie l'équipe par avance.
flechette
Comment 77 clippka 2007-08-13 11:36:38 UTC
naturellement
Comment 78 chkur 2007-08-31 08:09:10 UTC
Was decision of this issue included in OOo-dev? It doesn't work in 680m2. Or 
I'm not right? I insert sound on 1st slide and it plays only on 1st slide. 
Maybe, I must switch on some options?
Comment 79 ht990332 2007-08-31 08:16:06 UTC
Same as chkur, bug is still in OOG680_m2
Comment 80 yast 2007-09-04 09:42:33 UTC
J'espère que  bug concernant le son sur diaporama va être corrigée . Quand une
mise à jour va remédier cet retard devant PowerPoint ? Merci à toute l'équipe 
d'OpenOffice qui va faire diaporama pleinement fonctionnelle .
Comment 81 clippka 2007-09-04 16:28:08 UTC
my fixes collided with some structural changes in the slideshow project. The
file slideshow/source/engine/presentation.cxx was removed in m2 and replaced
with slideshow/source/engine/slideshowimpl.cxx.

I readded my already tested fix to the new file
Comment 82 clippka 2007-09-04 16:31:13 UTC
fixed again and commited to cws impress130 for OOo 2.3
Comment 83 clippka 2007-09-04 18:44:45 UTC
verified in cws, back to qa
Comment 84 christian.guenther 2007-09-04 19:50:06 UTC
And verified in cws impress 130
Comment 85 maximusx 2007-09-07 14:37:36 UTC
Quote:

------- Additional comments from cl Tue Sep 4 15:28:08 +0000 2007 -------

my fixes collided with some structural changes in the slideshow project. The
file slideshow/source/engine/presentation.cxx was removed in m2 and replaced
with slideshow/source/engine/slideshowimpl.cxx.

I readded my already tested fix to the new file------- Additional comments from 
cl Tue Sep 4 15:31:13 +0000 2007 -------

fixed again and commited to cws impress130 for OOo 2.3------- Additional 
comments from cl Tue Sep 4 17:44:45 +0000 2007 -------

verified in cws, back to qa------- Additional comments from cgu Tue Sep 4 
18:50:06 +0000 2007 -------

And verified in cws impress 130

End Quote.

ladies and Gentlemen, as intellectually stimulating as this discussion of files 
being replaced and XML being edited and such... I am an IT nut. Programming 
lingo does not interest me. It leaves me with nothing more than a headache, so 
I really must ask, and I would prefer to have a straight answer: Has the 
problem been fixed for OpenOffice 2.3, Yes or No? that's all I want to know. 
Thank you.
Comment 86 shaunmcdonald131 2007-09-07 14:57:05 UTC
This should be in the current RC builds for 2.3. They are available for you to test. Please download from 
http://download.openoffice.org/680/index.html?intcmp=1232
Comment 87 maximusx 2007-09-10 13:19:22 UTC
I'm glad this issue has finally been resolved, but I've checked the RC Release 
botes. I'm guessing that iVWXYZ (where v, w, x, y, and z are numbers) refers to 
a specific issue, but I don't see a little note marked "i24969" in the notes. 
am I missing something from the list, or is it due to be added later on?
Comment 88 shaunmcdonald131 2007-09-10 17:04:15 UTC
impress130	
OOo 2.3 show stopper bug fix.

OOG680m4

Is the item that relates to this issue on the release notes page.
Comment 89 bruce61 2007-09-18 14:20:34 UTC
Am I right in assuming that while Issue # 24969 might have a STATUS of Verified
and a RESOLUTION of FIXED, it hasn't been released as part of OOo 2.3 because it
depends on Issue # 78386 which has as its TARGET MILESTONE OOo 2.4.

If so, does that mean we have to wait to the next major release to see this
DEFECT finally fixed and working?
Comment 90 clippka 2007-09-18 14:32:18 UTC
no, this issue is fixed in 2.3. You just can't make the sound loop
Comment 91 ht990332 2007-09-18 14:37:12 UTC
cl, is there an open bug for making the sound loop?
Comment 92 rossnixon 2007-09-19 02:40:42 UTC
[Off Topic] There are "work arounds" for sound not playing over more than 1
slide and for sound not looping. I'm still on OOo 2.2 and uses macros for this.
My macros use 1by1 (Windows freeware) to play the sound, as this can run with no
user interface, the ini file can be edited to loop the sound, and global hotkeys
can be enabled so the sound can be paused and restarted (F8).
Comment 93 christian.guenther 2007-09-21 09:37:58 UTC
CGU: integrated in src680m229 and oog680m5
Comment 94 andthink 2007-09-24 07:52:18 UTC
Fixed? But How do I insert a background music? I can't!

Help
Comment 95 christian.guenther 2007-09-24 12:55:33 UTC
You must only assign a sound to a slide (in the slide transition dialog)
The sound plays as long as you assign another sound to another slide.
Comment 96 radams 2007-09-24 21:19:54 UTC
How is this 'Closed' and 'Fixed'? And what's up with your latest comment: "You 
must only assign a sound to a slide (in the slide transition dialog)
The sound plays as long as you assign another sound to another slide." Are you 
saying each slide only plays the associated sound? If so, then please re-read 
the Summary description: "[RFE] Presentation should play a sound file over more 
than one slide".

Or does this mean that sound can span slides, as long as at least one other 
slide has a separate sound? If so, that's still screwy and still needs to be 
fixed.
Comment 97 gamaral 2007-09-24 23:28:00 UTC
Yes, Radam.
The feature is implemented in OOo 2.3.
But...
- Opening a ppt/pps file with sound, Impress play the sound over more than one
slide continuously: The powerpoint compatibility bug resolved.
- Create a new presentation in Impress, assign a sound to a slide (in the slide
transition dialog) and select Apply for all slides. Nevertheless isn't possible
play the sound continuously in the slide sequence... the sound begin again after
every slide.... bad, bad!!!

Apparently the feature isn't implemented for the Impress interface.. but it's
present, vide opening PPS/PPT files...
Comment 98 renatoyamane 2007-09-25 00:01:21 UTC
You are doing wrong!
Don´t click in "Apply for all slides".
This feature work very well in OOo 2.3

Regards,
Renato S. Yamane
Comment 99 gamaral 2007-09-25 00:44:16 UTC
Oh, yes!
You have reason!
Discarding my commentaries....
The issue is Fixed.
Comment 100 Rainer Bielefeld 2007-12-21 12:22:02 UTC
*** Issue 84819 has been marked as a duplicate of this issue. ***
Comment 101 tj88 2008-02-28 07:25:07 UTC
Where do I get the fix? I'm still having this problem, and updating doesn't seem
to pick it up. Where is the download link for the fix?

HELP!
Comment 102 Rainer Bielefeld 2008-02-28 08:28:18 UTC
@tj88:
This is no help desk, so you should please discuss your problem in some user
mailing list! How can we recommend a fix without any knowledge concerning your
OOo, PC, OOo-version, PRESENTATION-document?

Please feel free to file a new issue if result of discussion in user mailing
list is that there really still something has to be fixed and if you can
contribute required information. 

But before you do so please read our guidelines on
<http://qa.openoffice.org/issue_handling/pre_submission.html> and  
<http://www.openoffice.org/bugs/bug_writing_guidelines.html>.
Comment 103 renatoyamane 2008-02-28 10:58:22 UTC
tj88,
This issue is fixed in OOo 2.3
Sound can be reproduced in more than 1 slide, BUT *loop* is not working.
Loop problems can be checked here:
http://www.openoffice.org/issues/show_bug.cgi?id=78386>

Regards,
Renato