Issue 25342

Summary: Envelope in landscape mode prints in portrait mode
Product: Writer Reporter: peterhb <phb>
Component: codeAssignee: h.ilter
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, utomo.prawiro
Version: OOo 1.1.1b   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
the detailed description none

Description peterhb 2004-02-10 18:46:33 UTC
Regrettably the paper handling modifications in OOo 1.1.1b, which resolved the
problem described in Issue 17439, have apparently introduced a new bug.

It is no longer possible to successfully print a DL sized envelope via the
envelope slot in the paper feed mechanism of the HP DeskJet 970Cxi and the
DeskJet 890C. The envelope is handled as if it were orientated for portrait
printing, rather than the correct landscape orientation.

This bug was not present in any prior release of OOo at least as far back as 1.0.3.
Comment 1 mci 2004-02-12 09:32:50 UTC
set target
Comment 2 utomo99 2004-03-03 03:33:15 UTC
utomo > Mci:
Please explain why the regression from OOo 1.1.0 which occur in 1.1.1b is 
targetted for OOo later ? 
Please consider to include this in earlier version. 
In my opinion we better to delay the OOo 1.1.1 release little bit and avoid 
this regression. just my 2c.
Thanks
Comment 3 mci 2004-03-03 12:26:05 UTC
Hi,

sorry, I accidentally chose the wrong target...

We were not able to reproduce this behaviour yet.
I'll try to reproduce this the next days...

Thanks for the advice...
reassigned to mci
Comment 4 peterhb 2004-03-10 18:54:53 UTC
Confirmation that the bug is still present in OOo 1.1.1rc.

Regards
Comment 5 mci 2004-03-12 08:44:44 UTC
reassigend to os

@ os: I think this is something for you...
It seems that the buttons for landscape mode have the function of portrait mode
and vice versa...
Comment 6 Oliver Specht 2004-03-16 06:58:47 UTC
os->ssa: As issue 17439 was yours this one should be yours, too.
Comment 7 thorsten.ziehm 2004-03-16 08:44:04 UTC
remove me from CC
Comment 8 mci 2004-03-16 09:06:23 UTC
remove mci from cc...
Comment 9 stephan_schaefer 2004-03-16 11:12:59 UTC
ssa->mci: I cannot do much with such a vague description. Please check carefully
what exactly does not work withg regards to landscape/portrait printing and with
what printer.  If the buttons would have their meaning swapped, as you guess, do
you really think this only affects envelope printing ??? This statement seems to
be totally useless and probably not tested.
Comment 10 peterhb 2004-03-16 18:59:18 UTC
Message for mci & ssa:

When I first raised the issue of this bug I described it in clear and concise
English and I too cannot understand the nonsense about "buttons".

I would be obliged if you would read my original report and advise me of any
lack of clarity that I can address. For further information, I have confirmed
that the printers are reset to portrait mode during the print process. Manually
setting the printer properties to DL Paper Size and Landscape orientation in the
Print dialogue prior to printing does not "stick" and it is clear that OOo is
issuing an over-ride to force Portrait mode.

Regards

Peter HB
Comment 11 mci 2004-03-17 20:37:24 UTC
Created attachment 13883 [details]
the detailed description
Comment 12 mci 2004-03-17 20:42:00 UTC
reassigned to ssa

@ ssa: 
I attached a more detailed description
sorry for the size...
I offered os to use the HP 970Cxi for testing and I offer to use it to you for 
testing, too...

Maybe now it's a little bit more clear what I meant with that "nonsense about 
buttons"...
Comment 13 stephan_schaefer 2004-03-19 09:56:05 UTC
ssa->mci: thanks for the good explanation  !

The problem was indeed a possible override of the orientation set by the user
and existed since OOo1.1.

Fixed in CWS vcl7pp3bugs and vcl21.
Comment 14 peterhb 2004-03-27 22:06:08 UTC
It's good to see that my issue has been fixed, and it would be even nicer if
someone could translate the "Fixed in CWS vcl7pp3bugs and vcl21" comment into an
externally usable build and/or release number. It clearly isn't fixed in
1.1.1rc3, Build 8762 and it would be nice to be able to identify the release in
which the fix will become generally available.

Pretty please.

Regards

Peter HB
Comment 15 stephan_schaefer 2004-03-30 10:24:20 UTC
ssa->phb: The fix is scheduled to be in the next StarOffice ProductPatch which
will correspond to OOo 1.1.2. It will also appear in any developer release of
the 680 branch as soon as the code is integrated. But as it first has to pass QA
I cannot tell when this will be.

ssa->hi: I received positive feedback from mci who tested the patch on his
printer. Because the fix affects orientation and paperformats please check the
following issues as well:

#106890#
i21775
i17439 (actually duplicate to i21775, but different printer)


Comment 16 h.ilter 2004-04-06 11:02:12 UTC
Verified with cws:vclpp3bugs:

HI->SSA: Unfortunately not quite fixed.
1. The Text will printed on Envelope and the Sender/Recipient on the letter
2. To avoid point 1, print in reverse mode. The Envelope is ok but the text on
the letter is cut.
Comment 17 h.ilter 2004-04-06 14:26:51 UTC
HI->SSA: I must excuse. Forget point one, my printer was adjusted to begin with
last side to print. So I'll look since when it goes wrong because it is all fine
in Office 7.0 final release without any patch.
Comment 18 h.ilter 2004-04-06 15:18:18 UTC
HI->SSA: OK, the text-cut ocurs since 645m32_8751 and has nothing to do with
your fix.
I'll open a new task for it.
Comment 19 h.ilter 2004-04-06 15:19:08 UTC
Button bug is fixed.
Comment 20 h.ilter 2004-04-06 15:19:44 UTC
Verified with cws: vclpp3bugs = ok
Comment 21 h.ilter 2004-04-07 08:31:01 UTC
To follow up the text cut, see issue 27514
Comment 22 mci 2004-04-08 14:21:24 UTC
*** Issue 27560 has been marked as a duplicate of this issue. ***
Comment 23 Rainer Bielefeld 2004-04-17 09:40:49 UTC
*** Issue 27825 has been marked as a duplicate of this issue. ***
Comment 24 boldi 2004-04-19 01:06:50 UTC
I can ackowledge this bug extists in 1.1.1. 
(History: I made a document in word for printing envelopes. It was converted 
to ooo and used to print envelopes. It correctly worked in 1.1.0 but in 1.1.1 
the same file results in a rotated something instead of the correct envelope 
(hp laserjet2100). I hope 1.1.2 will correct this issue.
Comment 25 stephan_schaefer 2004-04-29 15:40:57 UTC
*** Issue 28442 has been marked as a duplicate of this issue. ***
Comment 26 accordce8 2004-05-04 14:47:31 UTC
like boldi, i can confirm this bug occuring in 1.1.1, 1.1.0 was o.k.

when a patch is available before 1.1.2 is released, you can contact me to test.
 
Comment 27 h.ilter 2004-05-07 14:09:45 UTC
The fix from this issue is integrated in OOo 1.1.2
Verified with 645m42_8779, which will be public soon.
Comment 28 h.ilter 2004-05-07 15:09:22 UTC
*** Issue 21022 has been marked as a duplicate of this issue. ***
Comment 29 peterhb 2004-05-14 16:22:47 UTC
As the original reporter of this bug, it is a pleasure to confirm that it has
been eliminated in OOo 1.1.2rc2.

Regards

Peter HB