Issue 25756

Summary: WW8: drawings inside frames cannot be exported
Product: Writer Reporter: utomo99 <utomo.prawiro>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P5 (lowest) CC: ahz001, caolanm, issues
Version: OOo 1.1.1a   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
bug doc
none
shorter version, same problem... none

Description utomo99 2004-02-21 05:19:22 UTC
export to doc, page 2 3 and 4 damage
Comment 1 utomo99 2004-02-21 05:20:01 UTC
Created attachment 13337 [details]
bug doc
Comment 2 michael.ruess 2004-02-27 10:24:27 UTC
Created attachment 13464 [details]
shorter version, same problem...
Comment 3 michael.ruess 2004-02-27 10:29:17 UTC
MRU->CMC: there are some drawing groups which are anchored inside frames. This
does not seem to work together; the object groups are not selectable anymore in
WW and their positions are wrong. Also the assertion "Der escher-Stream wurde
schon geschrieben" rises.
Comment 4 caolanm 2004-03-02 09:35:24 UTC
This is because word doesn't allow drawings inside drawings. If you try it you
either get a drawing which is "positioned" inside a drawing, but not anchored
inside it, or you get an inline picture which is merely a snapshot of the
original drawing, and not a drawing anymore.
Comment 5 caolanm 2004-03-04 13:48:22 UTC
cmc->mru: Word can't do this, which is why there are asserts and no content on
export. Perhaps we should implement a feature in the filter to detect this case
(which we already do) and take a snapshot image of the drawing and export this
new graphic as a replacement for the drawing. If we do this the final image
could only be exported as an inline graphic. 

If you think this is a required hackaround word's problems then reassign to mmaher. 

(cmc->mmaher:) some sample code to get a snapshot graphic of a drawing is in
svx/source/msfilter/escherex.cxx & escherdo.cxx. sj can help with that.
Comment 6 michael.ruess 2004-07-15 15:02:52 UTC
MRU->MM: Somehow in the future we should workaround this deficiency in WinWord
by the filter. Sometimes there are users, which have drawings e.g. in caption
frames and want to export to WW format.
Comment 7 michael.ruess 2004-07-15 15:03:44 UTC
corrected owner
Comment 8 martin_maher 2005-05-05 10:32:12 UTC
mmaher->flr: Your's methinks
Comment 9 michael.ruess 2005-07-22 06:38:55 UTC
*** Issue 52280 has been marked as a duplicate of this issue. ***
Comment 10 bhaskara 2005-07-22 17:23:43 UTC
You guys /gals are not saying that I cannot insert a textbox in word and cut
(from where ever) and paste a .bmp or .jpg into a text box , are u ?

I know word can handle it as I just did that and reloaded in word and OO and
image did not disappear. OO can do similar things in .odt. I also can insert
equation object into text boxes in word without a problem. Same in OO. BUT  ....
when a native .odt with a bmp pasted into a frame is exported to .doc the pasted
image is not saved ......Issue 52280 is data loss bug ( P2 ? )

-G  

Comment 11 michael.ruess 2005-10-06 09:52:50 UTC
*** Issue 54910 has been marked as a duplicate of this issue. ***
Comment 12 Mathias_Bauer 2006-08-30 14:54:41 UTC
assigned to hbrinkm
Comment 13 michael.ruess 2007-10-25 13:59:12 UTC
*** Issue 81935 has been marked as a duplicate of this issue. ***
Comment 14 bsb 2008-02-23 20:05:15 UTC
This issue also applies to the scenario of inserting a frame inside a frame in 
OO Writer, as I recently discovered. After the export to MS Word 2000 DOC 
format the inside frame is lost along with its contents.
I believe the content must not be discarded. A simple workaround for the 
inability of DOC to support nested objects would be to export the objects on 
the same level, that is, as standard text boxes or other objects in Word. It 
will probably not be possible to retain the formatting of the original 
document. But I'd prefer to lose formatting instead of losing content. 
Comment 15 eric.savary 2009-05-25 09:48:11 UTC
*** Issue 102206 has been marked as a duplicate of this issue. ***
Comment 16 Marcus 2017-05-20 11:27:38 UTC
Reset assigne to the default "issues@openoffice.apache.org".