Issue 27722

Summary: separate dialog for palettes
Product: General Reporter: Regina Henschel <rb.henschel>
Component: uiAssignee: bettina.haberer
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: bugs-openoffice, issues
Version: OOo 1.1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows 98   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description Regina Henschel 2004-04-13 10:10:47 UTC
Now, when you have a drawing-object, then in the format-area dialog you can
load, alter and save the palettes for colors(soc),gradients(sog), hatching(soh)
and bitmaps(sob). I think, that it is no good place.

Imaging you are in Calc and you will define an own color for a cell-background.
Now you have to draw a rectangle, go to the format-area dialog of the rectangle,
define your color, then delete the rectangle and then you can use the new color
for your cell background. The same thing in writer: Defining a new color for
font or background can only be done by a temporary draw object. That's not
intuitive. So people think, that defining new colors is impossible, see the
issues 11098, 16217 and 20105.
Another reason for a separate dialog is the fact, that the changes, which will
be made in the format-area dialog, will not only change the color of this
special draw object, but will change the available colors for all further using
of colors in that document. Such far-reaching changes should not be made in a
place, where each other thing is a hard formating of a single object.

I propose to make a new dialog "alter palettes" and place it into the Tools-menu
so that it is available without any draw-object, but continues being specific to
each document.
Comment 1 olo 2004-04-13 10:31:40 UTC
It should be implemented in a way that palette editing still remains available
from format-area dialog.

That means, preserve the features available on the relevant format-area tabs
(color, gradient, hatching, bitmap):
  * the buttons "Add...", "Modify...", "Delete...", "Load..." and "Save..." 
  * the dialog: "The (color|gradient|hatching|bitmap) was modified without
saving. Modify the selected (color|gradient|hatching|bitmap) or add a new
(color|gradient|hatching|bitmap).", which has the buttons: "Modify", "Add",
"Cancel" (the dialog is triggered by clicking "OK" when the fill style hasn't
been saved).

I find those features very useful.
Comment 2 olo 2004-04-13 10:41:12 UTC
See also a related Issue 27724.
Comment 3 thorsten.martens 2004-04-13 11:49:08 UTC
TM->BH: This is an enhancement, please have a look. Thanks !
Comment 4 Regina Henschel 2005-07-12 15:52:12 UTC
*** Issue 51840 has been marked as a duplicate of this issue. ***
Comment 5 peschtra 2005-07-12 19:19:57 UTC
I am marking this as a dup of 33392.

I did this, because 33392 has essentially the same request, but it asks for it
to be added to the options menu whereas this big seems to be solved.

Does that make sense?

*** This issue has been marked as a duplicate of 33392 ***
Comment 6 Regina Henschel 2005-07-12 20:16:20 UTC
This is not solved in any way, but I agree to close this, because the other has
1 vote and this request for enhancement should be focused in 1 issue.