Issue 28465

Summary: pressing arrow key or moving mouse with hold down left button leads to document changed state and "empty" undo step
Product: Calc Reporter: norbert2 <norbert.notz>
Component: codeAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P4 CC: issues, stefan.weigel
Version: OOo 1.1.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
issue28465.zip - avi-file
none
issue28465_new.zip - AVI-file showing the problem with the "new" steps to reproduce none

Description norbert2 2004-04-28 11:22:08 UTC
Please ...

- open a new spreadsheet

- double-click A1 in order to enter edit-mode

- hold down the left mouse key in over A1

- pull the mouse over B1 and release the mouse key there
(this is a kind of drag&drop without content :-) ):

Now the save-button is enabled AND (and that's the bigger problem) an undo 
action is added! Due to this drag&drop of nothing, Calc seems to handle this as 
cell edit, also nothing has changed!

I really see this as bug, because the cursor is not switched to drag&drop-
cursor when no content is selected. But it is handled as document-change!
(If you really drag&drop content in this way, a drag&drop-cursor is shown.)
So this is not an enhacement request, its a DEFECT.

(
Additional info:
There seems to be a equal problem when drag&drop out of the edit-line. But I 
can hardly reproduce this myself.
)
Comment 1 norbert2 2004-04-28 11:24:14 UTC
Please forget the sentence:
"Due to this drag&drop of nothing, Calc seems to handle this as 
cell edit, also nothing has changed!"

I think that the changement to B1 is cought by undo, not A1.

But it's your turn to find out...
Comment 2 norbert2 2004-04-28 11:26:42 UTC
I forgot to enter the 5. step to reproduce:

- press RETURN
Comment 3 frank 2004-04-30 09:58:48 UTC
Hi Norbert,

I've tied to reproduce this behaviour on 3 Plattforms (Linux, Solaris and
Windows) with 3 Versions of SO/OOo and was not able to reproduce it. Three of my
colleagues tried it also and no one could reproduce it. So I have no chice as
closing this Issue, sorry for that.

Frank
Comment 4 frank 2004-04-30 09:59:08 UTC
closed wfm
Comment 5 norbert2 2004-05-01 11:37:01 UTC
Maybe you have not seen the last step (press RETURN) that I have added in
another comment, because I have forgotten it.

I also have attached a small avi-video below that shows the problem. Please
download this small file and watch it.


And here the correct steps to reproduce:

Please ...

- open a new spreadsheet

- double-click A1 in order to enter edit-mode

- hold down the left mouse key in over A1

- move the mouse over B1 and release the mouse key there
(this is a kind of drag&drop without content)

- press RETURN:
Now the save-button is enabled AND (and that's the bigger problem) an undo 
action is added!
Comment 6 norbert2 2004-05-01 11:49:04 UTC
Created attachment 14902 [details]
issue28465.zip - avi-file
Comment 7 norbert2 2004-05-03 06:39:53 UTC
Oh...

I just have found out, that this problem can be reproduced much easier. No 
additional cell is needed.

Here the corrected steps:

- open a new spreadsheet

- double-click A1 in order to enter edit-mode

- hold down the left mouse key in over A1

- pull the mouse-pointer a bit and release the mouse key over A1:

Save button and undo are enabled.

(Because no drag&drop pointer is shown I see this as bug.)
Comment 8 norbert2 2004-05-03 06:42:45 UTC
With the sentence

"Because no drag&drop pointer is shown I see this as bug."

I do not mean that you should just add a d&d-pointer for "empty" drag&drop 
operations. No content should be in general not able to be drag&dropped.
Comment 9 norbert2 2004-05-06 07:41:31 UTC
Created attachment 15011 [details]
issue28465_new.zip - AVI-file showing the problem with the "new" steps to reproduce
Comment 10 norbert2 2008-09-08 19:55:37 UTC
Now I have steps which are more easy to reproduce, which doe not need using the
mouse:

- open a blank spreadsheet (cell A1 is focused)
- press F2
- press any arrow key (direction doesn't matter) *
- press RETURN

The undo button and the save button are enabled.

* Alternatively you can move the mouse a bit within the focused cell while
holding down the left mouse button.

Reproducible in OOo 3 RC1.
Comment 11 norbert2 2008-09-08 19:58:49 UTC
Please forget my old comments. This bug has nothing to do with drag&drop.
Comment 12 norbert2 2008-09-08 20:00:47 UTC
Additional info:

The described steps which do not modify the spreadsheet are interpreted as
"Input", the undo step is named "Input".
Comment 13 Stefan Weigel 2008-10-31 23:09:34 UTC
I can confirm this issue with all discriptions from the beginning given by
norbert2 with OOo 3.0.0 (OOO300m9).

However, I am not sure about the importance of this issue.

Norbert, can you estimate and evaluate possible bad consequences to the user?

I tend to reduce it to P5.
Comment 14 norbert2 2008-10-31 23:38:18 UTC
I think P4 is okay. (P5 is for more marginal problems in my opinion.)
Comment 15 norbert2 2009-02-25 12:55:32 UTC
This bug turned out to have nothing to do with drag&drop.

Please set this issue as duplicate of Issue 99617 which has a less confusing
description. (I don't have the privileges.)
Comment 16 Stefan Weigel 2009-05-13 19:09:11 UTC
duplicate, as indicated by the reporter

*** This issue has been marked as a duplicate of 99617 ***
Comment 17 Stefan Weigel 2009-05-13 19:09:48 UTC
closing