Issue 28595

Summary: Unable to select text which is above a background (watermark) image
Product: Writer Reporter: sforbes <xslf>
Component: uiAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, orw, pagalmes.lists, wbsong1978, www.openoffice.org
Version: 680m32   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Sample doc. try to add or edit the text in the document.
none
Another example- imported word doc none

Description sforbes 2004-05-01 15:42:47 UTC
After insertings an image, and settings it wrap options to "in background" and
setting it as page background, there is no way to select the text using the
mouse (or get to the text objects toolbar)- the images is always selected.

Steps to repro:
* Create a new writer document, and enter some text into to.
* insert a graphic to the document.
* in the graphic properties, set the wrap option to "in background", and check
the box "background".
I have set the image as anchored to the page, and as a watermark as well.
* When done, attempt to select the text with the mouse for more editing (or to
insert more text).

Actaul result:
The background image keeps getting focus, thus preventing any more editing to
the text

Expected result:
Text should be selecteble, and the user should be able to enter more text to the
doc.

More information:
Attempting to get to the text object toolbar by clicking on the triangle in the
toolbar area fails- OOo just switches between image toolbar and the border toolbar.

An example document is attached.
Comment 1 sforbes 2004-05-01 15:44:58 UTC
Created attachment 14908 [details]
Sample doc. try to add or edit the text in the document.
Comment 2 rblackeagle 2004-05-01 16:48:59 UTC
I've encountered the same problem on every version from 1.0 to 1.1.2rc.  The
workaround is to click on the page and reduce the margins so that there is some
blank text visible inside the margins, then click outside the watermark.  Now
you can move around using arrow keys (any attempt to use the mouse reselects the
watermark again).

There needs to be some way to put the watermark in the background so that one
click does not select the watermark but the text instead.  Of course, if that is
done, one also needs a means of selecting the watermark, too.  It is a disaster
for the watermark to take precedence over the text -- well, in some cases it IS
a disaster, especially if the watermark HAS to cover the entire page.

I haven't tried it in 1.1.2rc yet, but I also find that putting a graphic of any
size on a page with a watermark can cause extraordinarily bizarre behavior from
crashes to the graphic absolutely refusing to stay put. This may or may not have
anything to do with the watermark taking precedence over the text.
Comment 3 michael.ruess 2004-05-03 09:02:03 UTC
MRU->AMA: somehow in the future we should adress this problem. What I have in
mind could be something like this: when clicking into text over a graphic "in
Background", a dialog requesting wether the user would like to place the cursor,
select text or select the graphic.
This issue is somewhere between "Defect" and "Enhancement", so I assign this to
you at first. I don't know if it's necessary to have the UserExp to decide about
such things...
Comment 4 andreas.martens 2004-05-03 09:56:32 UTC
Simply press <ESC> if you're graphic is selected. Then you are able to edit the
text on that page. That's the work-around. I don't like the idea of another
dialog. I prefer a click into an already selected object should select another
object or text at the same position (if available). If you have some overlapping
object you have to click until the wished object is selected. 
Comment 5 sforbes 2004-05-03 11:37:00 UTC
I  agree that a dialog is a very bad ideas.
However, if you take a look at the attached doc, you will notice that since
*all* of the text is overlapping the graphic, clicking to select it just doesn't
work.

The problem with the esc. is similar- it indeed de-selects the graphic, however,
the insertion point is always at the begning of the text. If I attempt to move
it to another area, or select the text to manipulate it using the mouse (for
example, I want to change the font face of the 2nd word  at the 2nd line), the
graphic gets selected again. The text in this exmaple is short, so it isn't such
a big deal navigating using the keyboard. However, with longer texts, this is a
real problem.

I would like that in cases like this, when the graphic is the background of the
full pages, clicking on the area of the text *will not* select the graphic, even
if there is a graphic undernith it. In order to select the graphic then, click
in some distance from the text.
Comment 6 sforbes 2004-05-03 13:56:53 UTC
Created attachment 14937 [details]
Another example- imported word doc
Comment 7 sforbes 2004-05-03 13:57:34 UTC
Another example of this problem can be seen in the word2003 document I just
attached.
Comment 8 rblackeagle 2004-05-03 14:16:37 UTC
If the graphic is *background*, then the click should select the text first. 
Then, given the nature of a watermark, clicking on the edges of the printable
area can select the graphic.  As it is, once you have a watermark, the mouse
becomes useless.  I have tried it on material sent with a large "For Review
Only" watermark on each page only to find I had to remove the watermark to edit
the text and add it again.

Essentially, adding a watermark makes the text almost uneditable.  The ONLY real
workaround is to abandon the mouse altogether and resort to cursor keys only.
Comment 9 andreas.martens 2004-05-03 14:21:16 UTC
I agree, I named <ESC> as work-around because you're not able to get where you
want into the text.
My idea for a solution is to get one object/text after the other when you click
the same mouse position again. It's only an idea, not already implemented. My
next idea is to start such selection with the smallest object. If you have
overlapping objects/text areas you select with the first click the most "inner"
object/text. So in the first bugdoc you may select the graphic via click into
the page margin and the text via clicking into the text (once).
Comment 10 sforbes 2004-05-03 17:12:55 UTC
> My next idea is to start such selection with the smallest object. If you have
>overlapping objects/text areas you select with the first click the most "inner"
>object/text.

That is what I meant in my comment above. you worded better then me.
Comment 11 Regina Henschel 2004-05-03 18:45:51 UTC
I think another solution would be, that selecting depends on z-order. In that
case the text must get a z-order too.

The actual situation should be corrected. Think of this scenario:
You have a printed form and want to fill it. You have no typewriter and have to
do it with your computer. You scan the form and put it into the background of
your document. But you cannot put the text at the right positions because a
mouse-click always activates the background-graphic. 
Comment 12 michael.ruess 2004-11-15 11:15:59 UTC
*** Issue 37146 has been marked as a duplicate of this issue. ***
Comment 13 msandersen 2004-11-30 08:21:47 UTC
How this works in Quark, if you click on a stack of layers, if there's no text
but a graphic where you click, the graphic/layer is selected. Else the uppermost
layer is selected. By clicking with a specific key combination, (let's say
ctrl-click for OO), you subsequently click down in the layer stack.
Currently, in OO 1.1.3, even though you can see the borders of the individual
layers ('layer' being any stacked object; it happens to frames with text or
graphics, but for me not page backgrounds), clicking on the border of a
lower-down frame doesn't select it, though the top layer is transparent. 
Hence some intuitive behavior is called for; 
1. If you click on text on a top layer, that's what's selected; 
2. If you click on a graphic (in a clear area, even within the page margins, say
between paragraphs), then that is selected, whatever 'layer' it is on. 
3. If the text is then clicked, even with the background frame selected, the
focus should shift.
4. Consequently, you also need the key-combination click to select through the
layers with each click for complex overlays, cycling back to the top after the
bottom layer.
5. If you can't already (only installed it the other day), frames etc should be
able to be locked so only the frame can be selected, not moved or the content
altered, with a lock icon in the corner. Hence you can create you 'Confidential'
watermark in a frame and send it to the back and lock it, and it won't interfere
with the front. An item in the top menu should then be able to temporarily
release all locks.
Comment 14 bsahlhof 2005-03-17 21:08:41 UTC
I agree with msandersen, having some kind of <CTRL> + Click to access the
background image would be excellent.  I want to convert our entire company to
OpenOffice, but we've got a watermark on all our letterhead.  We will also need
to keep the ability open for switching from word to OOo and back to word again.
I consider this 1 annoyance that any company using watermarks, and requiring
both word and OOo would rate as one of the largest problems.
Comment 15 michael.ruess 2005-05-30 10:18:23 UTC
*** Issue 49976 has been marked as a duplicate of this issue. ***
Comment 16 michael.ruess 2005-08-15 10:20:11 UTC
*** Issue 53284 has been marked as a duplicate of this issue. ***
Comment 17 michael.ruess 2005-08-15 10:22:12 UTC
This probem becomes a bit more and more propular. I raised the Prio to 3 because
frome usability view this is a quite disturbing problem. Also see issue 53284.
Comment 18 mbirth 2005-12-08 13:17:41 UTC
Also faced this problem today. I think the best way would be: If an image object 
is set as "background", it shouldn't get selected by a normal click but rather 
by Ctrl+click (or any other modifier-key plus click). This would also keep the 
"Direct Cursor"-feature working.

Another proposal: Maybe if hovering text (cursor should turn into text-selector
), select text and if there's no text under the cursor (cursor is an arrow) 
select the image.
Comment 19 michael.ruess 2006-04-26 09:21:05 UTC
*** Issue 64211 has been marked as a duplicate of this issue. ***
Comment 20 michael.ruess 2006-06-12 12:16:29 UTC
*** Issue 66303 has been marked as a duplicate of this issue. ***
Comment 21 michael.ruess 2006-09-26 07:45:09 UTC
*** Issue 69852 has been marked as a duplicate of this issue. ***
Comment 22 kpalagin 2007-03-20 17:00:03 UTC
Dear developers,
any progress with this issue?
Thanks a lot for your attention!
Comment 23 michael.ruess 2007-04-02 10:15:13 UTC
*** Issue 75930 has been marked as a duplicate of this issue. ***
Comment 24 michael.ruess 2007-08-21 08:26:15 UTC
*** Issue 80857 has been marked as a duplicate of this issue. ***
Comment 25 pesala 2007-10-14 04:08:22 UTC
I agree that one way to fix this is to use a modifier key to select the background image. 
A second click will select the text in Serifâ„¢ PagePlus, but Control + Click is almost as 
good. 

If a graphic is on top of text with wrap through then the graphic should be selected first, 
with a second click selecting the text below. 

Note that two separate clicks is different to double-click, but a modifier key could also be 
used. A second click would be more usable as it does not require the use of the 
keyboard. 
Comment 26 pesala 2007-10-14 04:10:52 UTC
That should have been, “A second click will select the background imageâ€, but the same 
is true of text beneath a foreground image, even if the text is not visible. 
Comment 27 michael.ruess 2008-01-02 14:41:44 UTC
*** Issue 84938 has been marked as a duplicate of this issue. ***
Comment 28 michael.ruess 2008-01-02 14:52:26 UTC
*** Issue 84935 has been marked as a duplicate of this issue. ***
Comment 29 michael.ruess 2008-01-11 08:49:10 UTC
*** Issue 85159 has been marked as a duplicate of this issue. ***
Comment 30 foxcole 2008-02-03 17:43:43 UTC
This issue has been on the books for a very long time and continues to be a
problem for businesses that use background images as watermarks. I also believe
this problem runs counter to the primary purpose of a word processor, which is
to create and edit text content. 

Recent changes to the behavior of hyperlink text in edit mode were made partly
for this reason, that the focus of functionality should be maintained throughout
the application. I would have rated that issue far below this one in overall
impact and significance because that hyperlink issue was not a defect, while
this one about background images has been around for years. I am challenging the
prioritizing process here.

I see this issue is marked as "Started" but also set for "OOo Later". Is any
work being done? Could we please have an update on the status of this issue and
have a target milestone?
Comment 31 andreas.martens 2008-02-04 13:26:52 UTC
I looked at the code and found even not an ideal solution but at least an
improvement.
With my changes a mouse click does not select an object in the background, the
cursor will set into the "normal" text instead with two exceptions:
1. if the mouse click is into the page margin, even a "background" object will
be selected.
2. if the mouse modifier <Strg> (<Ctrl>) is pressed, the object is selected, too.

Fixed in CWS sw8u10bf05
edtwin.cxx
feshview.cxx
Comment 32 foxcole 2008-02-08 21:49:45 UTC
I was hoping that if the user is placing a text insertion point, the text would
be selected, but if using the drawing selection arrow, the image would be
selected. But the solution as it stands is definitely an improvement! Thank you!!
Comment 33 andreas.martens 2008-02-26 10:03:28 UTC
Ready for QA.
Comment 34 michael.ruess 2008-03-10 16:49:03 UTC
Verified the "fix" in CWS sw8u10bf05.
Unfortunately, direct text selection is still not designed, but this will be
solved later.
Comment 35 michael.ruess 2008-03-27 16:16:14 UTC
Checked fix in DEV300m5.
Comment 36 mtoakey 2008-05-29 16:58:48 UTC
I have tried many different times/ways and every time the picture just covers up
the text.
I want the picture as a background behind the text completely filling the
business card and not as a watermark.
I have tried "Arrange", "Wrap", "Anchor" and a few others. None do what I think
they should.
This should not be that hard, or that hard to figure out.
The text that is editable and part of the business card, becomes non-editable
after inserting a graphic as a background (2.00' x 3.50')
It will not accept being "sent to back" and the 'wrap to background' causes the
issue I mentioned earlier, only showing some of the text and disallowing any of
it to be edited.
Multiple graphics does not seem to affect the issue at all, however a small
graphic (smaller than the whole card) does not seem to experience the same trouble.
How about marking it as an "issue" to be fine tuned in future releases instead.
It is definitely not right the way it is now... and needs to be tweeked to work
"right". One should be able to 'insert' a graphic first, if they so wish, then
add or remove text at will, or edit at any time the text OR the graphic (crop,
or change the size or whatever) or do any combination of these in any order, to
include making the graphic a 'watermark' with the ability to vary the
"opaque-ness" of the graphic.