Issue 29210

Summary: Moving a group of objects moves connectors further
Product: Draw Reporter: tkomulai <tommi.komulainen>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: don.troodon, issues
Version: OOo 1.1.1   
Target Milestone: AOO Later   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description tkomulai 2004-05-14 19:03:14 UTC
1. draw 4 rectangles in a 2x2 grid, leave some space between
2. draw a connector from upper-left to upper-right rectangle
3. draw a connector from lower-left to lower-right rectangle
4. group upper-left and lower-left rectangles together
5. group upper-right and lower-right rectangles together
6. select all, Ctrl+A or draw the rubberband selection around all rectangles
7. move the selection

-> The connector lines are moved double the distance the rectangles are,
breaking the drawing
Comment 1 wolframgarten 2004-05-17 08:00:24 UTC
Reproducible. Reassigned to Armin.
Comment 2 wolframgarten 2004-05-19 10:25:26 UTC
Set to new.
Comment 3 Armin Le Grand 2004-05-28 10:24:41 UTC
.
Comment 4 knackaerts 2004-07-05 12:26:04 UTC
Problem still present in v1.1.2 (tested on WinXP). Move only the objects that
the connectors are linked to and the connectors move correctly. Select
connectors too, they'll move erroneously.
Comment 5 christian.guenther 2007-05-16 10:49:59 UTC
*** Issue 77417 has been marked as a duplicate of this issue. ***
Comment 6 Armin Le Grand 2008-07-02 15:23:35 UTC
Added note
Comment 7 Armin Le Grand 2008-07-02 15:43:57 UTC
*** Issue 91140 has been marked as a duplicate of this issue. ***
Comment 8 Marcus 2017-05-20 11:29:48 UTC
Reset assigne to the default "issues@openoffice.apache.org".