Issue 29278

Summary: Indexes: Stop numbering
Product: Writer Reporter: nunotavares <nunotavares>
Component: codeAssignee: eric.savary
Status: CLOSED NOT_AN_OOO_ISSUE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1.1   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description nunotavares 2004-05-17 22:20:39 UTC
I've been using OpenOffice (1.1.0)  intensively for some months, and would like 
to post some suggestions [SUG], and, perhaps, bug reports [BUG].
If you can, forward this to the oO bugzilla. I'm lacking the time to fill 
complete bug reports (at least for now).

Here we go:

#1:[SUG] I'm writing a document whose chapters are based on a Style. Index 
correctly gives them numbers, but a problem rises when you have a TOC like this:
------------
1. Introduction
...
4. Conclusions
References
Bibliography
-------------
ie, "References" and "Bibliography" should share the same style, but remain 
unnumbered. Yet, they should be included in the main Index. Perhaps an option 
to "stop numbering at mark"?
Comment 1 nunotavares 2004-05-17 22:23:36 UTC
See #29279 on how I use to do it (but it has its own counterparts).
Comment 2 michael.ruess 2004-05-18 07:05:19 UTC
MRU->ES: please evaluate.
Comment 3 eric.savary 2004-05-18 11:27:46 UTC
Your problem is somehow an "how to" question and not a bug report. Thus I should
not answer it but...

- Apply (for ex.) "Heading 1" to your Chapter headings
- Apply a custom style (let's call it "Heading 1 clone") looking like Heading 1
to the "Bibliography" and other secrion
- In the Index dialog, check "Additional styles"
- click on [...]
- Set "Heading 1 clone" to level 1
Done

Please, in the future, talk about issues first on users@openoffice.org or any
other suiting mailing list (http://www.openoffice.org/mail_list.html) to see if
your problem reveals a bug or a missing feature, if it has a workaround, if the
bug is known etc.

Comment 4 eric.savary 2004-05-18 11:28:11 UTC
closed
Comment 5 nunotavares 2004-05-18 15:00:58 UTC
I've posted it as an ENHANCEMENT, not a DEFECT...

Anyway, your suggestion works... I couldn't find any documentation, and I
thought that "Other styles" would get numbered as well. 

I'm very sorry for the mistake. I've posted this to the mailing-list before,
nobody seemed to know how to do it (didn't get *any* reply).