Issue 29845

Summary: export callouts to eps: wrong line width
Product: Draw Reporter: fkater <f.kater2>
Component: uiAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1.1   
Target Milestone: AOO Later   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
bugdoc none

Description fkater 2004-06-03 20:03:34 UTC
Hi,

this is a nasty one and required a bit of work to track:

* have a drawing
* place some callouts (text box with line to label things)
* place some normal lines
* edit line width of lines and callouts bigger and smaller of 0.3 mm
* export to eps
* view with gv or gimp

result: alle lines of the callouts with 0.3 and smaller width are displayed as
ultra fine lines instead of 0.3 mm (while the normal lines are exported ok)
Comment 1 fkater 2004-06-03 20:06:18 UTC
workaround: convert callouts to polyons before exporting
Comment 2 fkater 2004-06-03 20:33:05 UTC
* the workaround (see above) works only if the line end is plain (at least no
circle) -- otherwise even the converted callout (to polygone) has a too small
line width

* even if you have a plain line end there is another error when converting the
callout to polygone before exporting: the color of the labeling line is
forgotten (set to black) while the box aound the text keeps its color (e.g. red)
Comment 3 wolframgarten 2004-06-04 07:38:11 UTC
Reproducible. Reassigned to Sven. Please have a look.
Comment 4 wolframgarten 2004-06-04 07:38:26 UTC
Set to new.
Comment 5 wolframgarten 2004-06-04 07:39:00 UTC
Created attachment 15670 [details]
bugdoc
Comment 6 sven.jacobi 2005-05-23 16:14:01 UTC
accepted
Comment 7 bludovic69 2006-07-06 11:14:22 UTC
Seems to be linked with issues 18607 and 44747
Comment 8 bednar007 2007-10-20 09:15:58 UTC
Here I can see the same problem in OOo Draw 2.3. The problem has been reported 
in Issue 80189  but this one has been closed "Resolution: WORKSFORME" but NOT 
FOR ME. The problem is UNRESOLVED.