Issue 30158

Summary: incurrect alignment of Hebrew in RTL cells imported from excel
Product: Internationalization Reporter: sforbes <xslf>
Component: BiDiAssignee: frank
Status: CLOSED DUPLICATE QA Contact: issues@l10n <issues>
Severity: Trivial    
Priority: P3 CC: alan, issues
Version: 680m62Keywords: ms_interoperability
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 17513    
Issue Blocks:    
Attachments:
Description Flags
sample file
none
another example (there are many many of these)
none
The text falls off the page here due to this bug
none
another exmaple
none
another exmaple (notice the contents of one of the cells that seems to be hidden due to this)
none
text incorrectly displayed as strike-thrugh none

Description sforbes 2004-06-13 16:22:40 UTC
OOo 680m38, win 2003:

when importing the attached file from excel 2003 to calc, all the Hebrew text
lost it's alignment and is aligned to the left instead of to the right.

This is probably related to issue #17513 (which was marked WONTFIX, and that
users do ask about).
Comment 1 sforbes 2004-06-13 16:23:10 UTC
Created attachment 15869 [details]
sample file
Comment 2 sforbes 2004-06-13 16:42:51 UTC
Created attachment 15872 [details]
another example (there are many many of these)
Comment 3 sforbes 2004-06-13 17:13:20 UTC
Created attachment 15873 [details]
The text falls off the page here due to this bug
Comment 4 Dieter.Loeschky 2004-07-05 11:30:02 UTC
DL->OC: Could you please handle this?
Comment 5 oc 2004-07-05 15:05:22 UTC
Hi Falko, please recheck this and #i17513#
Comment 6 Unknown 2004-07-21 20:58:03 UTC
Please add keywords: ms_interoperability
Comment 7 sforbes 2004-11-25 21:28:44 UTC
Another exmaple, with m62:
Comment 8 sforbes 2004-11-25 21:29:56 UTC
Created attachment 19702 [details]
another exmaple
Comment 9 sforbes 2004-11-25 21:32:09 UTC
adding alan as cc
Comment 10 sforbes 2004-11-25 21:39:59 UTC
Created attachment 19703 [details]
another exmaple (notice the contents of one of the cells that seems to be hidden due to this)
Comment 11 sforbes 2004-11-25 22:08:44 UTC
Even worse example-- all the text incorrectly appears striked through, due to
thus bug.
Comment 12 sforbes 2004-11-25 22:09:29 UTC
Created attachment 19709 [details]
text incorrectly displayed as strike-thrugh
Comment 13 falko.tesch 2005-02-16 10:01:25 UTC
FT->FST: Can you please cross-check this issue? If this is a MS interoperabilty
bug please asssign it to the responsible developer. Thx.
Comment 14 oc 2005-02-16 11:53:04 UTC
This one is duplicate to #i37905#

*** This issue has been marked as a duplicate of 37905 ***
Comment 15 frank 2005-02-18 13:12:05 UTC
and closed now