Issue 3029

Summary: WW: Import form fields as input fields to get better layout
Product: Writer Reporter: hansel <hroush>
Component: codeAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: aidan.butler, caolanm, falko.tesch, issues, jens-uwe, oooqa, scarr
Version: 641Keywords: oooqa
Target Milestone: ---   
Hardware: Other   
OS: Linux, all   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description hansel 2002-02-08 20:59:12 UTC
Apparently the creator of the MS Word doc used some kind of text 
boxes that OpenOffice's import filters  can't interpret?

Send me an email  at hroush@largo.com requesting the MS Word file 
and I will send it to you.
Comment 1 Joost Andrae 2002-02-11 13:18:51 UTC
JA->MRU: reassigned to you
Comment 2 michael.ruess 2002-02-19 11:07:02 UTC
MRU->CMC: thereĀ“s a FormField which contains a lot of text. The filter
converts it to a very big Control which is wider than the page in
StarWriter. My questions/suggestions for this are:
1. Limit the width of such a control to page width or text area width
on import
2. enable the "line break" feature for such controls on import
What do you think about it?
Comment 3 michael.ruess 2002-02-19 11:07:46 UTC
added CC
Comment 4 caolanm 2002-02-19 12:07:13 UTC
It sounds like a reasonable idea to set the max width to the max
available width and to turn on multiline seeing as line breaks are
allowed in these word textfields. But there would still probably be a
lot of problems because we would still not know the correct height to
use for a multiline textfield. Figuring out how many word fit on a
line etc to get the number of lines and then guessing the fontsize to
calculate the controls true height would really require laying out the
document first. 

All these layout problems with these textfields is because our
controls are of fixed size, while those word fields are flexible in
length. I wonder what would happen if we used our input fields for
these instead ? Our controls are really like word's other form
controls, the vba controls, while our input field looks more like
these type of fields.  An input field is flexible in width as well so
the layout would be good. And all those problems of ugliness and hard
to format issues would then go away.

On the minus we would loose being able to support some of the "help"
options, but on the plus side I think we would be able to use some of
the "Type" information because we can make out input fields fill in
variables and allow only date/time/number etc, just like word.

Would there be any problems in changing the import of textform fields
from uno controls to input fields that I haven't thought of. I'd
prefer to attempt to import them as input fields that keep hacking
around the problems of the uno form controls.

Comment 5 michael.ruess 2002-02-25 14:03:44 UTC
'I think, we should invoke Falko into this "discussion".
Comment 6 michael.ruess 2002-02-25 14:36:50 UTC
I think, we should try out Caolan's proposal. I think, using our
"Inputfield" for import on Word's FormFields. This would better keep
the formatting of the document and does not affect the Document layout
so strong.
Comment 7 michael.ruess 2002-02-27 11:45:57 UTC
Reassigned to Falko for decision.
Comment 8 caolanm 2002-05-10 12:35:56 UTC
Retitle to make sense.
Comment 9 caolanm 2002-05-14 14:47:07 UTC
*** Issue 4851 has been marked as a duplicate of this issue. ***
Comment 10 caolanm 2002-06-25 10:19:01 UTC
*** Issue 4427 has been marked as a duplicate of this issue. ***
Comment 11 prgmgr 2002-07-21 17:02:14 UTC
*** Issue 6469 has been marked as a duplicate of this issue. ***
Comment 12 michael.ruess 2002-09-03 10:47:16 UTC
*** Issue 5379 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2002-09-03 10:48:46 UTC
Added Scott Carr to CC (because of his closed issue #5379.
Comment 14 prgmgr 2002-09-08 19:04:05 UTC
*** Issue 5654 has been marked as a duplicate of this issue. ***
Comment 15 mblevy 2002-09-15 03:11:57 UTC
What's the status on this issue?  No pressure, just curious.
Comment 16 prgmgr 2002-09-22 06:00:29 UTC
*** Issue 5978 has been marked as a duplicate of this issue. ***
Comment 17 falko.tesch 2002-10-21 06:04:27 UTC
If you consider this to be a feasible solution go ahaed :o)
Comment 18 falko.tesch 2002-10-21 06:04:50 UTC
If you consider this to be a feasible solution go ahaed :o)
Comment 19 caolanm 2002-10-21 10:28:31 UTC
(Evil laugh). The layout should improve using a flexible field which
is the no 1 complaint.
Comment 20 caolanm 2002-11-08 12:43:23 UTC
Fix checked in. Will work in SRX644l
Comment 21 caolanm 2002-11-13 09:34:52 UTC
cmc->mru: For consideration in SRX644l. Superior layout with input fields.
Comment 22 michael.ruess 2002-11-14 10:37:03 UTC
Yes, in 644L the new implemtation works fine.
input fields are now used for depicting "flexible" Formfields from Word.
Fix will be available with OpenOffice build 644.
Comment 23 michael.ruess 2002-11-14 10:44:00 UTC
*** Issue 9019 has been marked as a duplicate of this issue. ***
Comment 24 michael.ruess 2002-11-29 08:34:09 UTC
The change will take place in OpenOffice 1.1 Beta.
Comment 25 caolanm 2002-12-03 09:14:57 UTC
*** Issue 9779 has been marked as a duplicate of this issue. ***
Comment 26 michael.ruess 2003-01-23 10:11:17 UTC
*** Issue 10355 has been marked as a duplicate of this issue. ***