Issue 3348

Summary: Modified font effects not carried accross to Word
Product: Writer Reporter: osavill <osavill>
Component: uiAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: caolanm, issues
Version: 641   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description osavill 2002-03-05 11:43:12 UTC
The default font effect style for Heading2 and Heading3 are italicised (I 
think). I changed this to be "normal" text. I also applied a numbering style 
and made the font sizes different.

The document was then exported to Word format.

All the attributes were copied accross except for the font effect. When 
rendered in Word they were still in italics.
Comment 1 Joost Andrae 2002-03-05 13:25:36 UTC
JA->MRU: reasssigned to you...
Comment 2 michael.ruess 2002-03-05 15:58:57 UTC
MRU->cmc: is this a double to issue #3273?
Comment 3 osavill 2002-03-05 16:11:52 UTC
I don't think it is. My initial OR didn't make clear where OO 
fitted in and where Word fitted in ! So: 

The default font effect style for Heading2 and Heading3 are 
italicised (I think). I changed this to be "normal" text. I also 
applied a numbering style and made the font sizes different. 

The document was then exported to Word format AND OPENED IN WORD 
ITSELF. (not shouting just highlighting what I should have said !)

All the attributes were copied accross except for the font 
effect. When rendered in Word they were still in italics.

The document looked 100% fine when Reopened in OO.

Hope this clarifies.
Comment 4 caolanm 2002-03-05 16:21:25 UTC
No michael is almost certainly right. Its a duplicate, go to 
tool->options->languages and click to enable asian languages. Go back
and examine the paragraphs that you modified. You will have modified
the western font, not the asian font. 

The problem is that word has only one size/weight/posture
(size/bold/italic) for western and asian fonts, we have two. When the
two are different then in your version both are exported to the same
setting and asian is done after western, so you will always get the
asian font settings for the attributes which are both folded to one in
word. The workaround is to change the asian fontsize slant and weight
when changing the western.

In the next version the language of the text will be detected on
export and the attribute being used for that language will be exported
and the other ignored.
Comment 5 osavill 2002-03-05 16:27:21 UTC
Off Topic:
Any idea when the next binary version is going to be released ? Last 
I heared the dev.version was already at 652 but us users / testers 
are still using 641 ! The bug report page tantalisingly has a drop 
down to submit bugs with 642 but this is still ten versions behind 
the tip of the tree and any way is no where to be found !
Comment 6 osavill 2002-03-05 16:34:53 UTC
I concur that this is a duplicate of 3273 and your previous 
comments. Enabling Asian fonts and adjusting all the used style 
accordingly rectified the observed problem.
Comment 7 michael.ruess 2002-03-06 10:07:42 UTC
This issue is now resolved as duplicate.
The release of OO 642 could be somehow this month, I think.

*** This issue has been marked as a duplicate of 3273 ***
Comment 8 michael.ruess 2002-11-29 09:44:59 UTC
Should be included in 643c.